SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0001204: openvpn: needs upgrade to 2.1_rc11 - MantisBT
MantisBT - Endian Firewall
View Issue Details
0001204Endian FirewallSecuritypublic2008-08-05 10:582009-10-27 12:00
peter-endian 
peter-endian 
normalminorhave not tried
closedfixed 
2.2-rc2 
2.32.3 
0001204: openvpn: needs upgrade to 2.1_rc11
needs upgrade to 2.1_rc11
No tags attached.
Issue History
2008-08-05 10:58peter-endianNew Issue
2008-08-06 13:47peter-endianStatusnew => resolved
2008-08-06 13:47peter-endianFixed in Version => 2.2-rc3
2008-08-06 13:47peter-endianResolutionopen => fixed
2008-08-06 13:47peter-endianAssigned To => peter-endian
2008-08-06 13:47peter-endianNote Added: 0001508
2008-08-20 10:53peter-endianNote Added: 0001527
2008-08-20 10:53peter-endianStatusresolved => assigned
2008-08-25 14:42peter-endianTarget Version2.2-rc3 => 2.3
2008-09-10 09:32peter-endianNote Added: 0001592
2008-09-10 16:20chris-endianSummaryopenvpn: needs upgrade to 2.1_rc9 => openvpn: needs upgrade to 2.1_rc10
2008-09-10 16:20chris-endianDescription Updated
2008-09-16 09:52peter-endianSummaryopenvpn: needs upgrade to 2.1_rc10 => openvpn: needs upgrade to 2.1_rc11
2008-09-16 09:52peter-endianDescription Updated
2008-09-16 09:52peter-endianNote Added: 0001624
2008-10-10 21:49johnwangNote Added: 0001685
2008-10-10 21:49johnwangNote Added: 0001686
2008-10-10 21:49johnwangStatusassigned => feedback
2008-10-10 21:52johnwangNote Deleted: 0001686
2008-10-10 22:00johnwangNote Edited: 0001685
2008-10-13 09:59peter-endianNote Added: 0001693
2009-05-27 09:26peter-endianStatusfeedback => resolved
2009-05-27 09:26peter-endianFixed in Version2.2-rc3 => 2.3
2009-10-27 12:00peter-endianStatusresolved => closed

Notes
(0001508)
peter-endian   
2008-08-06 13:47   
Thanks to Thomas Wouters for the upgraded SRPM
(0001527)
peter-endian   
2008-08-20 10:53   
openvpn configuration file needs to be changed:

script-security 3

need to be added in configuration templates of efw-vpn and efw-vpnclient
(0001592)
peter-endian   
2008-09-10 09:32   
upgrade to 2.1_rc10, that should fix the execv() issues on spawning a script.
adding script-security is still needed!
(0001624)
peter-endian   
2008-09-16 09:52   
This release fixes a serious (though not security-related) bug in the
SSL/TLS negotiation over UDP that can cause SSL/TLS handshake failures.
  The bug was introduced in 2.1_rc9.

All users of OpenVPN 2.1_rc9 and rc10 are urged to upgrade.
(0001685)
johnwang   
2008-10-10 21:49   
(edited on: 2008-10-10 22:00)
Is there any instruction on how to update the OpenVPN to 2.1rc11 or even rc13? The Endian 2.2rc3 firewall is still using OpenVPN 2.1rc7. There seem to be some bugs fixed from rc7 to rc10 or newer. I really want to upgrade it.

Thank you.

(0001693)
peter-endian   
2008-10-13 09:59   
As long as they (openvpn team) continue to release rc versions i would not upgrade. From rc7 to rc8 they changed behaviour which needs us to change the configuration template. I would wait until it gets stable enough, then we will change those configuration parameters.