SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0000231: Multi port nic's interfaces not displayed in network setup wizard (efw 2.1.2) - MantisBT
MantisBT - Endian Firewall
View Issue Details
0000231Endian FirewallGUIpublic2007-08-02 06:152007-10-27 18:58
clubbing80s 
raphael-endian 
normalmajoralways
closedfixed 
2.1 
2.2-beta1 
0000231: Multi port nic's interfaces not displayed in network setup wizard (efw 2.1.2)
When I installed a "D-Link DFE-580 4-Port Server Card", the network setup wizard did not display any of the interfaces just a list green, red, and orange, and blank spaces there the interfaces should be listed , thus can not assign, ip's to interfaces etc.
 
No tags attached.
related to 0000234closed  No Support for the IntelĀ® 82562 Fast Ethernet Controllers 
related to 0000197closed raphael-endian Ethernet NIC drivers isn't find! 
related to 0000110closed raphael-endian Not all Nic's vissible in web interface 
related to 0000223closed  Nvidia chipset - network interface is not added 
txt dlink.txt (17,800) 2007-08-06 14:54
https://bugs.endian.com/file_download.php?file_id=42&type=bug
txt kudzu.txt (6,127) 2007-08-28 14:33
https://bugs.endian.com/file_download.php?file_id=46&type=bug
txt lspci.txt (1,710) 2007-08-28 14:33
https://bugs.endian.com/file_download.php?file_id=47&type=bug
? ethconfig-debug (12,110) 2007-09-04 10:28
https://bugs.endian.com/file_download.php?file_id=48&type=bug
? ethconfig-debug-output (8,533) 2007-09-04 11:04
https://bugs.endian.com/file_download.php?file_id=49&type=bug
patch ethconfig.patch (314) 2007-09-06 14:33
https://bugs.endian.com/file_download.php?file_id=50&type=bug
? ethconfig-0.7-1.endian4.i386.rpm (6,624) 2007-09-07 09:23
https://bugs.endian.com/file_download.php?file_id=51&type=bug
Issue History
2007-08-02 06:15clubbing80sNew Issue
2007-08-06 14:26chhaasNote Added: 0000416
2007-08-06 14:26chhaasNote Added: 0000417
2007-08-06 14:26chhaasStatusnew => confirmed
2007-08-06 14:26chhaasNote Deleted: 0000416
2007-08-06 14:34raphael-endianStatusconfirmed => assigned
2007-08-06 14:34raphael-endianAssigned To => raphael-endian
2007-08-06 14:35raphael-endianNote Added: 0000418
2007-08-06 14:36raphael-endianStatusassigned => feedback
2007-08-06 14:54chhaasFile Added: dlink.txt
2007-08-06 14:55chhaasNote Added: 0000425
2007-08-10 11:25chhaasStatusfeedback => confirmed
2007-08-28 14:33clubbing80sFile Added: kudzu.txt
2007-08-28 14:33clubbing80sFile Added: lspci.txt
2007-08-28 14:35clubbing80sNote Added: 0000450
2007-08-28 14:52clubbing80sNote Added: 0000451
2007-08-28 14:58clubbing80sNote Edited: 0000451
2007-08-28 14:58clubbing80sNote Edited: 0000451
2007-08-28 15:24chhaasNote Added: 0000452
2007-08-28 15:30peter-endianNote Added: 0000453
2007-08-28 15:36chhaasNote Added: 0000454
2007-08-29 06:00clubbing80sNote Added: 0000455
2007-08-29 06:15clubbing80sNote Edited: 0000455
2007-08-29 06:16clubbing80sNote Edited: 0000455
2007-08-29 09:13peter-endianNote Added: 0000456
2007-08-29 10:19chhaasNote Added: 0000457
2007-08-29 10:20chhaasNote Edited: 0000457
2007-08-29 10:20chhaasNote Edited: 0000457
2007-08-29 10:50peter-endianNote Added: 0000458
2007-09-04 10:28raphael-endianFile Added: ethconfig-debug
2007-09-04 10:30raphael-endianNote Added: 0000469
2007-09-04 11:04clubbing80sFile Added: ethconfig-debug-output
2007-09-04 11:05clubbing80sNote Added: 0000470
2007-09-05 09:13raphael-endianNote Added: 0000473
2007-09-05 10:35clubbing80sNote Added: 0000474
2007-09-05 13:41raphael-endianNote Added: 0000475
2007-09-06 14:33raphael-endianFile Added: ethconfig.patch
2007-09-06 14:49raphael-endianNote Added: 0000476
2007-09-06 14:54raphael-endianRelationship addedrelated to 0000234
2007-09-06 15:06raphael-endianRelationship addedrelated to 0000197
2007-09-06 17:09raphael-endianNote Added: 0000484
2007-09-07 09:23raphael-endianFile Added: ethconfig-0.7-1.endian4.i386.rpm
2007-09-07 09:27raphael-endianNote Added: 0000485
2007-09-07 09:27raphael-endianStatusconfirmed => resolved
2007-09-07 09:27raphael-endianResolutionopen => fixed
2007-10-27 18:58peter-endianStatusresolved => closed
2007-10-27 18:58peter-endianFixed in Version => 2.2
2007-10-27 20:31peter-endianRelationship addedrelated to 0000110
2007-10-27 20:46peter-endianRelationship addedrelated to 0000223

Notes
(0000417)
chhaas   
2007-08-06 14:26   
I can confirm this behaviour. But the DLink DFE-580TX NIC is found during the boot-process as "MI PHY". Also MAC- and I/O-addresses and IRQs are detected correctly.
But if it comes to th "endian-stage" of the boot-process the 4 NICs are only found as 4 times "Businfo: n/a, Model: n/a and Driver: n/a n/a" :-(

very strange!
Christoph.
(0000418)
raphael-endian   
2007-08-06 14:35   
Please send us the output of "kudzu -p" and "lspci -v", this way we can inspect the problem.
(0000425)
chhaas   
2007-08-06 14:55   
Hi Raphael,

as you can see in the output of "lspci" 4 NICs of the type "Ethernet controller: D-Link System Inc DL10050 Sundance Ethernet (rev 14)" were found ...

Cheers
Christoph.
(0000450)
clubbing80s   
2007-08-28 14:35   
Hi
Sorry for the late response.. I have uploaded the results from kudzu -p and lspci .. I hope these will assist, I would like to have ago at resolving this, where do I start ?

Many thanks
Greg
(0000451)
clubbing80s   
2007-08-28 14:52   
(edited on: 2007-08-28 14:58)
ok i have been poking around .. lol and if i run /usr/sbin/ethconfig --update the nics appear in the gui.. if i run /usr/sbin/ethconfig --apply -f .. they are lost again .. if i run /usr/sbin/ethconfig --update --apply -f they are still lost ...
 Then I ran /usr/sbin/ethconfig --update and configured the interfaces, but when I went through the wizard again the cards where not displayed .. but if i run ifconfig it looks as if the ip's have been correctly assigned ..

hope this helps

(0000452)
chhaas   
2007-08-28 15:24   
Hi clubbing80s,

very interesting, but for me in the meantime also another problem occured: how can I configure more than 4 NICs in the GUI?

Since no solution came up with the 4-port NICs, I have put for testing purposes five 3C905C network cards, which have all been detected by the webinterface.

But my fifth NIC was automatically marked as a second GREEN interface and I had no possibility to configure anything for this interface - no chance to set IP-address or netmask.

How can I configure the efw 2.1 community release for:
1 LAN (green), 1 WAN (red) and 3 DMZs?

In the webinterface I can configure:
- green (LAN)
- red (WAN)
- _1_ DMZ (orange)
- and _1_ WiFi interface.
The 5th interface is automatically marked also as green interface and
cannot be configured (IP-address and netmask).

But there must be a way to configure more than 4 NICs, since the Macro
and Macro X2 appliance have _7_ NICs ...

I'd thought I could replace my existing Firewall with a Endian Commercial solution.

But since I run into so much trouble with testing, I doubt this aint a good idea at the moment... - very sad :-((

Cheers
Christoph.
(0000453)
peter-endian   
2007-08-28 15:30   
can you please post the output of:
ethtool -i eth0
ethtool -i eth1
ethtool -i eth2
ethtool -i eth3

(or whatever ethX the dlink cards are)
probably they will not be supported by this tool. if so, it will give an error

furthermore, please post the file /etc/businfotab


the file should contain pci ids, like this:
eth0 01:04.0
eth1 01:05.0

that file establish the relationship between pci id (reported by ethtool) and the eth device name. the same pci id's should be reported by lspci and link to the manufacturer and model name of the device.
(0000454)
chhaas   
2007-08-28 15:36   
Hi clubbing80s,

could you please answer Peters request? I have at the moment the DLINK changed for 5 single NICs.

@Peter:
is there somewhere a solution for the above mentioned problem with more than 4 NICs?

Cheers
Christoph.
(0000455)
clubbing80s   
2007-08-29 06:00   
(edited on: 2007-08-29 06:16)
hi
I currenty have the dlink 4 port and another single port nic

root@efw-1188316543:~ # ethtool -i eth0 ; ethtool -i eth1 ; ethtool -i eth2 ; ethtool -i eth3 ; ethtool -i eth4
driver: dmfe ### single port
version: 1.36.4
firmware-version:
bus-info: 0000:01:06.0

driver: sundance ### multi port
version: 1.01+LK1.09a
firmware-version:
bus-info: 0000:02:04.0

driver: sundance ### multi port
version: 1.01+LK1.09a
firmware-version:
bus-info: 0000:02:05.0

driver: sundance ### multi port
version: 1.01+LK1.09a
firmware-version:
bus-info: 0000:02:06.0

driver: sundance ### multi port
version: 1.01+LK1.09a
firmware-version:
bus-info: 0000:02:07.0

root@efw-1188316543:~ # cat /etc/businfotab
# Generated by ethconfig
eth0 01:06.0
eth1 n/a
eth2 n/a
eth3 n/a
eth4 n/a

"I'd thought I could replace my existing Firewall with a Endian Commercial solution.

But since I run into so much trouble with testing, I doubt this aint a good idea at the moment... - very sad :-(( "

mmm yes chhaas .. some times I feel we'r here just for finding the bugs .. I do understand why some of the features in the commercial version are not avalible in the os version.. but to be honest the quality of the os version is poor .. and i feel this has lost efw a lot of potential users, both for the os and comm ver .. Also the guys seem very close on giving info that would speed up the debugging process .. I we knew more ... we could give more back !!!!

(0000456)
peter-endian   
2007-08-29 09:13   
thank you clubbing80s
this must be a bug in ethconfig. i try to reproduce it with your information

@chhaas:
currently endian firewall community has only the possibility to assign multiple interfaces to the various zones. you can have 1 subnet on each of the zones.
if you assign multiple zones they will be joined together to a bridge, which makes the firewall then act like a switch for those ports.

next version (endian firewall 2.2) can handle multiple subnets per zone and has a zone filtering firewall (dmzholes), with which you can also filter between interfaces of the same zone, which in fact then turns 1 DMZ into 3 if you assigned 3 interfaces to it.

since now with 2.1.x versions this is only possible by configuring it manually.
(0000457)
chhaas   
2007-08-29 10:19   
(edited on: 2007-08-29 10:20)
Hi Peter,

thank you for your answer! Sorry for hijacking this bugreport...

- For what time is release of the efw 2.2-community with the mentioned features planned?

- since I probably want to buy a efw-appliance (Macro X2), I'd like to know, if the limitations for the efw 2.1-community release regarding the NICs/subnets and zones, applies also to this commercial product? This is for me really essential ...

Cheers
Christoph.

(0000458)
peter-endian   
2007-08-29 10:50   
> For what time is release of the efw 2.2-community with the mentioned features planned?

release of 2.2 community is scheduled for end of september. an alpha will probably be released before.


> since I probably want to buy a efw-appliance (Macro X2), I'd like to know, if > the limitations for the efw 2.1-community release regarding the NICs/subnets
> and zones, applies also to this commercial product? This is for me really
> essential ...

This limitation also exists for the enterprise 2.1 versions, but it is possible to configure this manually, which we already did for some customers and it's working fine.
The enterprise 2.2 certainly will come with this features included. With valid maintainance an enterprise 2.1 can be updated through Endian Network without extra fees to the 2.2.

If you have further questions please contact our sales staff at sales@endian.com
(even though it would make me proud as a developer to sell an appliance through my bug tracker)
(0000469)
raphael-endian   
2007-09-04 10:30   
I need some further info to track down the problem. I've attached a script "ethconfig-debug" that generates some debugging output, please copy it to your firewall, run it and send us the output.

This way we can solve the bug very quickly, thanks for your help.
(0000470)
clubbing80s   
2007-09-04 11:05   
I have posted the output in ethconfig-debug-output
(0000473)
raphael-endian   
2007-09-05 09:13   
Hmmm, this bug seems to be very nasty :) It's really hard to reproduce, the ethconfig-debug output is ok. It seems to be a timing bug related to the D-Link card.

We use ethtool to gather information about network cards, and if you get "n/a" it means that at this point ethtool return some invalid data, it's very strange. It works with all the network cards we have in our lab (Realtek, Intel, etc.).

The strange thing is that DLink seem to sometimes return valid ethtool responses (like in your debug output) and sometimes not. I don't think it'a a ethconf related bug... we have to find the reason why ethtool sometimes doesn't return valid data.

You wrote that "ethconf --update" fixes /etc/businfotab (pci ids instead of n/a), and "ethconf --apply -f" messes it up again. So we need further information about what happens when this command is run.
(0000474)
clubbing80s   
2007-09-05 10:35   
Hi what infomation do you need ? so I can give you the correct info ? would it help if i gave the server a live ip so you could access it ?
(0000475)
raphael-endian   
2007-09-05 13:41   
It would be great if you can give me access to the machine. Please send the access info to raphael (at) endian.com

Thanks
(0000476)
raphael-endian   
2007-09-06 14:49   
Finally with the precious help of clubbing80s (thanks a lot! :) i've found the "bug". It's related to some crappy NIC drivers (like the DLink one ;) that don't support querying with ethtool while the interface is down.

I've submitted a patch "ethconfig.patch", to apply it copy the file to your firewall through ssh, winscp (or whatever you like :) and run the following commands:
cd /usr/sbin
patch < your_path/ethconfig.patch

Then reboot the machine. After that everything should be working.

Please give us some feedback if it worked :)
(0000484)
raphael-endian   
2007-09-06 17:09   
Ooops, i've noticed that there is no "patch" utility on the efw default installation :)

Just use your favourite editor (nano or vi) and edit /usr/sbin/ethconfig manually removing the following line containing "updateBusinfotab(filename)":

---
  def setup(filename):
     print "* Setting up network interfaces"
 
>>> updateBusinfotab(filename)
     mactab = getBusinfotab(filename)
     (cardinfo, tabuifaces) = getCardInfo()

---

This should difinitely work ;)
(0000485)
raphael-endian   
2007-09-07 09:27   
Finally i've added some extra code that solves the problem and rebuilt the ethconfig rpm. To install it download the attached "ethconfig-0.7-1.endian4.i386.rpm" copy it to your firewall (use scp or winscp, etc.) and run:

rpm -Uhv <yourpath>/ethconfig-0.7-1.endian4.i386.rpm
ethconfig -u

After that you can open the Network Wizard on the Web-Interface and start enjoying Endian Firewall :)