SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0002358: Authentication fails on pppoe uplink if password contains "!" - MantisBT
MantisBT - Endian Firewall
View Issue Details
0002358Endian FirewallInput Validationpublic2009-11-03 09:552010-09-21 19:08
jimbolina22 
 
normalminoralways
confirmedopen 
 
 
0002358: Authentication fails on pppoe uplink if password contains "!"
On my first install of efw, (fine product btw ;)) I could not get my pppoe connection to work. The logs were reporting authentication failures.

I was certain the password was correct as it was working when the modem/router was in router mode instead of bridge mode so I changed it with my ISP and all I removed was the exclamation point (!). The authentication then succeeded.

This may be the case with other special characters and I'd love to test but I'm in enough trouble for the downtime as it is :P
No tags attached.
Issue History
2009-11-03 09:55jimbolina22New Issue
2010-02-04 10:13peter-endianRelationship addedrelated to 0002653
2010-02-04 10:13peter-endianStatusnew => confirmed
2010-09-21 19:08peter-endianCategoryNetwork related (VPN, uplinks) => Input Validation

There are no notes attached to this issue.