SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0002404: Proxy HTTP - MantisBT
MantisBT - Endian Firewall
View Issue Details
0002404Endian FirewallProxy HTTPpublic2009-11-11 12:472010-11-22 12:06
murtaza 
simon-endian 
normalmajoralways
closedfixed 
2.3 
2.3.12.3.1 
0002404: Proxy HTTP
Transparent HTTP Proxy does not work
No tags attached.
duplicate of 0002419closed simon-endian Transparent Http Proxy 
related to 0002393closed simon-endian Havp service not running 
has duplicate 0002397closed simon-endian Transparent Proxy 
jpg http-proxy.JPG (30,817) 2009-11-22 09:56
https://bugs.endian.com/file_download.php?file_id=308&type=bug
jpg

jpg squid_error.JPG (77,734) 2009-12-02 06:42
https://bugs.endian.com/file_download.php?file_id=311&type=bug
jpg
Issue History
2009-11-11 12:47murtazaNew Issue
2009-11-12 11:34arcanosNote Added: 0003296
2009-11-15 10:35murtazaNote Added: 0003302
2009-11-22 00:39davviddeNote Added: 0003335
2009-11-22 00:41davviddeNote Edited: 0003335
2009-11-22 00:50davviddeNote Edited: 0003335
2009-11-22 09:56murtazaFile Added: http-proxy.JPG
2009-11-22 09:59murtazaNote Added: 0003336
2009-11-22 14:51davviddeNote Added: 0003337
2009-11-24 06:46murtazaNote Added: 0003342
2009-11-25 10:11christian-endianRelationship addedchild of 0002435
2009-11-25 10:11christian-endianAssigned To => simon-endian
2009-11-25 10:11christian-endianStatusnew => acknowledged
2009-11-25 17:36peter-endianTarget Version => 2.3.1
2009-11-26 16:51simon-endianRelationship addedrelated to 0002300
2009-11-26 16:53simon-endianRelationship deletedrelated to 0002300
2009-11-26 16:55simon-endianRelationship addedduplicate of 0002419
2009-11-26 16:56simon-endianRelationship addedhas duplicate 0002397
2009-11-26 18:32simon-endianNote Added: 0003408
2009-11-26 18:32simon-endianRelationship addedrelated to 0002393
2009-11-26 18:37simon-endianStatusacknowledged => feedback
2009-11-27 16:02davviddeNote Added: 0003429
2009-12-02 06:42murtazaFile Added: squid_error.JPG
2009-12-02 06:43murtazaNote Added: 0003490
2009-12-02 06:44murtazaNote Edited: 0003490
2009-12-02 06:47murtazaNote Edited: 0003490
2010-02-02 12:15luca-endianStatusfeedback => confirmed
2010-02-03 19:49aenderNote Added: 0003735
2010-02-08 15:10aenderNote Added: 0003752
2010-02-15 06:35simon-endianNote Added: 0003780
2010-02-15 06:35simon-endianStatusconfirmed => resolved
2010-02-15 06:35simon-endianFixed in Version => 2.3.1
2010-02-15 06:35simon-endianResolutionopen => fixed
2010-11-22 12:06peter-endianStatusresolved => closed

Notes
(0003296)
arcanos   
2009-11-12 11:34   
Please, could you check if you have this files?:

/var/efw/havp/blacklist
/var/efw/havp/whitelist

I had this issue once (those files were missing), just to check if it could be the same issue.

If you don't have that files, please do...

touch /var/efw/havp/blacklist
touch /var/efw/havp/whitelist
chown nobody: /var/efw/havp/blacklist
chwon nobody: /var/efw/havp/whitelist

... restart proxy and try again to access internet.
(0003302)
murtaza   
2009-11-15 10:35   
I check those file, it was not there

So i followed the step given and restart the proxy but still transparent proxy is not working.

Plzz. help
(0003335)
davvidde   
2009-11-22 00:39   
(edited on: 2009-11-22 00:50)
I have the same problem: havp antivirus does not start when I modify the default profile (content1). the issue is because the files /var/efw/havp/blacklist and /var/efw/havp/whitelist are not present. After create them and the permission modified, run "/etc/init.d/havp start" so the HTTP antivirus should start and the proxy should work.
This problem is in place even in "not transparent" proxy mode.
Anyone know why these files are not created at EFW installation or when havp starts for the first time?

(0003336)
murtaza   
2009-11-22 09:59   
Thanks..

But the performing the above steps i change the http proxy from not transparent to Transparent mode.

But as soon as i apply settings it keeps on saying READING SQUID SETTINGS and not going further. Even after rebooting the firewall it appears the same

 I had also attached screenshot for the reference..

Anyone know how to get rid of this ?
(0003337)
davvidde   
2009-11-22 14:51   
Try to disable HTTP antivirus in the profile you use and restart the proxy.
(0003342)
murtaza   
2009-11-24 06:46   
I did that but again the same issue its taking long for READING SQUID SETTINGS.
and also even though HTTP service is running but on the dashboard is showing OFF
(0003408)
simon-endian   
2009-11-26 18:32   
this happens when the restartsquid script fails, because the notification service is not stopped.

can you give me more information about your configuration:

does this only happen with transparent enabled on a zone?
did you recover from a 2.2 backup?
can you confirm that /var/efw/havp/whitelist, /var/efw/havp/blacklist, /etc/havp/whitelist, /etc/havp/blacklist are not created? (remove them and then run restarsquid.py and check if they where created)
(0003429)
davvidde   
2009-11-27 16:02   
I made a fresh installation of efw 2.3 then I restored a 2.2 backup. When I realized that the backup was not working in 2.3 I restored to factory default from the console.
The problem was happened immediately the first time I reconfigure manually the proxy service from GUI in not transparent proxy mode.
(0003490)
murtaza   
2009-12-02 06:43   
(edited on: 2009-12-02 06:47)
I had also done fresh installation of efw 2.3. And as you said i had remove the file blacklist and whitelist and run the command restartsquid.py. but the above files are not created by itself and giving me error message.

I had attached the screenshot for your reference

(0003735)
aender   
2010-02-03 19:49   
The same problem here.

For me the first solution worked:

touch /var/efw/havp/blacklist
touch /var/efw/havp/whitelist
chown nobody: /var/efw/havp/blacklist
chown nobody: /var/efw/havp/whitelist
(0003752)
aender   
2010-02-08 15:10   
At the moment HTTP Proxy works.

But the Access Policys at the HTTP Proxy still not works.
(0003780)
simon-endian   
2010-02-15 06:35   
/var/efw/havp/*list files were not created when /etc/havp/*list links existed but /var/efw/havp/*list files not