SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0002485: Dashboard doesn't show up VLAN rx & tx speed - MantisBT
MantisBT - Endian Firewall
View Issue Details
0002485Endian FirewallGUIpublic2009-12-04 17:412010-11-22 12:06
mrkroket 
simon-endian 
normalminoralways
closedfixed 
2.3 
2.3.12.3.1 
0002485: Dashboard doesn't show up VLAN rx & tx speed
VLAN in and out transmission speeds always appears on blank.
Tested on both a virtual and a physical machine, on 3 browsers:
 -Firefox
 -IE8
 -Opera

All have the same behaviour. Dashboard shows in & out speed of any interface except for VLANs
purple
Issue History
2009-12-04 17:41mrkroketNew Issue
2009-12-04 17:53mrkroketNote Added: 0003513
2009-12-07 17:57peter-endianAssigned To => simon-endian
2009-12-07 17:57peter-endianStatusnew => confirmed
2009-12-07 17:57peter-endianTarget Version => 2.3.1
2010-01-27 16:54luca-endianTag Attached: purple
2010-02-15 04:08simon-endianNote Added: 0003779
2010-02-15 04:08simon-endianStatusconfirmed => resolved
2010-02-15 04:08simon-endianFixed in Version => 2.3.1
2010-02-15 04:08simon-endianResolutionopen => fixed
2010-11-22 12:06peter-endianStatusresolved => closed

Notes
(0003513)
mrkroket   
2009-12-04 17:53   
It seems that the problem is in /home/httpd/html/include/dashboard.js at line [33]
To detect a NIC, the script uses a regexp:
         var nic_regex = /interface\/if_octets\-([a-z0-9]+)/;
That works fine with almost all interfaces, but not with vlan ones. VLANS have a dot (eth0.20), so the above regexp will never match. Changing to
         var nic_regex = /interface\/if_octets\-([\.a-z0-9]+)/;

Seems to correct the problem. Anyways that doesn't work on IE8, I don't know why. But it correctly shows both on Opera and Firefox
(0003779)
simon-endian   
2010-02-15 04:08   
tested and applied solution mentioned by mrkroket