SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0002818: gui says "some error" on QoS - MantisBT
MantisBT - Endian Firewall
View Issue Details
0002818Endian FirewallQoSpublic2010-04-06 13:442012-05-15 22:43
luca-endian 
peter-endian 
urgentmajorhave not tried
confirmedopen 
2.3 
future 
0002818: gui says "some error" on QoS
When I add or modify a QOS Rule, i have the message 'some error' that appear under 'TOS/DSCP' see the screenshot
purple
child of 0003045confirmed peter-endian TODO: QoS rework - QoS collecting ticket 
png 31-03-2010 10-26-38.png (54,120) 2010-04-06 13:44
https://bugs.endian.com/file_download.php?file_id=385&type=bug
png

jpg QoS devices.jpg (139,841) 2010-05-04 17:29
https://bugs.endian.com/file_download.php?file_id=407&type=bug
jpg

jpg QoS Classes.jpg (149,617) 2010-05-04 17:30
https://bugs.endian.com/file_download.php?file_id=408&type=bug
jpg

jpg Some Error.jpg (160,024) 2010-05-04 17:30
https://bugs.endian.com/file_download.php?file_id=409&type=bug
jpg

png 80599.png (86,196) 2010-06-30 12:27
https://bugs.endian.com/file_download.php?file_id=460&type=bug
png
Issue History
2010-04-06 13:44luca-endianNew Issue
2010-04-06 13:44luca-endianFile Added: 31-03-2010 10-26-38.png
2010-04-06 13:45luca-endianTag Attached: purple
2010-04-06 16:19peter-endianNote Added: 0004114
2010-04-06 16:19peter-endianStatusnew => feedback
2010-05-04 17:29baldyNote Added: 0004226
2010-05-04 17:29baldyFile Added: QoS devices.jpg
2010-05-04 17:30baldyFile Added: QoS Classes.jpg
2010-05-04 17:30baldyFile Added: Some Error.jpg
2010-05-05 09:20peter-endianNote Added: 0004229
2010-05-05 09:20peter-endianStatusfeedback => confirmed
2010-05-05 09:20peter-endianTarget Version => future
2010-06-30 12:27luca-endianFile Added: 80599.png
2010-06-30 12:49aenderNote Added: 0004573
2010-07-05 16:40peter-endianRelationship addedchild of 0003045
2010-09-17 01:06maximNote Added: 0004730
2010-09-17 01:15maximNote Added: 0004731
2010-09-20 17:24peter-endianCategoryOther Scripts => QoS
2011-01-27 08:41Tikle DestekNote Added: 0005532
2011-01-27 08:42Tikle DestekNote Edited: 0005532
2011-02-03 14:53lorenzo-endianCustomer Occurencies => 0
2011-02-03 14:53lorenzo-endianAssigned To => peter-endian
2011-02-11 14:19ardit-endianCustomer Occurencies0 => 4-6
2011-02-14 11:54luca-endianCustomer Occurencies4-6 => 7-10
2011-02-22 11:48luca-endianNote Added: 0005739
2011-03-18 11:27mgabrielNote Added: 0005993
2011-08-04 10:07ardit-endianPrioritynormal => urgent
2011-08-04 10:07ardit-endianSeverityminor => major
2012-05-15 22:43LyveNote Added: 0007870

Notes
(0004114)
peter-endian   
2010-04-06 16:19   
does not happen to me.
is the system up-to-date?

can you try the same on another installation?
(0004226)
baldy   
2010-05-04 17:29   
I have the same issue. Tried to define a QoS rule allowing <ALL> under service.Protocol TCP&UDP and ports 0:65535 are selected by default.

I think that in this case the port range is where the error message comes from.

I have also defined a Q0S rule allowing <ANY> which can be created successfully.

Screenprints are added.
(0004229)
peter-endian   
2010-05-05 09:20   
did not manage to reproduce both of those issues, i tried with the same input parameters.

however i managed it to get the same error using an invalid mac address.


i think those 2 issues are already fixed and fixes will be released soon.
however, the real problem is the expressionless error message which we should turn in something which really explains what is wrong.
(0004573)
aender   
2010-06-30 12:49   
Why target version "future"

QoS is a feature that should work since 2.3 !!
And 2.3 is an 8 month old version....
At the moment QoS is not useable and a working QoS seems to be far away.

Can Endian give us any status information for a working QoS Release Date?
(0004730)
maxim   
2010-09-17 01:06   
This issue has been around since 2.3 RCs. It was the reason that I updated to 2.4. Is there a way that I can see some sort of LOG which would indicate what the issue is?
(0004731)
maxim   
2010-09-17 01:15   
I found this thread here: http://efwsupport.com/index.php?topic=1807.0 [^]

Using a different brower (Opera) on Windows it works fine.
(0005532)
Tikle Destek   
2011-01-27 08:41   
(edited on: 2011-01-27 08:42)
Same thing here.
Got "some error" with Google Chrome, Works fine with Mozilla Firefox.
Version 2.4.1

(0005739)
luca-endian   
2011-02-22 11:48   
Seems to be a problem with Google Chrome.. possible?
(0005993)
mgabriel   
2011-03-18 11:27   
this is a problem with google chrome and safari - both use the webkit engine afaik. it works with firefox.

I can confirm the problem since endian 2.3 on mac/safari and windows/chrome.
(0007870)
Lyve   
2012-05-15 22:43   
Works fine for me with Mozilla Firefox but fails both in Chrome and IE8