SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0003130: Change user ncsa password does not work - MantisBT
MantisBT - Endian Firewall
View Issue Details
0003130Endian FirewallProxy HTTPpublic2010-09-02 09:492011-02-10 11:16
smai 
Anonymous 
normalmajoralways
closedfixed 
2.4 
2.4 
0003130: Change user ncsa password does not work
I have added users in the local user database. When the user change the password he become a message "user does not exists".

The ticket with id 0003083 has the same problem. The problem was fixed in version 2.4. Does not right, i use the v 2.4 and i have the same issue.
No tags attached.
gif error.gif (10,456) 2010-09-02 09:49
https://bugs.endian.com/file_download.php?file_id=480&type=bug
gif
Issue History
2010-09-02 09:49smaiNew Issue
2010-09-02 09:49smaiFile Added: error.gif
2010-09-03 06:57NinNinNote Added: 0004706
2010-09-03 06:58NinNinNote Edited: 0004706
2010-09-03 09:08AnonymousNote Added: 0004707
2010-09-03 09:08AnonymousStatusnew => resolved
2010-09-03 09:08AnonymousResolutionopen => fixed
2010-09-03 09:08AnonymousAssigned To => Anonymous
2010-09-19 16:31AnonymousNote Added: 0004741
2010-09-19 16:31AnonymousStatusresolved => feedback
2010-09-19 16:31AnonymousResolutionfixed => reopened
2011-02-10 10:27ra-endianNote Deleted: 0004741
2011-02-10 11:16lorenzo-endianNote Added: 0005661
2011-02-10 11:16lorenzo-endianStatusfeedback => closed
2011-02-10 11:16lorenzo-endianResolutionreopened => fixed
2011-02-10 11:16lorenzo-endianFixed in Version => 2.4

Notes
(0004706)
NinNin   
2010-09-03 06:57   
(edited on: 2010-09-03 06:58)
vi /home/httpd/cgi-bin/chpasswd.cgi <enter>

find the line

my $userdb = "$swroot/proxy/ncsauser"

change to

my $userdb = "$swroot/proxy/ncsausers"

save and try again.

(0004707)
Anonymous   
2010-09-03 09:08   
The problem is fixed.
(0005661)
lorenzo-endian   
2011-02-10 11:16   
Hi smai,

the problem does not exists in the newer versions :-)

Just update your system and feel free to reopen this bug if the problem still exists.

Have a nice day and thanks a lot for reporting this issue!

Lo