SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0003293: 2.4.1 Proxy HTTP not work with AD authentication - MantisBT
MantisBT - Endian Firewall
View Issue Details
0003293Endian FirewallProxy HTTPpublic2010-11-12 11:362012-11-07 04:47
NarinNil 
simon-endian 
normalmajorhave not tried
feedbackreopened 
2.4 
2.4.1 
0003293: 2.4.1 Proxy HTTP not work with AD authentication
After efw-upgrade to 2.4.1 it's can joined domain
can see list of gropu and user on active directory
But can't login with AD user on my web browser
IE, Opera, Chrome, Firefox, etc.. It's always show as below
But if i used local user on linux it's work

How to? thanks

ERROR
The requested URL could not be retrieved

--------------------------------------------------------------------------------

While trying to retrieve the URL: http://www.silkspan.com/newsletter/101112_1/news101112_1_k-express.html [^]


The following error was encountered:
Cache Access Denied.

Access control configuration prevents your request from
being allowed at this time. Please contact your service provider if
you feel this is incorrect.

Sorry, you are not currently allowed to request:
http://www.silkspan.com/newsletter/101112_1/news101112_1_k-express.html [^]
from this cache until you have authenticated yourself.

You need to use Netscape version 2.0 or greater, or Microsoft Internet
Explorer 3.0, or an HTTP/1.1 compliant browser for this to work. Please
contact the cache administrator if you have
difficulties authenticating yourself or
change your default password.
purple
has duplicate 0003456resolved simon-endian AD autentication does not work due to incorrect permissions 
Issue History
2010-11-12 11:36NarinNilNew Issue
2010-11-16 08:04lorenzo-endianAssigned To => lorenzo-endian
2010-11-16 08:04lorenzo-endianStatusnew => acknowledged
2010-11-23 10:20lorenzo-endianNote Added: 0005184
2010-11-23 10:20lorenzo-endianAssigned Tolorenzo-endian => simon-endian
2010-11-23 10:20lorenzo-endianStatusacknowledged => feedback
2010-11-24 13:13simon-endianStatusfeedback => resolved
2010-11-24 13:13simon-endianFixed in Version => 2.4.1
2010-11-24 13:13simon-endianResolutionopen => fixed
2010-11-29 03:00NarinNilNote Added: 0005223
2010-11-29 03:00NarinNilStatusresolved => feedback
2010-11-29 03:00NarinNilResolutionfixed => reopened
2010-11-29 06:36lorenzo-endianNote Added: 0005224
2010-11-29 09:56NarinNilNote Added: 0005234
2010-11-29 16:27lorenzo-endianNote Added: 0005247
2010-11-29 16:27lorenzo-endianStatusfeedback => closed
2010-11-29 16:27lorenzo-endianResolutionreopened => fixed
2010-11-30 05:01NarinNilNote Added: 0005250
2010-11-30 05:01NarinNilStatusclosed => feedback
2010-11-30 05:01NarinNilResolutionfixed => reopened
2010-11-30 07:20lorenzo-endianNote Added: 0005251
2010-11-30 07:20lorenzo-endianStatusfeedback => closed
2010-11-30 07:20lorenzo-endianResolutionreopened => no change required
2010-12-21 16:43NarinNilNote Added: 0005402
2010-12-21 16:43NarinNilStatusclosed => resolved
2011-02-02 10:10davviddeRelationship addedhas duplicate 0003456
2011-02-25 13:29luca-endianStatusresolved => feedback
2011-02-25 13:29luca-endianResolutionno change required => reopened
2011-02-25 13:29luca-endianStatusfeedback => confirmed
2011-04-05 12:34luca-endianTag Attached: purple
2011-04-12 05:44icedburnNote Added: 0006104
2011-04-19 13:45AnonymousStatusconfirmed => resolved
2011-04-19 13:45AnonymousResolutionreopened => fixed
2012-11-07 04:47fqureshiNote Added: 0008260
2012-11-07 04:47fqureshiStatusresolved => feedback
2012-11-07 04:47fqureshiResolutionfixed => reopened

Notes
(0005184)
lorenzo-endian   
2010-11-23 10:20   
Hi NarinNil,

I can confirm that this is a bug!

Here is a workaround (run the commands as root):

# chgrp squid /var/cache/samba/winbindd_privileged
# chmod 750 /var/cache/samba/winbindd_privileged

Can you check if it works and provide a feedback? In the meanwhile we will work to fix this bug!

Thnaks in advace for the test and thanks a lot to report this issue!

Lo
(0005223)
NarinNil   
2010-11-29 03:00   
dear lo i will test within today and will be feedback again

thanks for your helping ;)
(0005224)
lorenzo-endian   
2010-11-29 06:36   
Hi NarinNil,

thanks a lot for you support and test!

I will wait for a feedback :)

Lo
(0005234)
NarinNil   
2010-11-29 09:56   
Hi lo

i fresh installed 2.2 and then upgrade to 2.4.1
but can't upgrade it's show error as below

error: file /home/httpd/html/include/servicesubscriber.js from install of efw-guilib-2.4.3-0.endian5 conflicts with file from package
efw-base-2.6.127.2-1.endian9

i try 3 times but still got error :( 2.3, 2.4, 2.4.1 can't install
on my system with raid problem

my system = hp proliant dl360 g3 (72 GB x 2 with raid 0)
(0005247)
lorenzo-endian   
2010-11-29 16:27   
Hi NarilNil,

Please create a new issue report for this new problem.

Thanks in advance

Lo
(0005250)
NarinNil   
2010-11-30 05:01   
Sorry lo i have been created new issue

http://bugs.endian.com/view.php?id=3340 [^]

Thank ;)
(0005251)
lorenzo-endian   
2010-11-30 07:20   
Hi NarinNil,

thanks a lot, this help us to keep the system well-ordered and the it helps the other users to find on problem (and hopefully, a solution) for each issue reported.

Thanks a lot!

Lo
(0005402)
NarinNil   
2010-12-21 16:43   
Thank lo your solution work !! :D :D
(0006104)
icedburn   
2011-04-12 05:44   
Thank you. it also work for me.
but.. after the implementing the workaround,
just clear cache in the firewall..
and also clearing the cache in the browser..
work like a charm..
(0008260)
fqureshi   
2012-11-07 04:47   
My question is from Narin. May I know what configuration parameters have you used in authentication? I am also using LDAP authentication and it lists the groups but users never come up from AD. I want to know what is the difference between parameters used by you or what I am doing wrong?