SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0003296: Main Uplink displays an incorrct status information. - MantisBT
MantisBT - Endian Firewall
View Issue Details
0003296Endian FirewallGUIpublic2010-11-14 03:392010-11-23 07:11
piratpl 
simon-endian 
normalminoralways
confirmedopen 
2.4 
 
0003296: Main Uplink displays an incorrct status information.
The status for Main Uplink under the Uplinks section on the System page shows as UP even when the Main Uplink is down.
This behavior is noticed in the double-nated setup, however, it may not be limited to that setup as other scenarios were not tested.

Here is the description of the network setup.

The internet connection comes in to the ISP router. The router does NAT and forward all the packets to Endian on a privet IP range 192.168.x.0/24.

Steps to reproduce:

1. Unplug the uplink cable. The uplink status still shows as UP
No tags attached.
Issue History
2010-11-14 03:39piratplNew Issue
2010-11-15 08:22lorenzo-endianAssigned To => lorenzo-endian
2010-11-15 08:22lorenzo-endianStatusnew => acknowledged
2010-11-16 08:57lorenzo-endianNote Added: 0005127
2010-11-16 08:57lorenzo-endianStatusacknowledged => confirmed
2010-11-16 14:50lorenzo-endianStatusconfirmed => new
2010-11-16 14:50lorenzo-endianAssigned Tolorenzo-endian => simon-endian
2010-11-23 07:11lorenzo-endianStatusnew => confirmed

Notes
(0005127)
lorenzo-endian   
2010-11-16 08:57   
Hi piratpl,

I can confirm that this problem exists. The eth3 link inside the interfaces' list is shown as "Down", but the uplink status is shown as UP.

Refreshing the page does not fix the problem. The only way for getting the right uplink status is to re-init the uplink, which of course is not ok.

Thanks a lot!

Lo