SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0003329: 2.4.1 CE does not install on a Compaq EVO D500 - MantisBT
MantisBT - Endian Firewall
View Issue Details
0003329Endian FirewallInstallationpublic2010-11-25 20:522010-12-03 14:10
baldy 
lorenzo-endian 
normalminoralways
feedbackopen 
2.4 
 
0003329: 2.4.1 CE does not install on a Compaq EVO D500
When installing the 2.4.1 CE, installation starts properly, but when the first blue screen appears it justs hangs. Normally you get the setup wizard screens.

When installing 2.4.0 CE and upgrading via efw-upgrade all works fine.

I have tested this on three different D500's and have used several 2.4.1 cd's.
root@efw-1290625823:~ # lspci -v
00:00.0 Host bridge: Intel Corporation 82845 845 [Brookdale] Chipset Host Bridge
 (rev 03)
        Flags: bus master, fast devsel, latency 0
        Memory at f8000000 (32-bit, prefetchable) [size=64M]
        Capabilities: [e4] Vendor Specific Information
        Capabilities: [a0] AGP version 2.0

00:01.0 PCI bridge: Intel Corporation 82845 845 [Brookdale] Chipset AGP Bridge (
rev 03) (prog-if 00 [Normal decode])
        Flags: bus master, 66MHz, fast devsel, latency 64
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=32
        Memory behind bridge: fd000000-fe1fffff
        Prefetchable memory behind bridge: f5e00000-f7ffffff

00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 12) (prog-if 00 [Nor
mal decode])
        Flags: bus master, fast devsel, latency 0
        Bus: primary=00, secondary=02, subordinate=02, sec-latency=64
        I/O behind bridge: 00001000-00001fff
        Memory behind bridge: fc200000-fc4fffff
        Prefetchable memory behind bridge: 30000000-300fffff

00:1f.0 ISA bridge: Intel Corporation 82801BA ISA Bridge (LPC) (rev 12)
        Flags: bus master, medium devsel, latency 0

00:1f.1 IDE interface: Intel Corporation 82801BA IDE U100 Controller (rev 12) (p
rog-if 80 [Master])
        Subsystem: Compaq Computer Corporation Unknown device 2411
        Flags: bus master, medium devsel, latency 0
        [virtual] Memory at 000001f0 (32-bit, non-prefetchable) [disabled] [size
=8]
        [virtual] Memory at 000003f0 (type 3, non-prefetchable) [disabled] [size
=1]
        [virtual] Memory at 00000170 (32-bit, non-prefetchable) [disabled] [size
=8]
        [virtual] Memory at 00000370 (type 3, non-prefetchable) [disabled] [size
=1]
        I/O ports at 2480 [size=16]

00:1f.2 USB Controller: Intel Corporation 82801BA/BAM USB Controller 0000001 (rev 12)
 (prog-if 00 [UHCI])
        Subsystem: Compaq Computer Corporation Unknown device 2411
        Flags: bus master, medium devsel, latency 0, IRQ 19
        I/O ports at 2440 [size=32]

00:1f.4 USB Controller: Intel Corporation 82801BA/BAM USB Controller 0000001 (rev 12)
 (prog-if 00 [UHCI])
        Subsystem: Compaq Computer Corporation Unknown device 2411
        Flags: bus master, medium devsel, latency 0, IRQ 23
        I/O ports at 2460 [size=32]

00:1f.5 Multimedia audio controller: Intel Corporation 82801BA/BAM AC'97 Audio C
ontroller (rev 12)
        Subsystem: Compaq Computer Corporation Evo D500
        Flags: bus master, medium devsel, latency 0, IRQ 11
        I/O ports at 2000 [size=256]
        I/O ports at 2400 [size=64]

01:00.0 VGA compatible controller: nVidia Corporation NV6 [Vanta/Vanta LT] (rev
15) (prog-if 00 [VGA controller])
        Subsystem: nVidia Corporation Unknown device 0072
        Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 10
        Memory at fd000000 (32-bit, non-prefetchable) [size=16M]
        Memory at f6000000 (32-bit, prefetchable) [size=32M]
        [virtual] Expansion ROM at f5e00000 [disabled] [size=64K]
        Capabilities: [60] Power Management version 1
        Capabilities: [44] AGP version 2.0

02:04.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado] (rev 74)
        Subsystem: 3Com Corporation 3C905CX-TX/TX-M Fast Etherlink for PC Manage
ment NIC
        Flags: bus master, medium devsel, latency 64, IRQ 16
        I/O ports at 1000 [size=128]
        Memory at fc401000 (32-bit, non-prefetchable) [size=128]
        [virtual] Expansion ROM at 30000000 [disabled] [size=128K]
        Capabilities: [dc] Power Management version 2

02:08.0 Ethernet controller: Intel Corporation 82801BA/BAM/CA/CAM Ethernet Contr
oller (rev 03)
        Subsystem: Compaq Computer Corporation EtherExpress PRO/100 VM
        Flags: bus master, medium devsel, latency 66, IRQ 20
        Memory at fc400000 (32-bit, non-prefetchable) [size=4K]
        I/O ports at 1080 [size=64]
        Capabilities: [dc] Power Management version 2

Systems are running a socket 478 P4-1.7GHz, 20GB IDE HDD, IDE CD and 768MB SDRAM
No tags attached.
Issue History
2010-11-25 20:52baldyNew Issue
2010-11-30 17:27baldyNote Added: 0005258
2010-12-02 10:40lorenzo-endianNote Added: 0005270
2010-12-02 10:40lorenzo-endianAssigned To => lorenzo-endian
2010-12-02 10:40lorenzo-endianStatusnew => feedback
2010-12-02 12:08baldyNote Added: 0005275
2010-12-02 12:08baldyNote Added: 0005276
2010-12-02 12:13baldyNote Edited: 0005276
2010-12-02 12:13lorenzo-endianNote Added: 0005277
2010-12-02 13:47lorenzo-endianNote Edited: 0005270
2010-12-02 13:50lorenzo-endianNote Added: 0005279
2010-12-03 14:02baldyNote Added: 0005294
2010-12-03 14:09baldyNote Added: 0005295
2010-12-03 14:10baldyNote Added: 0005296

Notes
(0005258)
baldy   
2010-11-30 17:27   
When switching to the console the following is shown :

Loading 3c59x
Loading ata_piix
Loading e100
Loading intel_rng
FATAL: Error inserting intel_rng (/lib/modules/2.6.32.25-57.e40.i586/kernel/drivers/charhw_randeom/intel-rng.ko.gz): Device or resource busy
Loading uhci_hcd
Running command: /bin/sendstatus.sh init
Initializing PCMCIA controllers.
Running command: modprobe i82365
FATAL: Module i82364 not found.
Detected No PCMCIA Controller (Will re-try later for floppy boot)
Initializing USB Controllers.
Running command: /sbin/modprobe sd_mod
Running command: /sbin/modprobe sr_mod
Running command: /sbin/modprobe usb-storage
Running command: /sbin/modprobe ehci-hcd
Running command: /sbin/modprobe ohci-hcd
Running command: /sbin/modprobe uhci-hcd
Running command: /sbin/modprobe usbhid
FATAL: Module usbhid not found
Running command: /bin/mount -t usbfs none /proc/bus/usb
Running command: /bin/mountsource.sh
Scanning source media
(blinking cursor)
(0005270)
lorenzo-endian   
2010-12-02 10:40   
(edited on: 2010-12-02 13:47)
Hi Baldy,

when the installer stops, could you switch to the console 2 or 3, execute

kudzu -qps

and post the output? this seems a problem with hdd / hdd controllers drivers...

Thanks in advance!

Lo

(0005275)
baldy   
2010-12-02 12:08   
-
class: OTHER
bus: PCI
detached: 0
desc: "Intel Corporation 82845 845 [Brookdale] Chipset Host Bridge"
vendorId: 8086
deviceId: 1a30
subVendorId: 0000
subDeviceId: 0000
pciType: 1
pcidom: 0
pcibus: 0
pcidev: 0
pcifn: 0

-
class: OTHER
bus: PCI
detached: 0
desc: "Intel Corporation 82845 845 [Brookdale] Chipset AGP Bridge"
vendorId: 8086
deviceId: 1a31
subVendorId: 0000
subDeviceId: 0000
pciType: 1
pcidom: 0
pcibus: 0
pcidev: 1
pcifn: 0

-
class: OTHER
bus: PCI
detached: 0
desc: "Intel Corporation 82801 PCI Bridge"
vendorId: 8086
deviceId: 244e
subVendorId: 0000
subDeviceId: 0000
pciType: 1
pcidom: 0
pcibus: 0
pcidev: 1e
pcifn: 0

-
class: OTHER
bus: PCI
detached: 0
driver: intel-rng
desc: "Intel Corporation 82801BA ISA Bridge (LPC)"
vendorId: 8086
deviceId: 2440
subVendorId: 0000
subDeviceId: 0000
pciType: 1
pcidom: 0
pcibus: 0
pcidev: 1f
pcifn: 0

-
class: OTHER
bus: USB
detached: 0
desc: "Linux 2.6.32.25-57.e40.i586 uhci_hcd UHCI Host Controller"
usbclass: 9
usbsubclass: 0
usbprotocol: 0
usbbus: 2
usblevel: 0
usbport: 0
usbdev: 1
vendorId: 1d6b
deviceId: 0001
usbmfr: Linux 2.6.32.25-57.e40.i586 uhci_hcd
usbprod: UHCI Host Controller

-
class: OTHER
bus: USB
detached: 0
desc: "Linux 2.6.32.25-57.e40.i586 uhci_hcd UHCI Host Controller"
usbclass: 9
usbsubclass: 0
usbprotocol: 0
usbbus: 1
usblevel: 0
usbport: 0
usbdev: 1
vendorId: 1d6b
deviceId: 0001
usbmfr: Linux 2.6.32.25-57.e40.i586 uhci_hcd
usbprod: UHCI Host Controller

-
class: OTHER
bus: PSAUX
detached: 0
driver: pcspkr
desc: "PC Speaker"

-
class: OTHER
bus: ISAPNP
detached: 0
desc: "PNP0003"
deviceId: PNP0003

-
class: OTHER
bus: ISAPNP
detached: 0
desc: "PNP0200"
deviceId: PNP0200

-
class: OTHER
bus: ISAPNP
detached: 0
desc: "PNP0303"
deviceId: PNP0303

-
class: OTHER
bus: ISAPNP
detached: 0
desc: "PNP0401"
deviceId: PNP0401

-
class: OTHER
bus: ISAPNP
detached: 0
desc: "PNP0501"
deviceId: PNP0501
compat: PNP0500

-
class: OTHER
bus: ISAPNP
detached: 0
desc: "PNP0501"
deviceId: PNP0501
compat: PNP0500

-
class: OTHER
bus: ISAPNP
detached: 0
desc: "PNP0700"
deviceId: PNP0700

-
class: OTHER
bus: ISAPNP
detached: 0
desc: "PNP0800"
deviceId: PNP0800
-
class: OTHER
bus: ISAPNP
detached: 0
desc: "PNP0a03"
deviceId: PNP0a03

-
class: OTHER
bus: ISAPNP
detached: 0
desc: "PNP0b00"
deviceId: PNP0b00

-
class: OTHER
bus: ISAPNP
detached: 0
desc: "PNP0c01"
deviceId: PNP0c01

-
class: OTHER
bus: ISAPNP
detached: 0
desc: "PNP0c02"
deviceId: PNP0c02

-
class: OTHER
bus: ISAPNP
detached: 0
desc: "PNP0c02"
deviceId: PNP0c02

-
class: OTHER
bus: ISAPNP
detached: 0
desc: "PNP0c04"
deviceId: PNP0c04

-
class: OTHER
bus: ISAPNP
detached: 0
desc: "PNP0f13"
deviceId: PNP0f13
compat: PNP0f0e

-
class: OTHER
bus: PSAUX
detached: 0
desc: "Power Button"

-
class: OTHER
bus: PSAUX
detached: 0
desc: "Power Button"

-
class: NETWORK
bus: PCI
detached: 0
device: eth0
driver: 3c59x: "3Com Corporation 3c905C-TX/TX-M [Tornado]"
network.hwaddr: 00:04:75:fe:68:29
vendorId: 10b7
deviceId: 9200
subVendorId: 10b7
subDeviceId: 100
pciType: 1
pcidom: 0
pcibus: 2
pcidev: 4
pcifn: 0

-
class: NETWORK
bus: PCI
detached: 0
device: eth1
driver: e100
desc: "Intel Corporation 82801BA/BAM/CA/CAM Ethernet Controller"
network.hwaddr: 00:08:02:0d:1d:3c
vendorId: 8086
deviceId: 2449
subVendorId: 0e11
subDeviceId: 0012
pciType: 1
pcidom: 0
pcibus: 2
pcidev: 8
pcifn: 0

-
class: AUDIO
bus: PCI
detached: 0
desc: "Intel Corporation 82801BA/BAM AC'97 Audio Controller"
vendorId: 8086
deviceId: 2445
subVendorId: 0e11
subDeviceId: 0088
pciType: 1
pcidom: 0
pcibus: 0
pcidev: 1f
pcifn: 5

-
class: CDROM
bus: IDE
detached: 0
device: hdc
desc: "LTN486S"

-
class: VIDEO
bus: PCI
detached: 0
desc: "nVidia Corporation NV6 [Vanta/Vanta LT]"
vendorId: 10de
deviceId: 002c
subVendorId: 10de
subDeviceId: 0072
pciType: 1
pcidom: 0
pcibus: 1
pcidev: 0
pcifn: 0
-
class: HD
bus: IDE
detached: 0
device: hda
desc: "IC35L060AVV207-0"
physical: 16383/16/63
logical: 16383/255/63

-
class: KEYBOARD
bus: PSAUX
detached: 0
desc: "AT Translated Set 2 keyboard"

-
class: USB
bus: PCI
detached: 0
driver: uhci-hcd
desc: "Intel Corporation 82801BA/BAM USB Controller 0000001"
vendorId: 8086
deviceId: 2442
subVendorId: 0e11
subDeviceId: 2411
pciType: 1
pcidom: 0
pcibus: 0
pcidev: 1f
pcifn: 2

-
class: USB
bus: PCI
detached: 0
driver: uhci-hcd
desc: "Intel Corporation 82801BA/BAM USB Controller 0000001"
vendorId: 8086
deviceId: 2444
subVendorId: 0e11
subDeviceId: 2411
pciType: 1
pcidom: 0
pcibus: 0
pcidev: 1f
pcifn: 4

-
class: IDE
bus: PCI
detached: 0
driver: ata_piix
desc: "Intel Corporation 82801BA IDE U100 Controller"
vendorId: 8086
deviceId: 244b
subVendorId: 0e11
subDeviceId: 2411
pciType: 1
pcidom: 0
pcibus: 0
pcidev: 1f
pcifn: 1
(0005276)
baldy   
2010-12-02 12:08   
(edited on: 2010-12-02 12:13)
it was kudzu btw, not kuzku ;-)

Kudzu output on an upgraded system is the same as on the 2.4.1. hanging install.

(0005277)
lorenzo-endian   
2010-12-02 12:13   
Hi baldy!

first of all sorry for saying you the wrong command!

thanks for the info provided, I will keep you informed about the progress I made!

Thanks again!

Lo
(0005279)
lorenzo-endian   
2010-12-02 13:50   
I am trying to get other info which could be useful for troubleshooting this problem...

Could you please post the output of "lsmod" both of the upgraded and fresh-installed system?

Thanks a lot!

Lo
(0005294)
baldy   
2010-12-03 14:02   
Hi Lo, from an upgraded system :

Module Size Used by
tun 8484 2
ipv6 193285 20
xt_hashlimit 6486 20
xt_CONNMARK 899 15
xt_connmark 739 16
ipt_REJECT 1529 1
xt_physdev 1180 19
ebt_mark_m 638 1
xt_MARK 565 5
xt_mark 565 1
xt_TCPMSS 2303 1
xt_limit 980 1
xt_state 855 23
xt_tcpudp 1703 79
ebtable_nat 1041 1
ebtable_filter 1049 1
ebtables 12735 2 ebtable_nat,ebtable_filter
iptable_mangle 1177 1
bridge 32457 0
8021q 13350 0
garp 3900 1 8021q
stp 928 2 bridge,garp
llc 2392 3 bridge,garp,stp
nf_conntrack_netbios_ns 898 0
nf_nat_snmp_basic 6470 0
nf_nat_sip 3710 0
nf_conntrack_sip 10485 1 nf_nat_sip
nf_nat_pptp 1578 0
nf_nat_proto_gre 837 1 nf_nat_pptp
nf_conntrack_pptp 2841 1 nf_nat_pptp
nf_conntrack_proto_gre 2517 1 nf_conntrack_pptp
nf_nat_tftp 534 0
nf_conntrack_tftp 2273 1 nf_nat_tftp
nf_nat_irc 814 0
nf_conntrack_irc 2395 1 nf_nat_irc
nf_nat_h323 4255 0
nf_conntrack_h323 32208 1 nf_nat_h323
nf_nat_ftp 1247 0
nf_conntrack_ftp 4069 1 nf_nat_ftp
nf_nat_amanda 664 0
ts_kmp 1231 5
nf_conntrack_amanda 1541 1 nf_nat_amanda
iptable_filter 938 1
iptable_nat 2574 1
ip_tables 7539 3 iptable_mangle,iptable_filter,iptable_nat
nf_nat 10267 9 nf_nat_sip,nf_nat_pptp,nf_nat_proto_gre,nf_nat_tftp,nf_nat_irc,nf_nat_h323,nf_nat_ftp,nf_nat_amanda,iptable_nat
x_tables 7990 15 xt_hashlimit,xt_CONNMARK,xt_connmark,ipt_REJECT,xt_physdev,ebt_mark_m,xt_MARK,xt_mark,xt_TCPMSS,xt_limit,xt_state,xt_tcpudp,ebtables,iptable_nat,ip_tables
nf_conntrack_ipv4 7418 57 iptable_nat,nf_nat
nf_conntrack 38475 23 xt_CONNMARK,xt_connmark,xt_state,nf_conntrack_netbios_ns,nf_nat_snmp_basic,nf_nat_sip,nf_conntrack_sip,nf_nat_pptp,nf_conntrack_pptp,nf_conntrack_proto_gre,nf_nat_tftp,nf_conntrack_tftp,nf_nat_irc,nf_conntrack_irc,nf_nat_h323,nf_conntrack_h323,nf_nat_ftp,nf_conntrack_ftp,nf_nat_amanda,nf_conntrack_amanda,iptable_nat,nf_nat,nf_conntrack_ipv4
nf_defrag_ipv4 715 1 nf_conntrack_ipv4
camellia 18759 0
sha512_generic 8249 0
sha256_generic 11860 0
deflate 1281 0
zlib_deflate 15683 1 deflate
arc4 914 0
ecb 1337 0
aes_i586 6800 0
aes_generic 26682 1 aes_i586
cast5 16277 0
blowfish 7344 0
des_generic 14963 0
cbc 1955 0
cryptosoft 10177 0
cryptodev 8948 0
ocf 16853 2 cryptosoft,cryptodev
capi 8377 0
capifs 1845 2 capi
kernelcapi 25396 1 capi
nfnetlink_log 5383 2
nfnetlink 1678 3 nfnetlink_log
sd_mod 21224 0
usb_storage 23793 0
dm_mod 40927 12
pcspkr 1235 0
e100 22793 0
mii 2594 1 e100
uhci_hcd 15586 0
ide_cd_mod 20418 0
cdrom 25196 1 ide_cd_mod
ext3 88438 5
jbd 30725 1 ext3
ata_piix 17476 0
(0005295)
baldy   
2010-12-03 14:09   
On the system that does not continue setup :

Module Size Used by Not Tainted
ide_cd_mod 20418 1
ohci_hcd 17575 0
ssb 23814 1 ohci_hcd
ehci_hcd 27529 0
usb_storage 23793 0
sr_mod 10162 0
cdrom 25196 0 ide_cd_mod,sr_mod
sd_mod 21224 0
uhci-hcd 15586 0
e100 22793 0
ata_piix 17476 0
3c59x 26029 0
mii 2594 0 e100,3c59x
loop 9120 0
(0005296)
baldy   
2010-12-03 14:10   
Hi Lo,

FYI, the only difference between the two EVO's is that one has 2 intel nics and the other one intel and one 3com.

Issue with installing 2.4.1 occurs on both.

Regards,

Baldy