SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0003432: HAVP => no youtube videos from iphone & ipad - MantisBT
MantisBT - Endian Firewall
View Issue Details
0003432Endian FirewallProxy HTTPpublic2011-01-14 16:062013-03-11 08:41
ardit-endian 
peter-endian 
normalmajoralways
feedbackopen 
2.4.1 
 
0003432: HAVP => no youtube videos from iphone & ipad
When HAVP is enabled we are unable to see youtube videos with iphone or ipad.
when is disabled the problem disappears.

The issue is reproducible and the zone is indifferent (green/orange or blue).

I noticed testing this that the cause is havp but no error message in the log.

System tested was full up-to-date.
purple
Issue History
2011-01-14 16:06ardit-endianNew Issue
2011-01-14 16:06ardit-endianTag Attached: purple
2011-01-14 16:55ardit-endianCustomer Occurencies => 1
2011-01-15 13:26baldyNote Added: 0005478
2011-01-15 13:27baldyNote Edited: 0005478
2011-01-15 13:31baldyNote Edited: 0005478
2011-01-17 08:31ardit-endianNote Added: 0005479
2011-01-17 09:55ardit-endianNote Added: 0005480
2011-01-17 09:59ardit-endianNote Edited: 0005480
2011-02-07 08:29ra-endianAssigned To => peter-endian
2011-02-07 08:29ra-endianStatusnew => confirmed
2011-02-10 14:15ra-endianCategoryOther Services => Proxy HTTP
2011-02-11 08:43ardit-endianCustomer Occurencies1 => 4-6
2011-02-18 14:26ra-endianSeveritymajor => minor
2011-03-08 11:57diwodaNote Added: 0005877
2011-05-16 04:59timboauNote Added: 0006342
2011-05-24 12:28ardit-endianSeverityminor => major
2011-05-26 23:00baldyNote Added: 0006515
2011-06-02 10:18davezekingNote Added: 0006558
2012-03-27 12:08luca-endianNote Added: 0007767
2012-03-27 13:11luca-endianNote Added: 0007768
2012-06-07 22:10fqureshiNote Added: 0007906
2012-08-11 16:07LyveNote Added: 0008007
2012-08-13 08:13ardit-endianNote Added: 0008008
2012-11-28 14:22AnonymousStatusconfirmed => feedback
2013-03-11 08:41herbert-endianNote Added: 0008391

Notes
(0005478)
baldy   
2011-01-15 13:26   
(edited on: 2011-01-15 13:31)
Hi Ardit,

the option "SKIPMIME image/* video/* audio/*" should fix the problem.

Option should be added to /etc/havp/havp.conf
Not sure whether the file will be overwritten when the process restarts.

http://www.ipcops.com/phpbb3/viewtopic.php?f=7&t=14274 [^]

regards,

Baldy

(0005479)
ardit-endian   
2011-01-17 08:31   
Hi Baldy,

Actually, there is an Mime Type option in Access Policy rules but it is applicable only with "deny access"

We should try putting SKIPMIME image/* video/* audio/* to havp.conf.tmpl (this modification is permanent) and see if this solve the problem.

nice catch,

I hope that there will be a fix included in the next update.

Regards,
Ardit.
(0005480)
ardit-endian   
2011-01-17 09:55   
(edited on: 2011-01-17 09:59)
NOTE:

Option not supported in havp 0.90 (currently installed in 2.4 enterprise), option available only with 0.92 and up*

Please note:

update also;
dansguardian,
squid,
clamav

(0005877)
diwoda   
2011-03-08 11:57   
Sorry, but this bug is NOT minor at all !

Especially not in Hotspot Inviroments but also in everydays life! Just think about the immense number of iphone and ipad users!

Kindly request a FAST solution! (bypassing the proxy is no option because it is not possible to enter each MAC or IP Address manually...)
(0006342)
timboau   
2011-05-16 04:59   
Hi,
Has any progress been made with this.

I'm looking at deploying Endian as a firewall/proxy and everything was working perfectly until I deployed it and users started complaining about videos not streaming. It appears they are Flash videos that are not working.
Unfortunately this will be a deal breaker for me and I will have to look elsewhere. I'm happy to exclude the complete site from the proxy if necessary however that didnt seem to make any difference.

Could it be anything to do with RTMP Protocol?
(0006515)
baldy   
2011-05-26 23:00   
Hi timboau,

Can you test this package and post back the results ?

From a ssh session: curl bugfixes.endian.com/havp-clam/install | sh

I have been testing this package for different reasons, but should fix your problem in combination with the /SKIPMIME option above.

Regards,

Klaas-Jan
(0006558)
davezeking   
2011-06-02 10:18   
Hi baldy,

I've been having the same issue with Youtube and HTML5 videos on the iPad, I tried your fixes (the update and SKIPMIME directive), this still didn't fix the issue.

After hours of messing around I've worked out that the RANGE command needs to be supported by the proxy in order to use pseudo HTTP Streaming on iOS.

If you add the following line to /etc/havp/havp.conf.tmpl:

RANGE true

And then save your changes via the web interface so the template is written into the live config file you should find that both the YouTube app and HTML5 videos in Safari now work.

In the end I commented out the SKIPMIME directive as this didn't seem to help and also seems less secure.

Regards,

Dave.
(0007767)
luca-endian   
2012-03-27 12:08   
rpm -q havp
havp-0.92a-2.endian15

root@stan:/etc/havp # cat havp.conf | grep SK
SKIPMIME image/* video/* audio/*

Doesn't fix the problem..
(0007768)
luca-endian   
2012-03-27 13:11   
rpm -q havp
havp-0.92a-2.endian15

root@stan:/etc/havp # cat havp.conf | grep RANGE
RANGE true

youtube and appstore on iphone works
(0007906)
fqureshi   
2012-06-07 22:10   
I was facing the same issue. First I passsed the argument of "RANGE true" it didn't work. Then I checked the version of havp which is havp-0.92a-2.endian15.

Then I added SKIPMIME image/* video/* audio/*
everything is working as desired. Thus I am passing two arguments in havp.config.tmpl file

RANGE true
SKIPMIME image/* video/* audio/*
(0008007)
Lyve   
2012-08-11 16:07   
Thanks @fqureshi this fixed the problem for me, too.
(0008008)
ardit-endian   
2012-08-13 08:13   
@everyone,

yes the SKIPMIME will fix the issue but will also not scann any image, picture, audio for viruses.

Don't use this setting in critical environments where you rely on the antivirus for protecting your data.
(0008391)
herbert-endian   
2013-03-11 08:41   
Hi Guys,

I have a customer with the same issue on all of his Machines.
I gave him the workaroung with the information from Ardit, that he should pay attention.
When would this Bug be fixed?

Please let me know.
Cheers.

Herbert