SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0003880: Check host function takes down the uplink - MantisBT
MantisBT - Endian Firewall
View Issue Details
0003880Endian FirewallNetwork related (VPN, uplinks)public2011-06-10 14:282011-07-26 10:47
luca-endian 
lorenzo-endian 
normalmajorrandom
feedbackopen 
2.4.1 
 
0003880: Check host function takes down the uplink
If you have two connections (both static Ethernet) and enable fail-over on the main connection it immediately says it is inactive then fails over to the backup link.

The uplink is working fine until the check host function is enabled.
The only way to bring the main connection back to a working state is to disable fail-over and restart. I have tried restarting the connection and disabling and reenabling but all it says is Dead, Failure or Inactive.
purple
png cable.png (65,122) 2011-06-10 14:33
https://bugs.endian.com/file_download.php?file_id=778&type=bug
png
Issue History
2011-06-10 14:28luca-endianNew Issue
2011-06-10 14:28luca-endianTag Attached: purple
2011-06-10 14:33luca-endianFile Added: cable.png
2011-07-06 11:12lorenzo-endianNote Added: 0006889
2011-07-06 11:12lorenzo-endianAssigned To => lorenzo-endian
2011-07-06 11:12lorenzo-endianStatusnew => feedback
2011-07-09 07:29marioeireaNote Added: 0006928
2011-07-09 08:38marioeireaNote Edited: 0006928
2011-07-09 08:39marioeireaNote Edited: 0006928
2011-07-09 08:41marioeireaNote Edited: 0006928
2011-07-26 10:47luca-endianNote Added: 0007093

Notes
(0006889)
lorenzo-endian   
2011-07-06 11:12   
Hey luca!

something changes if you put "8.8.8.8" instead of "google.com" in the "check hosts" form?

It is just to be sure that the problem is not related to any DNS resolution (even if I am quite sure is not related).

Thanks in advance!

Lo
(0006928)
marioeirea   
2011-07-09 07:29   
(edited on: 2011-07-09 08:41)
I can confirm this is happening to me also.

Also, I have a box that refuses to do DNS lookups if the main uplink is down. It seems this is happening when both main and secondary uplinks share the same DNS servers. OpenDNS is used on both uplinks.

(0007093)
luca-endian   
2011-07-26 10:47   
marioeriea different uplinks should never share the same uplinks because there are policy routing to force dns request through the specific uplink..