SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0000040: HAVP 0.81 Problem - MantisBT
MantisBT - Endian Firewall
View Issue Details
0000040Endian FirewallSecuritypublic2006-10-25 03:232007-01-02 07:54
bryanj0207 
peter-endian 
normalmajoralways
closedfixed 
2 
2.1 
0000040: HAVP 0.81 Problem
I am receiving the following error page in browser when attempting to reach some sites.

I am receiving the following message:

HAVP: Server is down

The following server is down:

somewhere.somewhere.co_

If you have any queries contact your ICT Co-ordinator or Network Manager.

Endian Firewall - Powered by HAVP

.........

The following error messages are in /var/log/havp/havp.log

22/10/2006 23:08:24 (127.0.0.1) Could not read browser header
22/10/2006 23:08:26 (127.0.0.1) Could not read browser header
22/10/2006 23:08:32 (127.0.0.1) Could not read server header (salespoint.dealerconnection.com:80)
22/10/2006 23:08:33 (127.0.0.1) Could not read server header (salespoint.dealerconnection.com:80)
22/10/2006 23:11:25 (127.0.0.1) Could not read server header (salespoint.dealerconnection.com:80)
22/10/2006 23:11:26 (127.0.0.1) Could not read server header (salespoint.dealerconnection.com:80)
22/10/2006 23:12:03 === Starting HAVP Version: 0.81

I posted the above information to the HAVP forums and was informed by a HAVP developer this is a known bug in HAVP 0.81.

0.82 or greater fixes these header issues.

Could you please provide an update?
No tags attached.
Issue History
2006-10-25 03:23bryanj0207New Issue
2006-10-25 03:24bryanj0207Note Added: 0000058
2006-11-03 01:53peter-endianStatusnew => resolved
2006-11-03 01:53peter-endianResolutionopen => fixed
2006-11-03 01:53peter-endianAssigned To => peter-endian
2006-11-03 01:53peter-endianNote Added: 0000064
2007-01-02 07:54ra-endianStatusresolved => closed
2007-01-02 07:54ra-endianFixed in Version => 2.1

Notes
(0000058)
bryanj0207   
2006-10-25 03:24   
The only workaround I have been able to perform has been to disable Antivirus on the proxy page.
(0000064)
peter-endian   
2006-11-03 01:53   
thanks to mike tremaine, there is an update rpm package on http://www.stellarcore.net/downloads/efw2-updates/ [^] which solves this problem.

the new efw version 2.1 will be shipped with at least version 0.83

thank you for the report