SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0004196: Source Code distribution isn't complete? - MantisBT
MantisBT - Endian Firewall
View Issue Details
0004196Endian FirewallUncategorizedpublic2011-10-20 12:402012-06-09 02:57
gionn 
peter-endian 
normalminorhave not tried
confirmedopen 
2.4.1 
 
0004196: Source Code distribution isn't complete?
I'm trying to compile from source a third-party software on my Endian system.

I've downloaded the source package from:
http://www.endian.com/en/community/download/ [^]

I've unpacked the archive and rsynced its content to my Endian system in /var/build and when I try to install build-essential:

root@efw-1319107248:/var/build/DEVEL_RPMS # rpm -i *
error: Failed dependencies:
    libtool is needed by build-essential-0.4-endian3.i586
    ncurses-devel is needed by build-essential-0.4-endian3.i586
    libselinux-devel is needed by build-essential-0.4-endian3.i586
    glibc-headers is needed by build-essential-0.4-endian3.i586
    kernel-devel is needed by build-essential-0.4-endian3.i586
    kernel-smp-devel is needed by build-essential-0.4-endian3.i586
    rpm-build is needed by build-essential-0.4-endian3.i586
    procinfo is needed by build-essential-0.4-endian3.i586
    busybox is needed by build-essential-0.4-endian3.i586
    newt-devel is needed by build-essential-0.4-endian3.i586
    libsmooth is needed by build-essential-0.4-endian3.i586
    kernel-PAE-devel is needed by build-essential-0.4-endian3.i586
    zlib-devel is needed by build-essential-0.4-endian3.i586
    glibc-devel >= 2.2.90-12 is needed by gcc-3.4.6-10.endian8.i586
    glibc-devel >= 2.2.90-12 is needed by gcc4-4.1.2-14.endian1.i586
No tags attached.
Issue History
2011-10-20 12:40gionnNew Issue
2011-10-25 10:31lorenzo-endianNote Added: 0007511
2011-10-25 10:31lorenzo-endianAssigned To => peter-endian
2011-10-25 10:31lorenzo-endianStatusnew => confirmed
2011-10-25 12:17gionnNote Added: 0007512
2011-10-25 12:24lorenzo-endianNote Added: 0007513
2011-10-28 21:25melconNote Added: 0007521
2011-10-29 07:28gionnNote Added: 0007522
2011-11-02 11:12melconNote Added: 0007527
2012-06-09 02:57guidfailNote Added: 0007908

Notes
(0007511)
lorenzo-endian   
2011-10-25 10:31   
Hi gionn,

I can confirm that this problem exists :(

Thanks for reporting it!

Lo
(0007512)
gionn   
2011-10-25 12:17   
Hi Lorenzo, thank you for the acknowledgment.

Please be aware that releasing full-sources is necessary to be GPL-compliant.

I'm looking forward to hear news about the release of an updated source package.

Cheers.
(0007513)
lorenzo-endian   
2011-10-25 12:24   
Hi gionn,

you are completely right!

Fortunately, this bug is only a problem related to missing dependencies :)

Thanks again for your support!

Lo
(0007521)
melcon   
2011-10-28 21:25   
Any ideas on how to find those dependancies?

gionn:
 Is there a doc on how to compile from source?
(0007522)
gionn   
2011-10-29 07:28   
@Melcon: as is clearly stated in the subject of the report, dependencies are missing because they weren't included in the Source package released by Endian.

AFAIK, Source distribution isn't intended for compiling the entire Endian Community from scratch, but to compile third-party source packages or to recompile existing ones on a Endian Community box, and this is why I'm interested in it.
(0007527)
melcon   
2011-11-02 11:12   
Same here, gionn. I need to compile some stuff in.

2.4.1 does not have ACPI_PROC_EVENT set on kernel and I need it for power button/UPS functions
(0007908)
guidfail   
2012-06-09 02:57   
Bump - is Endian going to release the required dependencies?