SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0004394: Support for Intel 82580 based network cards (Ethernet-Server-Adapter I340-T4) - MantisBT
MantisBT - Endian Firewall
View Issue Details
0004394Endian FirewallHardware related (kernel, drivers, hardware)public2012-07-18 14:452013-11-26 15:39
EDV-Team 
luca-endian 
normaltweakalways
resolvedfixed 
2.5 
future 
0004394: Support for Intel 82580 based network cards (Ethernet-Server-Adapter I340-T4)
The Intel Ethernet-Server-Adapter I340-T4 and other Intel 82580 based network cards don't work on Endian 2.5.1.
There is a Linux driver on the Intel website:
http://downloadcenter.intel.com/detail_desc.aspx?agr=Y&DwnldID=13663 [^]

Please add this driver to EFW Community Edition or provide a Kernel source package so that users can compile the driver itself.

Thank you very much!
purple
Issue History
2012-07-18 14:45EDV-TeamNew Issue
2012-08-16 15:42svenasseNote Added: 0008011
2012-08-16 16:33ardit-endianTag Attached: purple
2012-08-16 16:33ardit-endianStatusnew => confirmed
2012-11-13 19:29dbinaryNote Added: 0008305
2012-11-13 19:30dbinaryNote Edited: 0008305bug_revision_view_page.php?bugnote_id=8305#r13
2013-01-23 10:03EDV-TeamNote Added: 0008364
2013-02-13 06:25d072330Note Added: 0008371
2013-02-13 08:05EDV-TeamNote Added: 0008372
2013-02-13 14:55d072330Note Added: 0008373
2013-02-13 18:21dbinaryNote Added: 0008375
2013-02-13 18:50d072330Note Added: 0008376
2013-02-13 20:14EDV-TeamNote Added: 0008377
2013-02-14 23:56d072330Note Added: 0008378
2013-02-15 05:34EDV-TeamNote Added: 0008379
2013-02-19 05:23d072330Note Added: 0008382
2013-08-07 08:34EDV-TeamNote Added: 0008450
2013-08-07 12:08EDV-TeamNote Deleted: 0008450
2013-08-26 08:37luca-endianNote Added: 0008463
2013-08-26 08:37luca-endianAssigned To => luca-endian
2013-08-26 08:37luca-endianStatusconfirmed => feedback
2013-08-26 09:29EDV-TeamNote Added: 0008466
2013-08-26 09:29EDV-TeamStatusfeedback => new
2013-09-06 15:35Mike_SeamanNote Added: 0008514
2013-10-09 15:36Mike_SeamanNote Added: 0008551
2013-11-26 15:39AnonymousNote Added: 0008552
2013-11-26 15:39AnonymousStatusnew => resolved
2013-11-26 15:39AnonymousFixed in Version => future
2013-11-26 15:39AnonymousResolutionopen => fixed

Notes
(0008011)
svenasse   
2012-08-16 15:42   
I'm using the commercial version of Endian 2.5 and am having issues with the Intel 82580 support. This was not an issue with Endian 2.4.

/lib/modules/2.6.32.43-57.e43.i586/kernel/drivers/net/igb.ko.gz is the 1.3.9 version and is loaded by modprobe. This version does not work. Endian 2.5 install didn't even recognise that I had the card as /etc/modprobe.conf made no mention of the igb driver. I had to either add "alias eth igb" to /etc/modprobe.conf or executed "modprobe igb" and see from dmesg that it loaded 1.3.9 but not initialse the 4 ethernet ports.

/lib/modules/2.6.32.43-57.e43/kernel/drivers/net/igb.ko is the 2.4.8 version and was installed by the kernel-module-igb-2.4.8-2.endian2_2.6.32.43_57.e43.rpm. While this version is two years old it does work with my hardware. I could only test this by using insmod. This was how our server was able to limp through the day yesterday.

Last night I applied the e44 updates with no resolution to the problem. I then did a second clean install from the Endian 2.5 ISO. I caught the error when I ran "modinfo igb" and noted the 1.3.9 version and location of this driver.

My solution was:
# gzip -c9 /lib/modules/2.6.32.43-57.e43/kernel/drivers/net/igb.ko > /lib/modules/2.6.32.43-57.e43.i586/kernel/drivers/net/igb.ko.gz
# vi /etc/modprobe.conf (add "alias eth igb")
# depmod -a
# shutdown -r now

This process had to be repeated after I applied the e44 updates.
(0008305)
dbinary   
2012-11-13 19:29   
(edited on: 2012-11-13 19:30)
The procedure that worked for me in endian UTM 2.5 is:

# gzip -c9 /lib/modules/2.6.32.43-57.e43/kernel/drivers/net/igb.ko > /lib/modules/2.6.32.43-57.e43.i586/kernel/drivers/net/igb/igb.ko.gz
# vi /etc/modprobe.conf (add "alias eth igb")
# modprobe igb
# depmod -a
# reboot

(0008364)
EDV-Team   
2013-01-23 10:03   
Thank you very much for your feedback! It works! :)

All i have to do was:
1. Switch to development channel with 'efw-upgrade -s'
2. smart install igb
3. gzip -c9 /lib/modules/2.6.32.43-57.e43/kernel/drivers/net/igb.ko > /lib/modules/2.6.32.43-57.e43.i586/kernel/drivers/net/igb.ko.gz
4. vi /etc/modprobe.conf (add "alias eth igb")
5. depmod -a
6. reboot
(0008371)
d072330   
2013-02-13 06:25   
How do you do this if you cannot get past the wizard? I have tried to connect to the serial port to install the Intel drivers but have had no luck getting connected.
(0008372)
EDV-Team   
2013-02-13 08:05   
Our Endian Firewall is running on a Dell PowerEdge R210 Server that has two Broadcom on-board NICs. We changed only the additional PCIe Broadcom network card with the Intel Server Adapter to have 6 Ethernet ports instead of 4 ports.

If you have no other working network card in your system, than it's really hard to install the Intel network drivers.
(0008373)
d072330   
2013-02-13 14:55   
I have one working NIC.
(0008375)
dbinary   
2013-02-13 18:21   
Is not necessary pass the wizard only connect a monitor and press 0 option from menu, after enable ssh service login to ssh and follow the steps.


# gzip -c9 /lib/modules/2.6.32.43-57.e43/kernel/drivers/net/igb.ko > /lib/modules/2.6.32.43-57.e43.i586/kernel/drivers/net/igb/igb.ko.gz
# vi /etc/modprobe.conf (add "alias eth igb")
# modprobe igb
# depmod -a
# reboot
(0008376)
d072330   
2013-02-13 18:50   
This directory does not exist on my machine.

/lib/modules/2.6.32.43-57.e43/kernel/drivers/net/

I only have this directory: /lib/modules/2.6.32.43-57.e43.i586/kernel/drivers/net/igb/

Do I need to do something with this file first (igb-4.1.2.tar.gz)?
(0008377)
EDV-Team   
2013-02-13 20:14   
You need an Internet connection on your Endian Firewall to download the IGB driver package from Endians "development channel". Use 'efw-upgrade -s' to switch to this channel and 'smart install igb" to download and install the driver package.
(0008378)
d072330   
2013-02-14 23:56   
got to internet did these steps:

1. Switch to development channel with 'efw-upgrade -s'
2. smart install igb
3. gzip -c9 /lib/modules/2.6.32.43-57.e43/kernel/drivers/net/igb.ko > /lib/modules/2.6.32.43-57.e43.i586/kernel/drivers/net/igb.ko.gz
4. vi /etc/modprobe.conf (add "alias eth igb")
5. depmod -a
6. reboot

When I rebooted it still did not see the extra NIC's. When I do a lsmod | grep igb nothing shows but if we grep for igb we get this:

kernel-module-igb-2.4.8-2.endian2_2.6.32.43_57.e43
igb-2.4.8-2.endian2_2.6.32.43_57.e43

Why after reboot is the driver not sticking?
(0008379)
EDV-Team   
2013-02-15 05:34   
Try this:
1. cp /lib/modules/2.6.32.43-57.e43/kernel/drivers/net/igb.ko /lib/modules/2.6.32.43-57.e43.i586/kernel/drivers/net/
2. modprobe igb
3. depmod -a
4. reboot
(0008382)
d072330   
2013-02-19 05:23   
What worked for us was getting the latest Intel driver and installing it.
(0008463)
luca-endian   
2013-08-26 08:37   
I think this should be fixed with 2.5.2
(0008466)
EDV-Team   
2013-08-26 09:29   
No! Intel 82580 based network cards are still not supported in Endian 2.5.2, because the Intel IGB driver included in Kernel 2.6.32 is too old and doesn't support this chipset!

IGB driver version in Endian 2.5.2 is: 1.3.16
To get Intel 82580 based cards to work we need at least driver version 2.4.x.
(Because of this there was a separate IGB driver package for a while in the Endian 2.5.1 development channel that includes driver version 2.4.8)

Please provide a newer Intel IGB driver to support these cards!
(Latest Version of the driver is 5.0.5)
(0008514)
Mike_Seaman   
2013-09-06 15:35   
I have confirmed this issue. I can replicate on upgrade and clean install.
Please 'rpmbuild -tb igb.tar.gz' latest IGB driver 5.0.5 from https://downloadcenter.intel.com/confirm.aspx?httpDown=http://downloadmirror.intel.com/13663/eng/igb-5.0.5.tar.gz&lang=eng&Dwnldid=13663 [^]

or allow us to download kernel-dev SRPMS so that we can compile our own drivers.

thank you
(0008551)
Mike_Seaman   
2013-10-09 15:36   
bump. This fix will only take 20 minutes. what is the status?
(0008552)
Anonymous   
2013-11-26 15:39   
http://jira.endian.com/browse/CORE-629 [^]