SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0004415: NTOP / Traffic Monitoring Is Not Working - MantisBT
MantisBT - Endian Firewall
View Issue Details
0004415Endian FirewallOther Servicespublic2012-08-08 05:252013-08-27 07:16
mhLearn 
lorenzo-endian 
normalmajoralways
resolvedfixed 
2.5 
 
0004415: NTOP / Traffic Monitoring Is Not Working
On Endian Firewall 2.5.1.

The NTOP doesn't work even Intrusion is turned off (some reported this issue may due to Intrusion turned on).
ntop, traffic monitoring
jpg NTOP_Not Working.jpg (118,547) 2012-08-08 05:25
https://bugs.endian.com/file_download.php?file_id=972&type=bug
jpg

txt NTOP_Error.txt (22,010) 2012-10-24 08:46
https://bugs.endian.com/file_download.php?file_id=998&type=bug
Issue History
2012-08-08 05:25mhLearnNew Issue
2012-08-08 05:25mhLearnFile Added: NTOP_Not Working.jpg
2012-08-08 15:19lorenzo-endianNote Added: 0008000
2012-08-08 15:19lorenzo-endianAssigned To => lorenzo-endian
2012-08-08 15:19lorenzo-endianStatusnew => feedback
2012-10-19 09:34mhLearnNote Added: 0008242
2012-10-19 10:10mhLearnNote Added: 0008243
2012-10-24 08:46mhLearnFile Added: NTOP_Error.txt
2012-10-24 08:48mhLearnNote Added: 0008247
2012-10-24 08:48mhLearnStatusfeedback => new
2012-11-08 11:40mhLearnNote Added: 0008275
2012-12-04 04:26mhLearnTag Attached: ntop
2012-12-04 04:26mhLearnTag Attached: traffic monitoring
2013-03-11 04:21mhLearnNote Added: 0008390
2013-06-06 22:26soportenaluchoNote Added: 0008436
2013-07-12 11:02daniele-endianNote Added: 0008443
2013-07-19 20:11roninNote Added: 0008447
2013-07-19 20:22roninNote Edited: 0008447bug_revision_view_page.php?bugnote_id=8447#r41
2013-07-20 01:42roninNote Edited: 0008447bug_revision_view_page.php?bugnote_id=8447#r42
2013-08-26 08:17luca-endianNote Added: 0008458
2013-08-26 08:17luca-endianStatusnew => feedback
2013-08-26 09:54mhLearnNote Added: 0008467
2013-08-26 09:54mhLearnStatusfeedback => new
2013-08-27 04:52mhLearnNote Added: 0008471
2013-08-27 07:15daniele-endianNote Added: 0008474
2013-08-27 07:16daniele-endianStatusnew => resolved
2013-08-27 07:16daniele-endianResolutionopen => fixed

Notes
(0008000)
lorenzo-endian   
2012-08-08 15:19   
hi mhLearn,

could this issue be the same described in the bug http://bugs.endian.com/view.php?id=4412 [^] ?

thanks in advance!

Lo
(0008242)
mhLearn   
2012-10-19 09:34   
Hi Lo,

In my case was worsen, the traffic monitoring was not able to load, error message "unable to connect".

thx
mh
(0008243)
mhLearn   
2012-10-19 10:10   
Noticed some said the problem solved after while, eg.
http://bugs.endian.com/view.php?id=4415 [^]

But, how?
(0008247)
mhLearn   
2012-10-24 08:48   
Just upload the log, hope someone can help to resolve the problem. I am new to this, don't understand the log.
(0008275)
mhLearn   
2012-11-08 11:40   
Installed efw on different computer and traffic monitoring was running perfectly on testing environment, i.e. pc <-> green zone switch <-> efw.

But after putting in environment,

    PCs <-> green zone switch, Orange/Blue router <-> efw <-> 2 Red zones

then it failed to work. Found this error message,

 **ERROR** mVLAN: Host (identical IP/MAC) found on multiple VLANs

What does this mean?
(0008390)
mhLearn   
2013-03-11 04:21   
for those that may facing the same problem. Hope below useful to you.

1. Disable the Traffic monitoring.
2. Run ntop from shell
3. Access web through yourfirewall_ip:port. port can be 3000 or 3001.

Good luck
(0008436)
soportenalucho   
2013-06-06 22:26   
I have the same problem... any solution?
Thank you
(0008443)
daniele-endian   
2013-07-12 11:02   
Hi guys,

please try with the following configuration

===========================================
root@endian:~ # cat /etc/ntop/ntop.conf.tmpl
--user ntop
--daemon
--db-file-path /var/ntop
--interface br0,br1,br2
--trace-level 3
--http-server 0
--https-server 3001
--ipv4
--max-table-rows 150
-x 1000

===========================================
Then do restartntop -f the webinterface with this config should be working fine
(0008447)
ronin   
2013-07-19 20:11   
(edited on: 2013-07-20 01:42)
Daniele-endian, I have tried this config and it appears that it has not fixed the issue. ntop appears to be working for a short period of time and then then web interface times out. when it eventually comes back, stats are reset.
Any other suggestion would be appreciated.
Thx

UPDATE: This config seems to have made the problem worse, fwiw. Availability of the service is even less now. Virtually non-existent even after the restart of ntop

UPDATE-RESOLVED: It appears that if you modify the ntop option so that the web interface is accessible via HTTP rather then HTTPS, everything works fine

(0008458)
luca-endian   
2013-08-26 08:17   
Please try with 2.5.2
(0008467)
mhLearn   
2013-08-26 09:54   
it is working after changed according to provided configuration from daniele-endian.
(0008471)
mhLearn   
2013-08-27 04:52   
it's working fine in 2.5.2
(0008474)
daniele-endian   
2013-08-27 07:15   
Ok, many thanks for the feedback. I close this bug.