SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0004545: error squid_ldap_group - MantisBT
MantisBT - Endian Firewall
View Issue Details
0004545Endian FirewallProxy - HTTPpublic2013-05-07 13:212013-06-29 19:10
rodrigor.bnu 
 
highmajorsometimes
newopen 
WindowsWindows Server 2008 R2
2.5 
 
0004545: error squid_ldap_group
Hello guys,

I started to test the Endian 2.5.1 and enjoyed. Currently I'm testing on a VM in Hyper-v. Well, already configured for integration with Active Directory and is listing the users and groups usually ok communication. I began to configure some access policies for a group of AD and early functioned properly, but after some time the policies do not work anymore and blocked everything, just out of nowhere. Since this policy is like first. When running a tail-f / var / log / squid / cache.log appear the following errors:

user filter '(&(objectClass=person)(sAMAccountName=squid))', searchbase 'dc=edusoft,dc=net'
attempting to authenticate user 'CN=squid,CN=Users,DC=edusoft,DC=net'
Connected OK
group filter '(&(objectClass=person)(sAMAccountName=squid)(memberOf=CN=Suporte,OU=Groups Edusoft,OU=Edusoft,DC=edusoft,DC=net))', searchbase 'dc=edusoft,dc=net'
squid_ldap_group WARNING, LDAP search error 'Operations error'
Connected OK
group filter '(&(objectClass=person)(sAMAccountName=squid)(memberOf=CN=Administrators,CN=Builtin,DC=edusoft,DC=net))', searchbase 'dc=edusoft,dc=net'

At another time also appeared the message:

Can't contact LDAP server

It seems that error is occurring in the validation of the AD group, but when I edit an access policy appears normally AD users and groups.

Any idea what it might be?

Rodrigo
After login and navigate the links, after some time the links are blocked released.
No tags attached.
jpg erro_endian.JPG (73,887) 2013-05-07 13:21
https://bugs.endian.com/file_download.php?file_id=1049&type=bug
jpg
Issue History
2013-05-07 13:21rodrigor.bnuNew Issue
2013-05-07 13:21rodrigor.bnuFile Added: erro_endian.JPG
2013-06-29 19:10yanqianNote Added: 0008439

Notes
(0008439)
yanqian   
2013-06-29 19:10   
Hi,
I am not familiar with endian firewall, but I got the same error before when I ran squid in a linux box, I had to add "-R" option to squid_ldap_group helper, then issue solved.