SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0004554: BCM 5788 - MantisBT
MantisBT - Endian Firewall
View Issue Details
0004554Endian FirewallHardware related (kernel, drivers, hardware)public2013-07-17 22:222018-01-14 03:31
marioeirea 
Anonymous 
normalmajoralways
closedfixed 
2.5 
future 
0004554: BCM 5788
Error at startup:

tg3: Problem fetching invariants of chip, aborting.

After start up, network adapters are unavailable.
This seems to fix the problem but only can be done after system has booted:

modprobe -r broadcom
modprobe -r tg3
modprobe broadcom
modprobe tg3
No tags attached.
duplicate of 0000001closed peter-endian Creating a backup results into a blank "Backup Sets" list 
Issue History
2013-07-17 22:22marioeireaNew Issue
2013-07-17 22:31marioeireaNote Added: 0008446
2013-09-25 14:03kieronrobNote Added: 0008538
2017-05-16 18:43AnonymousStatusnew => feedback
2018-01-14 03:31AnonymousNote Added: 0009177
2018-01-14 03:31AnonymousRelationship addedduplicate of 0000001
2018-01-14 03:31AnonymousStatusfeedback => resolved
2018-01-14 03:31AnonymousFixed in Version => 1
2018-01-14 03:31AnonymousResolutionopen => fixed
2018-01-14 03:31AnonymousAssigned To => Anonymous
2018-01-14 03:31AnonymousStatusresolved => closed
2018-01-14 03:31AnonymousFixed in Version1 => future

Notes
(0008446)
marioeirea   
2013-07-17 22:31   
I meant BCM57788
(0008538)
kieronrob   
2013-09-25 14:03   
This is how I solved it:

1. Connected an ASIX USB NIC and configured it as GREEN
2. Connected a Conexant USB ADSL Modem
3. Connect to the Endian and enable SSH
4. Connect via WinSCP
5. Edit /etc/modprobe.d/local.conf and add the following line at the end: install tg3 /sbin/modprobe broadcom; /sbin/modprobe --ignore-install tg3
6. Save
7. Edit /etc/modprobe.d/dist.conf and add the following lines at the end: install tg3 /sbin/modprobe broadcom; /sbin/modprobe --ignore-install tg3;
install skfp /sbin/modprobe marvell; /sbin/modprobe --ignore-install skfp. Note that these are two seperate lines!
8. Save
9. Reboot
10. Go into the "Network Configuration" menu on the dashboard and the NICs will be available to configure as you wish.
11. Remove the USB NIC if you wish.

I have tried this and it works, the cards I have are listed as follows in the lspci output:

01:00.0 Ethernet controller: Broadcom Corporation NetLink BCM57788 Gigabit Ethernet PCIe (rev 01)

lspci -n show it as the following:

01:00.0 0200: 14e4:1691 (rev 01)

If it stops or gives trouble, I will update.
(0009177)
Anonymous   
2018-01-14 03:31   
1"'`--