SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0000710: enable to configure http proxy - MantisBT
MantisBT - Endian Firewall
View Issue Details
0000710Endian FirewallApplication Level Proxiespublic2008-04-23 17:562009-10-27 12:03
dexters84 
simon-endian 
normalblockalways
closedfixed 
2.2-beta4 
2.2-rc1 
0000710: enable to configure http proxy
After a clean install of EFW ver. 2.2 beta4 I'm unable to configure http proxy.
After clicking button save changes on configuration page of http proxy I receive red colored message saying
Default settings are not defined.
Furthermore if I go to default policy settings and I try to change rules from unrestricted to anything else - doesn't metter if it is content scanning or antivirus - nothing changes.
I did a tail -f /var/log/messages when doing described actions and when I've executed one of the commands from log:
/usr/local/bin/restartdansguardian.py

I've received the following error:
# Error reading config /var/efw/dansguardian/default/settings
# Error reading config /var/efw/dansguardian/settings
['/var/efw/dansguardian/default']
['/var/efw/dansguardian/default']
# Error reading config /var/efw/dansguardian/default/default/settings
# Error reading config /var/efw/dansguardian/default/settings
No tags attached.
has duplicate 0000734closed simon-endian http-Proxy -- default policy 
child of 0000719closed simon-endian no content filter policy after upgrade 2.2b3->2.2b4 
? efw-interfaceeditor-2.2.22-0.endian1.noarch.rpm (12,936) 2008-04-24 15:18
https://bugs.endian.com/file_download.php?file_id=115&type=bug
? efw-proxy-2.2.54-1.endian1.noarch.rpm (72,539) 2008-04-24 15:18
https://bugs.endian.com/file_download.php?file_id=116&type=bug
? efw-base-2.6.101-1.endian3.noarch.rpm (95,590) 2008-04-24 17:02
https://bugs.endian.com/file_download.php?file_id=120&type=bug
Issue History
2008-04-23 17:56dexters84New Issue
2008-04-23 18:03dexters84Note Added: 0001027
2008-04-23 18:06simon-endianNote Added: 0001028
2008-04-23 18:06simon-endianAssigned To => simon-endian
2008-04-23 18:06simon-endianStatusnew => confirmed
2008-04-23 18:10simon-endianNote Edited: 0001028
2008-04-24 08:37tethienNote Added: 0001030
2008-04-24 08:38tethienNote Deleted: 0001030
2008-04-24 08:42tethienNote Added: 0001031
2008-04-24 08:43tethienNote Edited: 0001031
2008-04-24 13:21simon-endianRelationship addedchild of 0000719
2008-04-24 15:14simon-endianStatusconfirmed => resolved
2008-04-24 15:14simon-endianFixed in Version => 2.2-rc1
2008-04-24 15:14simon-endianResolutionopen => fixed
2008-04-24 15:14simon-endianNote Added: 0001056
2008-04-24 15:16simon-endianStatusresolved => feedback
2008-04-24 15:16simon-endianResolutionfixed => reopened
2008-04-24 15:17simon-endianFile Added: efw-base-2.6.100-1.endian3.noarch.rpm
2008-04-24 15:18simon-endianFile Added: efw-interfaceeditor-2.2.22-0.endian1.noarch.rpm
2008-04-24 15:18simon-endianFile Added: efw-proxy-2.2.54-1.endian1.noarch.rpm
2008-04-24 15:19simon-endianStatusfeedback => resolved
2008-04-24 15:19simon-endianResolutionreopened => fixed
2008-04-24 15:19simon-endianNote Added: 0001057
2008-04-24 17:02simon-endianStatusresolved => feedback
2008-04-24 17:02simon-endianResolutionfixed => reopened
2008-04-24 17:02simon-endianFile Deleted: efw-base-2.6.100-1.endian3.noarch.rpm
2008-04-24 17:02simon-endianFile Added: efw-base-2.6.101-1.endian3.noarch.rpm
2008-04-24 17:04simon-endianStatusfeedback => resolved
2008-04-24 17:04simon-endianResolutionreopened => fixed
2008-04-24 17:33wildchildStatusresolved => feedback
2008-04-24 17:33wildchildResolutionfixed => reopened
2008-04-24 17:33wildchildNote Added: 0001062
2008-04-24 17:43simon-endianNote Added: 0001063
2008-04-24 17:43simon-endianStatusfeedback => assigned
2008-04-25 07:04tethienNote Added: 0001073
2008-04-25 07:20ra-endianNote Added: 0001074
2008-04-25 08:28tethienNote Added: 0001075
2008-05-02 13:34simon-endianRelationship addedhas duplicate 0000734
2008-05-02 13:35simon-endianStatusassigned => resolved
2008-05-02 13:35simon-endianResolutionreopened => fixed
2009-10-27 12:03peter-endianStatusresolved => closed

Notes
(0001027)
dexters84   
2008-04-23 18:03   
the title should be "unable to configure http proxy" - sorry for that
(0001028)
simon-endian   
2008-04-23 18:06   
(edited on: 2008-04-23 18:10)
- default policy rules cgi has a js bug which resets the settings before saving
- default settings not defined errormessage -> permissionproblem or emtpy file (/var/efw/proxy/settings) need to make fallback if settingsfile is empty

(0001031)
tethien   
2008-04-24 08:42   
(edited on: 2008-04-24 08:43)
-default policy allway become "unrestricted" on rule 1
-I can create rule "content filter + antivirus scan" or "antivirus scan only" on rule 2. But if I move it to rule 1 it will become "unrestricted"!!!

(0001056)
simon-endian   
2008-04-24 15:14   
fixed the bug
-> restartscript did not find rule1 so he added defaultrule which deleted the original rule
-> fom.js did collide with js from defaultpolicy -> new proxyprofile.js fixed problem
-> cgi did not check if /var/efw/proxy/settings was empty -> now default settings are used if it is empty

i will add the rpms which should fix the problem.

thx for testing. it would be nice if you could inform me, if any of the problem inf bug 0000710 and 0000719 still occur.

greatz simon
(0001057)
simon-endian   
2008-04-24 15:19   
added rpms
(0001062)
wildchild   
2008-04-24 17:33   
To get it to work for myself even after installing the updated packages I modified advproxy.cgi since /var/efw/proxy/profiles/default didnt exist.

        #check if default profiledir exists
- if (!-d "$profiledir/default") {
+ if (!-d "$profiledir/defaultprofile") {
            $errormessage = _("Default settings are not defined.")
        }
        else {
            system("/usr/local/bin/restartsquid --force");
        }
(0001063)
simon-endian   
2008-04-24 17:43   
thx, will fix this.

simon
(0001073)
tethien   
2008-04-25 07:04   
Can't change Authentication type to "none" ?
In the list only have Local, LDAP, Windows, Radius !!!
(0001074)
ra-endian   
2008-04-25 07:20   
please choose "no authentication" or "transparent" on green or blue or orange ( Proxy->HTTP->Configuration )
(0001075)
tethien   
2008-04-25 08:28   
in that case. i think you can disable Authentication type if choosed "no authentication" or "transparent"