SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0000770: uplinkeditor.cgi loops for ever, so selecting "Interfaces" on the Network tab stalls. - MantisBT
MantisBT - Endian Firewall
View Issue Details
0000770Endian FirewallNetwork related (VPN, uplinks)public2008-05-07 14:322008-07-27 20:18
jsalgado 
simon-endian 
normalblockalways
closedfixed 
2.2-beta4 
2.2-rc2 
0000770: uplinkeditor.cgi loops for ever, so selecting "Interfaces" on the Network tab stalls.
I set up 2 pppoe uplinks, and then tried to apply the "if this linkg goes down.. " checkbox , then both links went down, and the manager webpages looped with no results.

I logged via ssh and saw uplinkeditor.cgi on 99% CPU LOAD, i waited for an hour and the process never ended.

There was no way to access the uplinks to delete or modify anything. until I went to the network wizard and set the red interface to static. Then uplinks became accesible but they both kind of lost their config.
No tags attached.
? efw-configroot-2.2.47.test3-0.endian7.noarch.rpm (29,466) 2008-05-15 08:35
https://bugs.endian.com/file_download.php?file_id=140&type=bug
? efw-interfaceeditor-2.2.23.test29-0.endian1.noarch.rpm (13,254) 2008-05-15 08:35
https://bugs.endian.com/file_download.php?file_id=141&type=bug
Issue History
2008-05-07 14:32jsalgadoNew Issue
2008-05-07 14:32jsalgadoStatusnew => assigned
2008-05-07 14:32jsalgadoAssigned To => peter-endian
2008-05-07 14:45ra-endianAssigned Topeter-endian => simon-endian
2008-05-14 11:26simon-endianReproducibilityhave not tried => unable to reproduce
2008-05-15 08:33simon-endianNote Added: 0001173
2008-05-15 08:33simon-endianReproducibilityunable to reproduce => always
2008-05-15 08:35simon-endianFile Added: efw-configroot-2.2.47.test3-0.endian7.noarch.rpm
2008-05-15 08:35simon-endianFile Added: efw-interfaceeditor-2.2.23.test29-0.endian1.noarch.rpm
2008-05-15 08:37simon-endianStatusassigned => resolved
2008-05-15 08:37simon-endianFixed in Version => 2.2
2008-05-15 08:37simon-endianResolutionopen => fixed
2008-05-15 08:37simon-endianNote Added: 0001174
2008-05-15 17:33jsalgadoStatusresolved => feedback
2008-05-15 17:33jsalgadoResolutionfixed => reopened
2008-05-15 17:33jsalgadoNote Added: 0001184
2008-05-15 17:34jsalgadoStatusfeedback => resolved
2008-05-15 17:34jsalgadoResolutionreopened => fixed
2008-07-24 15:55ra-endianFixed in Version2.2 => 2.2-rc2
2008-07-27 20:18peter-endianStatusresolved => closed

Notes
(0001173)
simon-endian   
2008-05-15 08:33   
happens when uplink1 is backup of uplink2 and uplink2 is backup of uplink1
(0001174)
simon-endian   
2008-05-15 08:37   
i fixed the bug and attached 2 rpms.
could you install them and test if it works now?

greatz simon
(0001184)
jsalgado   
2008-05-15 17:33   
Thank you very much Simon, I have instaled both rpms, and made some tests.

I may confirm the issue is solved. I tested with my system, and I have no more infinite loop on the uplink web tab.

good job! =)