SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0000102: proxy no longer allows any access - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000102Endian FirewallApplication Level Proxiespublic2007-02-09 03:432007-07-11 09:05
Reportercode_slave 
Assigned Topeter-endian 
PrioritynormalSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.1 
Target VersionFixed in Version 
Summary0000102: proxy no longer allows any access
DescriptionIN VERSION 2.0 the proxy functioned correctly, when enabled on green & transparent on green
with no user login

indeed "group management/Activated groups/advanced "oprions all disabled.

after saving out a backup of the settings and upgrading to 2.1 the proxy stopped working.(it blocked all access)
now i have to turn off 'enabled on green & transparent on green'
to allow users access to the internet, but now my contentfiltering is disabled.


TagsNo tags attached.
Attached Files? file icon efw-proxy-2.1.24-0.endian6.i386.rpm [^] (44,695 bytes) 2007-02-12 13:59

- Relationships
has duplicate 0000132closedpeter-endian Riferimento all'interfaccia ORANGE non definita 
has duplicate 0000144closedpeter-endian Web Proxy Won't Start 
has duplicate 0000167closedpeter-endian Errore in /etc/squid/squidconf 
has duplicate 0000170closedpeter-endian Web Proxy not starting 
has duplicate 0000176closedpeter-endian Web Proxy not starting 

-  Notes
(0000164)
code_slave (reporter)
2007-02-12 03:11

it seems that even after completely re-installing the firewall and doing a reconfigure from scratch (not using the backup option) , the web proxy is always showing stopped in the status list.

I can see no errors in the 'messages' file to indicate a problem.
(0000165)
peter-endian (administrator)
2007-02-12 08:57

this is a bug and happens if you do not have the orange zone.
enable orange and it will start working again

we fixed this bug already and it's included in 2.2
(0000166)
code_slave (reporter)
2007-02-12 09:05
edited on: 2007-02-12 09:06

I do have an orange , green and red, but no blue and it still does not work!!.

green =192.168.2.2
orange=192.168.3.1
red =59.37.49.50

(0000167)
peter-endian (administrator)
2007-02-12 09:24

try to enable all zones, it should work then

if not please look into squids logfile /var/log/squid/cache.log and send us the error message
(0000168)
code_slave (reporter)
2007-02-12 09:37

when you say enable all zones , i assume you mean
1. goto "proxy" tab
2. enable transparent on green& orange
3. enable "enable " on green & orange.
4. save & restart.

even rebooting will not get it started.
also in the "status" tab it shows "web proxy" as stopped.
finally there is no file ' /var/log/squid/cache.log'
(0000169)
peter-endian (administrator)
2007-02-12 09:43

no i mean configure blue&orange within network wizard.
the proxy configuration script tries to add acl rules for each zone even if they do not exist on the firewall.
(0000170)
code_slave (reporter)
2007-02-12 09:49

I really apreciate your help peter,

but i already have RED , GREEN & ORANGE enabled in the wizard, infact they must be enabled and working because i am using the internet now.
I can even see the lights flashing on the 3 network cards, to indicate traffic.
(0000171)
peter-endian (administrator)
2007-02-12 10:11

oh, so i misunderstood you, sorry

can you please post the error messages from squid log file?
they should help
(0000172)
code_slave (reporter)
2007-02-12 10:50

there is no log file for SQUID!!

'/var/log/squid/cache.log'

is missing , which would indicate it does not even get launched.

where do i need to look for the script that runs SQUID?
(0000173)
peter-endian (administrator)
2007-02-12 11:09

you can manually start it with
squid -D
then you should directly get the error message since it directly will stop working
(0000174)
code_slave (reporter)
2007-02-12 12:17
edited on: 2007-02-12 12:19

Thanks peter!!!
here it is

2007/02/12 20:16:59| ACL name 'EFW_dst_blue' not defined!
FATAL: Bungled squid.conf line 80: http_access deny EFW_src_orange EFW_dst_blue
Squid Cache (Version 2.5.STABLE11): Terminated abnormally.

I don't have a blue , so how can i hack it until the 2.2 is released.

(0000175)
peter-endian (administrator)
2007-02-12 14:01

well, i know this issue and we managed it to resolve the problem by activating all zones with the network wizard.

try to install the update which i attached here

rpm -U efw-proxy-2.1.24-0.endian6.i386.rpm

it should work then.
(0000187)
peter-endian (administrator)
2007-02-21 16:29

is this now working?
(0000193)
code_slave (reporter)
2007-02-27 00:58

yes it is now fixed!!

- Issue History
Date Modified Username Field Change
2007-02-09 03:43 code_slave New Issue
2007-02-12 03:11 code_slave Note Added: 0000164
2007-02-12 08:57 peter-endian Note Added: 0000165
2007-02-12 08:57 peter-endian Status new => confirmed
2007-02-12 08:57 peter-endian Status confirmed => resolved
2007-02-12 08:57 peter-endian Resolution open => fixed
2007-02-12 08:57 peter-endian Assigned To => peter-endian
2007-02-12 09:05 code_slave Status resolved => feedback
2007-02-12 09:05 code_slave Resolution fixed => reopened
2007-02-12 09:05 code_slave Note Added: 0000166
2007-02-12 09:06 code_slave Note Edited: 0000166
2007-02-12 09:24 peter-endian Note Added: 0000167
2007-02-12 09:37 code_slave Note Added: 0000168
2007-02-12 09:43 peter-endian Note Added: 0000169
2007-02-12 09:49 code_slave Note Added: 0000170
2007-02-12 10:11 peter-endian Note Added: 0000171
2007-02-12 10:50 code_slave Note Added: 0000172
2007-02-12 11:09 peter-endian Note Added: 0000173
2007-02-12 12:17 code_slave Note Added: 0000174
2007-02-12 12:19 code_slave Note Edited: 0000174
2007-02-12 13:59 peter-endian File Added: efw-proxy-2.1.24-0.endian6.i386.rpm
2007-02-12 14:01 peter-endian Note Added: 0000175
2007-02-21 16:29 peter-endian Note Added: 0000187
2007-02-27 00:58 code_slave Note Added: 0000193
2007-02-27 09:39 peter-endian Status feedback => resolved
2007-02-27 09:39 peter-endian Resolution reopened => fixed
2007-03-12 16:45 peter-endian Relationship added has duplicate 0000132
2007-03-18 15:27 peter-endian Relationship added has duplicate 0000144
2007-04-29 20:56 peter-endian Relationship added has duplicate 0000167
2007-05-01 17:43 peter-endian Relationship added has duplicate 0000170
2007-05-10 14:42 peter-endian Relationship added has duplicate 0000176
2007-07-11 09:05 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker