SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0001020: generic spinner for gui - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001020Endian FirewallGUIpublic2008-06-26 08:442008-10-08 13:30
Reporterpeter-endian 
Assigned Tolukas-endian 
PriorityurgentSeverityfeatureReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.2-rc1 
Target Version2.2-rc3Fixed in Version2.2-rc3 
Summary0001020: generic spinner for gui
Descriptionsince our restart scripts run in background we need a spinner which informs the user that the script is still running.

as of now the GUI says "service yet another service restarted successfully" immediately after the save button has been pushed. This is not true, since the script is actually running in background and the user should wait until it is done. Then a notification message should be shown.


Solution:
- create a generic spinner "widget" for the GUI which runs if a service specific status file exists (/var/lock/services/openvpn)
- create a python class ServiceStatus which can be used by every restartscript which can:
  o create the status file at the very beginning of the restartscript
  o remove the status file at the end of the restartscript
  o the status file contains a JSON string
  o writes status messages into the file (.notify()). notify() can be triggered while the script is running, so the GUI displays what is going on.
  X .notify() could be combined with logger.info()/error() (.debug()?? when enabled) in a later task
  o the status file could contain a history of the last notifications
- spinner "widget" should display a notification regarding the content of the status file, if it exists.
- status history could be optionally displayed by the spinner widget
- If the status file does not exist anymore, the last message should be displayed on the GUI and removed with the next http request.
- error messages should be displayed with a respective spinner icon.

pay attention about permissions
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2008-06-26 08:44 peter-endian New Issue
2008-06-26 08:44 peter-endian Status new => assigned
2008-06-26 08:44 peter-endian Assigned To => lukas-endian
2008-06-26 08:45 peter-endian Description Updated
2008-06-26 08:48 peter-endian Description Updated
2008-06-26 08:52 peter-endian Description Updated
2008-06-26 08:56 peter-endian Description Updated
2008-06-26 09:04 peter-endian Description Updated
2008-06-30 10:21 peter-endian Relationship added related to 0000934
2008-07-10 18:52 peter-endian Priority normal => urgent
2008-07-24 16:05 ra-endian Target Version 2.2-rc2 => 2.2-rc3
2008-08-19 17:02 lukas-endian Status assigned => resolved
2008-08-19 17:02 lukas-endian Fixed in Version => 2.2-rc3
2008-08-19 17:02 lukas-endian Resolution open => fixed
2008-10-08 13:30 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker