SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0001039: iptables has a race condition when it will be started in parallel - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001039Endian FirewallFirewall (iptables)public2008-06-30 10:172008-07-27 20:18
Reporterpeter-endian 
Assigned Topeter-endian 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.2-rc1 
Target Version2.2-rc2Fixed in Version2.2-rc2 
Summary0001039: iptables has a race condition when it will be started in parallel
Descriptioniptables need to be locked in order to have it running only once at the same time.
Otherwise iptables returns with "Ressource temporary unavailable" when two processes try to commit the configuration to the kernel at the same time.

This causes the firewall scripts to not create all necessary rules and leave away some randomly.
TagsNo tags attached.
Attached Files

- Relationships
related to 0000923closedpeter-endian setxtaccess: sometimes it does not create rules because of the iptablesxtaccess cache file. 
related to 0000948closedpeter-endian DNS not working 

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2008-06-30 10:17 peter-endian New Issue
2008-06-30 10:17 peter-endian Status new => assigned
2008-06-30 10:17 peter-endian Assigned To => peter-endian
2008-06-30 10:18 peter-endian Status assigned => resolved
2008-06-30 10:18 peter-endian Fixed in Version => 2.2-rc2
2008-06-30 10:18 peter-endian Resolution open => fixed
2008-06-30 10:18 peter-endian Relationship added related to 0000923
2008-06-30 10:18 peter-endian Relationship added related to 0000948
2008-07-27 20:18 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker