SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0000105: POP3 proxy not passing traffic - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000105Endian FirewallApplication Level Proxiespublic2007-02-10 14:442009-03-15 08:45
ReporterBigTy 
Assigned Topeter-endian 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.1 
Target VersionFixed in Version 
Summary0000105: POP3 proxy not passing traffic
DescriptionWhen using Apple's Mac mail with any default pop3 will not pass through while proxy is active. Out look works b very slowly.
Additional Information1.7gig processor
512MB of ram.
20gig HD
TagsNo tags attached.
Attached Files

- Relationships
has duplicate 0000154closedra-endian P3scan hangs on receiving mails! 
has duplicate 0000216acknowledgedpeter-endian POP3 proxy: spamd cannot read/write to whitelist DB 

-  Notes
(0000226)
sbeavan (reporter)
2007-03-13 03:19

I also have issues with POP3 proxy. Using outlook express and yahoo mail, I have premium Yahoo account with pop access pop.mail.yahoo.com but it times out with Outlook Express. Thunderbird seemed to be OK..
(0000230)
peter-endian (administrator)
2007-03-13 15:03

we noticed that the pyzor host is currently down, therefore the pyzor request waits until a timeout. we can't really do anything to change this situation, so we added an option which let's the user choose whether he/she likes to use pyzor or not. (only for pop3 proxy, for smtp proxy this slowness does not interest much)

due to the timeout with spamassassin the mac clients also timeout. you may try to manually disable pyzor by editing the configuration template /etc/spamassassin/local.cf.tmpl, search the line
use_pyzor 1
and change the 1 to a 0:
use_pyzor 0

then restart pop3 proxy and it sould work again..
please confirm if this helps
(0000374)
Chris van Heyningen (reporter)
2007-07-02 09:37

I tried to use the 'use_pyzor 0' method.
But it didn't work.

Any other solution?

This problem is (what I see) only bij Apple Mail.
(0000389)
mboss (reporter)
2007-07-06 08:32

I had the same kind of problems using the POP3 proxy feature:
my email client (kmail) was hanging after getting the few first emails.

I figured out the following ISSUE:
my spamd-log in /var/log/spamd/spamd.log reported the following 2 lines
for each "refused" mail:
>>Jul 5 18:03:19 asterix spamd[8082]: auto-whitelist: cannot open auto_whitelist_path /var/lib/spamassassin/auto-whitelist: Permission denied
>>Jul 5 18:03:19 asterix spamd[8082]: auto-whitelist: open of auto-whitelist file failed: auto-whitelist: cannot open auto_whitelist_path /var/lib/spamassassin/auto-whitelist: Permission denied

And, surprise, file permission for /var/lib/spamassassin/auto-whitelist
was set to read/write access for user 'root' and group 'root' only;
I changed ownership to 'amavis' and group to 'amavis' (which is the
user running spamd process) and everything is FINE now.
(0001766)
CIURI (reporter)
2008-11-01 08:11

I use thunderbird and pop3 proxy and when I enable it emails are not been received
any more :|

In the logs I don't see any errors ,strange .

Nov 1 09:59:03 router1 p3scan[1149]: P3Scan Version 2.3.2
Nov 1 09:59:03 router1 p3scan[1149]: Selected scannertype: basic (Basic file invocation scanner)
Nov 1 09:59:03 router1 p3scan[1149]: Listen now on 0.0.0.0:8110
Nov 1 09:59:03 router1 p3scan[1150]: Changing uid (we are root)
Nov 1 09:59:03 router1 p3scan[1150]: Running as user: clamav
Nov 1 09:59:12 router1 p3scan[1160]: POP3S Connection from 15.1.1.9:1253
Nov 1 09:59:12 router1 p3scan[1160]: Real-server address is 72.14.221.109:995
Nov 1 09:59:12 router1 p3scan[1160]: Session done (Clean Exit). Mails: 0 Bytes: 0
(0002043)
raphael-endian (administrator)
2009-03-15 08:45

Fixed in 2.2

- Issue History
Date Modified Username Field Change
2007-02-10 14:44 BigTy New Issue
2007-03-13 03:19 sbeavan Note Added: 0000226
2007-03-13 15:03 peter-endian Note Added: 0000230
2007-03-13 15:03 peter-endian Status new => confirmed
2007-04-12 17:01 peter-endian Relationship added has duplicate 0000154
2007-07-02 09:37 Chris van Heyningen Note Added: 0000374
2007-07-06 08:32 mboss Note Added: 0000389
2007-10-28 14:17 peter-endian Status confirmed => assigned
2007-10-28 14:17 peter-endian Assigned To => peter-endian
2007-10-28 14:39 peter-endian Relationship added has duplicate 0000216
2008-06-29 06:47 raphael-endian Status assigned => closed
2008-06-29 06:47 raphael-endian Resolution open => fixed
2008-08-08 11:14 peter-endian Status closed => confirmed
2008-11-01 08:11 CIURI Note Added: 0001766
2009-03-15 08:45 raphael-endian Note Added: 0002043
2009-03-15 08:45 raphael-endian Status confirmed => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker