SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0001134: creating zone subnet acl if <zone>_IPS ends with , fails - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001134Endian FirewallProxy HTTPpublic2008-07-16 23:532008-07-27 20:18
Reportersimon-endian 
Assigned Tosimon-endian 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version2.2-rc2 
Summary0001134: creating zone subnet acl if <zone>_IPS ends with , fails
Descriptionif <zone>_IPS ends with , the creation of a new zone subnet acl fail because cidr from empty string can├čt be generated


Additional InformationTraceback (most recent call last):
  File "/usr/local/bin/restartsquid.py", line 1628, in ?
    checkSubnets()
  File "/usr/local/bin/restartsquid.py", line 1012, in checkSubnets
    createZoneSubnets(zone)
  File "/usr/local/bin/restartsquid.py", line 975, in createZoneSubnets
    newnets = map(lambda x: cidrnet2nmnet(x), newnets)
  File "/usr/local/bin/restartsquid.py", line 975, in <lambda>
    newnets = map(lambda x: cidrnet2nmnet(x), newnets)
  File "/usr/local/bin/restartsquid.py", line 860, in cidrnet2nmnet
    obj = iplib.CIDR(net)
  File "/usr/lib/python2.4/site-packages/iplib.py", line 611, in __init__
    self.set(ip, netmask)
  File "/usr/lib/python2.4/site-packages/iplib.py", line 619, in set
    raise ValueError, 'set: invalid CIDR: "' + str(ip) + '"'

TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0001455)
simon-endian (developer)
2008-07-16 23:57

- if <zone>_IPS in /var/efw/ethernet/settings ends with , the emtpy string in the split array is deleted

- Issue History
Date Modified Username Field Change
2008-07-16 23:53 simon-endian New Issue
2008-07-16 23:53 simon-endian Status new => assigned
2008-07-16 23:53 simon-endian Assigned To => simon-endian
2008-07-16 23:57 simon-endian Status assigned => resolved
2008-07-16 23:57 simon-endian Fixed in Version => 2.2-rc2
2008-07-16 23:57 simon-endian Resolution open => fixed
2008-07-16 23:57 simon-endian Note Added: 0001455
2008-07-27 20:18 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker