SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0000117: Memory leak - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000117Endian FirewallOther Servicespublic2007-02-19 12:532007-12-31 19:15
Reporterbtvrugt 
Assigned Topeter-endian 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.1 
Target VersionFixed in Version2.2-beta2 
Summary0000117: Memory leak
DescriptionOur EFW is eating memory, i think there is a memory leak somewhere.
This only happens when smtp proxy is turned on (so i think its in antispam/virus)
Here is a screenshot of memory usage per week. (we did a reboot on friday so whe wouldnt have problems in the weekend)
http://img245.imageshack.us/img245/4745/memoryweekpd1.png [^]

List of services:
CRON server RUNNING
Content filter STOPPED
DHCP Server RUNNING
DNS proxy server RUNNING
E-Mail scanner (POP3) STOPPED
FTP virus scanner STOPPED
HTTP antivirus (havp) STOPPED
Intrusion Detection System (GREEN) STOPPED
Intrusion Detection System (RED main) RUNNING
Kernel logging server RUNNING
Logging server RUNNING
NTP Server RUNNING
Openvpn Server STOPPED
Pyzor Spamfilter STOPPED
Secure shell server RUNNING
Sip Proxy STOPPED
Spamfilter for POP3 (spamd) STOPPED
Spamfilter for SMTP (amavis) RUNNING
VPN (ipsec) STOPPED
Virus scanner RUNNING
Web proxy STOPPED
Web server RUNNING

We do not discard any mails. we all forward them with modified header en do not quaritine them.
TagsNo tags attached.
Attached Filespng file icon memory-week.PNG [^] (28,707 bytes) 2007-02-19 12:53


png file icon memory-week2.png [^] (31,462 bytes) 2007-02-23 15:08


? file icon efw-clamav-2.0.23-0.endian1.i386.rpm [^] (12,601 bytes) 2007-02-26 09:30
? file icon amavisd-new-2.4.5-1.rf.endian12.i386.rpm [^] (258,841 bytes) 2007-03-05 16:31
? file icon clamav-0.90.1-0.endian6.i386.rpm [^] (312,792 bytes) 2007-03-05 16:33

- Relationships
parent of 0000127closedpeter-endian Proxy no longer allows access 

-  Notes
(0000185)
peter-endian (administrator)
2007-02-19 13:24

interesting

could you please send us the output of
ps aux
of different days, in order to enable us to isolate the growing process?
(0000186)
btvrugt (reporter)
2007-02-19 13:29
edited on: 2007-02-19 13:31

im not a linux guru so i think you want this:
http://www.hardnet.nl/tmp/psaux.txt [^]

(0000188)
btvrugt (reporter)
2007-02-23 15:10

a week later still memory eating
ps aux:
http://www.hardnet.nl/tmp/psaux2.txt [^]

and i attached a new screenshot
(0000189)
peter-endian (administrator)
2007-02-23 17:01

can you please provide us hardware specifications, first of all how much ram do you have?

this is strange since we do not have this problem on our installations. the only difference we have, is, that we do not activate snort
can you try to disable snort? maybe that's the evil here.

clamd is also growing much, we provide an update with the next release.
(0000190)
btvrugt (reporter)
2007-02-26 08:37

hardware specs:
HP gl320 G5
Intel Xeon 2,13 dual core
1 gig RAM
80gb SATA

This weekend i disabled the smtp virus scanner and i removed the spam/virus admin e-mail so it will not send any reports of the e-mails that where blocked.
Now it is not eating memory so its either in the virus scanner or the spam admin.

This week i will add my e-mail address again as spam admin and will look if that is the problem.
(0000191)
peter-endian (administrator)
2007-02-26 09:33

try to upgrade amavisd-new and clamav with the packages i provided here.
you can upgrade by downloading them to your firewall and install them with:
rpm -U --force package1.rpm package2.rpm ...

the clamav package will need you to install also clamav-db, however it was too big to upload here. it will install nevertheless (because of the --force). since that package contains only clamav signatures, which will be downloaded by freshclam, there is no issue to expect from this missing dependency.

pay attention to install efw-clamav, since it contains new configuration templates, which will be needed in order to have clamav working, since clamav slightly changed it's configuration syntax.
(0000201)
aender (reporter)
2007-03-01 10:14

Sorry Peter.
But installing of the clamav-0.90 doesn´t work!!

 rpm -U --force clamav-0.90-0.endian6.i386.rpm
error: Failed dependencies:
        clamav-db = 0.90-0.endian6 is needed by clamav-0.90-0.endian6.i386

Can you post the clamav-db??
(0000202)
aender (reporter)
2007-03-01 10:20
edited on: 2007-03-01 10:31

Sorry.

The correct syntax to install clamav-0.90-0 is:

rpm -U --force --nodeps clamav-0.90-0.endian6.i386.rpm

So you can also download all files and then type in

rpm -U --force --nodeps *.rpm

(0000203)
peter-endian (administrator)
2007-03-01 11:03

ah, sorry
it's --nodeps instead of --force
(0000207)
aender (reporter)
2007-03-05 13:43

Hello.

Can you give us a new clamav engine?

Latest ClamAV™ stable release is: 0.90.1
(0000208)
ra-endian (administrator)
2007-03-05 16:45

attached amavisd-new 2.4.5 and clamav 0.90.1


Thank you
(0000221)
peter-endian (administrator)
2007-03-11 17:48
edited on: 2007-03-11 17:54

you need also the new havp packet and the perl-Mail-Clamav packet from http://www.stellarcore.net/downloads/efw2-updates/, [^] otherwise http proxy will not work anymore with antivirus enabled

enterprise version has already included the new clamav engine, we certainly include it also within next community release. as we have seen it makes trouble to release single packages, so it's maybe better if you wait until the next community release (until we can manage this better) or get in touch with our sales department in order to get an enterprise version.


- Issue History
Date Modified Username Field Change
2007-02-19 12:53 btvrugt New Issue
2007-02-19 12:53 btvrugt File Added: memory-week.PNG
2007-02-19 13:24 peter-endian Note Added: 0000185
2007-02-19 13:29 btvrugt Note Added: 0000186
2007-02-19 13:31 btvrugt Note Edited: 0000186
2007-02-23 15:08 btvrugt File Added: memory-week2.png
2007-02-23 15:10 btvrugt Note Added: 0000188
2007-02-23 17:01 peter-endian Note Added: 0000189
2007-02-26 08:37 btvrugt Note Added: 0000190
2007-02-26 09:27 peter-endian File Added: amavisd-new-2.4.4-1.rf.endian12.i386.rpm
2007-02-26 09:28 peter-endian File Added: clamav-0.90-0.endian6.i386.rpm
2007-02-26 09:30 peter-endian File Added: efw-clamav-2.0.23-0.endian1.i386.rpm
2007-02-26 09:33 peter-endian Note Added: 0000191
2007-02-28 09:48 peter-endian Status new => assigned
2007-02-28 09:48 peter-endian Assigned To => peter-endian
2007-03-01 10:14 aender Note Added: 0000201
2007-03-01 10:20 aender Note Added: 0000202
2007-03-01 10:31 aender Note Edited: 0000202
2007-03-01 11:03 peter-endian Note Added: 0000203
2007-03-05 13:43 aender Note Added: 0000207
2007-03-05 16:31 ra-endian File Added: amavisd-new-2.4.5-1.rf.endian12.i386.rpm
2007-03-05 16:33 ra-endian File Added: clamav-0.90.1-0.endian6.i386.rpm
2007-03-05 16:33 ra-endian File Deleted: amavisd-new-2.4.4-1.rf.endian12.i386.rpm
2007-03-05 16:33 ra-endian File Deleted: clamav-0.90-0.endian6.i386.rpm
2007-03-05 16:45 ra-endian Note Added: 0000208
2007-03-11 17:48 peter-endian Note Added: 0000221
2007-03-11 17:48 peter-endian Relationship added parent of 0000127
2007-03-11 17:54 peter-endian Note Edited: 0000221
2007-10-27 21:57 peter-endian Status assigned => resolved
2007-10-27 21:57 peter-endian Resolution open => fixed
2007-12-31 19:15 raphael-endian Fixed in Version => 2.2-beta2
2007-12-31 19:15 raphael-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker