SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0001274: When a change to OpenVPN is made, restart is needed - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001274Endian FirewallNetwork related (VPN, uplinks)public2008-08-15 01:412008-10-08 13:30
Reporterkfason 
Assigned Topeter-endian 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.2-rc2 
Target VersionFixed in Version2.2-rc3 
Summary0001274: When a change to OpenVPN is made, restart is needed
DescriptionWhen making a change in OpenVPN GUI. enabling, changed nameservers field etc many services stop working. 10443 stops working, ssh to the EFW stops working. If you log in via console it puts the following error message on screen and into /var/log/messages.

I tried bringing tap1 down and back up to no avail. If you do a shutdown -r now it starts shutting down and stops at trying to dismount root filesystem. You have ot powercycle it at this point.

I tried this on two 2.2rc2. One that was setup new, and onother that had a backup from 2.2rc1 restored.
Additional InformationEFW kernel: unregister_netdevice: waiting for tap1 to become free. Usage count = -1
TagsNo tags attached.
Attached Files

- Relationships
duplicate of 0001192closedpeter-endian removeing tap device from bridge freezes the machine 

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2008-08-15 01:41 kfason New Issue
2008-08-15 01:41 kfason Status new => assigned
2008-08-15 01:41 kfason Assigned To => peter-endian
2008-08-18 10:00 peter-endian Relationship added duplicate of 0001192
2008-08-18 10:00 peter-endian Status assigned => resolved
2008-08-18 10:00 peter-endian Fixed in Version => 2.2-rc3
2008-08-18 10:00 peter-endian Resolution open => fixed
2008-10-08 13:30 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker