SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0001296: When a link goes down the machine appears to freeze. - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001296Endian FirewallNetwork related (VPN, uplinks)public2008-09-02 00:502009-10-27 12:02
Reporterjvodan 
Assigned Topeter-endian 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.2-rc2 
Target VersionFixed in Version2.3 
Summary0001296: When a link goes down the machine appears to freeze.
DescriptionBaiscally if/when a pppoe link goes down, it doesn't came back up
The following log extract shows what is happening.
The log continues for ever until the box is rebooted.

Sep 2 10:35:38 install pppd[8165]: No response to 3 echo-requests
Sep 2 10:35:38 install pppd[8165]: Serial link appears to be disconnected.
Sep 2 10:35:38 install pppd[8165]: Connect time 19.0 minutes.
Sep 2 10:35:38 install pppd[8165]: Sent 15154 bytes, received 52525 bytes.
Sep 2 10:35:39 install uplink[main]: Notify uplinks daemon about status change of uplink 'main'. Status id FAILED
Sep 2 10:35:44 install pppd[8165]: Connection terminated.
Sep 2 10:35:45 install uplink[main]: Starting Uplink 'main'
Sep 2 10:35:54 install kernel: unregister_netdevice: waiting for ppp0 to become free. Usage count = -1
Sep 2 10:36:05 install kernel: unregister_netdevice: waiting for ppp0 to become free. Usage count = -1
Sep 2 10:36:15 install kernel: unregister_netdevice: waiting for ppp0 to become free. Usage count = -1
Sep 2 10:36:25 install kernel: unregister_netdevice: waiting for ppp0 to become free. Usage count = -1
Sep 2 10:36:35 install kernel: unregister_netdevice: waiting for ppp0 to become free. Usage count = -1
Sep 2 10:36:46 install kernel: unregister_netdevice: waiting for ppp0 to become free. Usage count = -1
Sep 2 10:36:56 install kernel: unregister_netdevice: waiting for ppp0 to become free. Usage count = -1
Sep 2 10:37:06 install kernel: unregister_netdevice: waiting for ppp0 to become free. Usage count = -1
Sep 2 10:37:16 install kernel: unregister_netdevice: waiting for ppp0 to become free. Usage count = -1
Sep 2 10:37:26 install kernel: unregister_netdevice: waiting for ppp0 to become free. Usage count = -1
Sep 2 10:37:37 install kernel: unregister_netdevice: waiting for ppp0 to become free. Usage count = -1
Sep 2 10:37:47 install kernel: unregister_netdevice: waiting for ppp0 to become free. Usage count = -1
Sep 2 10:37:57 install kernel: unregister_netdevice: waiting for ppp0 to become free. Usage count = -1
Sep 2 10:38:07 install kernel: unregister_netdevice: waiting for ppp0 to become free. Usage count = -1
Sep 2 10:38:18 install kernel: unregister_netdevice: waiting for ppp0 to become free. Usage count = -1
Sep 2 10:38:28 install kernel: unregister_netdevice: waiting for ppp0 to become free. Usage count = -1
Sep 2 10:38:38 install kernel: unregister_netdevice: waiting for ppp0 to become free. Usage count = -1
Sep 2 10:38:39 install kernel: eth1: link down
Sep 2 10:38:39 install kernel: eth1: link up, 10Mbps, half-duplex, lpa 0x0000
Sep 2 10:38:41 install kernel: eth1: link down
Sep 2 10:38:41 install kernel: eth1: link up, 10Mbps, half-duplex, lpa 0x0000
Sep 2 10:38:48 install kernel: unregister_netdevice: waiting for ppp0 to become free. Usage count = -1
Sep 2 10:38:59 install kernel: unregister_netdevice: waiting for ppp0 to become free. Usage count = -1
Sep 2 10:39:09 install kernel: unregister_netdevice: waiting for ppp0 to become free. Usage count = -1
Sep 2 10:39:19 install kernel: unregister_netdevice: waiting for ppp0 to become free. Usage count = -1
Sep 2 10:39:29 install kernel: unregister_netdevice: waiting for ppp0 to become free. Usage count = -1
Sep 2 10:39:40 install kernel: unregister_netdevice: waiting for ppp0 to become free. Usage count = -1
Sep 2 10:39:50 install kernel: unregister_netdevice: waiting for ppp0 to become free. Usage count = -1
Sep 2 10:40:00 install kernel: unregister_netdevice: waiting for ppp0 to become free. Usage count = -1
Sep 2 10:40:10 install kernel: unregister_netdevice: waiting for ppp0 to become free. Usage count = -1
Sep 2 10:40:20 install kernel: unregister_netdevice: waiting for ppp0 to become free. Usage count = -1
Sep 2 10:40:31 install kernel: unregister_netdevice: waiting for ppp0 to become free. Usage count = -1
Sep 2 10:40:41 install kernel: unregister_netdevice: waiting for ppp0 to become free. Usage count = -1
Sep 2 10:40:47 install uplink[main]: Stopping Uplink 'main'
Sep 2 10:40:51 install kernel: unregister_netdevice: waiting for ppp0 to become free. Usage count = -1
Sep 2 10:41:01 install kernel: unregister_netdevice: waiting for ppp0 to become free. Usage count = -1
Sep 2 10:41:11 install kernel: unregister_netdevice: waiting for ppp0 to become free. Usage count = -1
Sep 2 10:41:22 install kernel: unregister_netdevice: waiting for ppp0 to become free. Usage count = -1
Sep 2 10:41:32 install kernel: unregister_netdevice: waiting for ppp0 to become free. Usage count = -1
Sep 2 10:41:42 install kernel: unregister_netdevice: waiting for ppp0 to become free. Usage count = -1
Additional InformationI notice there are also bug reports for openvpn with the same errors reported in the /var/log/messages except the error was for tap0

Also I have seen this error occur when I used the gui to rearrange the network cards, this time the error was on the br0 interface.

Tagsheavy, needsfix
Attached Files

- Relationships
related to 0001192closedpeter-endian removeing tap device from bridge freezes the machine 

-  Notes
(0001567)
jvodan (reporter)
2008-09-02 00:55

The machine does not reboot when reboot or shutdown is performed through the GUI.

The system is going down for reboot NOW!
Sep 2 10:52:08 install init: Switching to runlevel: 6
Sep 2 10:52:15 install kernel: unregister_netdevice: waiting for ppp0 to become free. Usage count = -1
.
.
.
.
.
(0001568)
jvodan (reporter)
2008-09-02 01:14
edited on: 2008-09-02 01:16

Further more this bug seems to have appeared in one of update sets downloaded in the last month.

The only solution is to hard reset the box (power cycle), this means every time a ppp interface goes down the box needs to be rebooted.

(0001582)
jvodan (reporter)
2008-09-09 02:02

If the update/fix is in the lastest patched version, I have just applied (and rebooted) the following two packages (plus all those that preceded them)
endian-core-2.2.23-0.endian1 endian-release-enterprise-2.2.x0-8

which according to network.endian.it brings the unit up to date, still the problem persists.

If the above patches fix the problem then i still have it, otherwise how do i get RC3.

I have some unhappy clients who need to hard powercycle their firewall whenever their link drops.
(0001586)
peter-endian (administrator)
2008-09-09 10:35

the package which should had fixed this problem is:
kernel-2.6.22.19-72.endian14

can you please check which kernel package version do you have, using:
rpm -q kernel

if you have this kernel version, then this is probably a new bug, otherwise please write to support@endian.com in order to check why your systems are not up-to-date.
(0001590)
jvodan (reporter)
2008-09-10 06:05

I do indeed have that kernel
(0001593)
peter-endian (administrator)
2008-09-10 11:12

aijeh.
ok, we will debug it
(0001605)
jvodan (reporter)
2008-09-10 22:27

Thanks just a reminder I get the error if I change the network cards around via the network wizard,
Then the error is with br0

So its not just ppp
(0001607)
peter-endian (administrator)
2008-09-11 13:38

do you use ipsec on that machine?
(0001614)
peter-endian (administrator)
2008-09-12 14:13

found the same problem on another machine. machine uses ipsec
(0001617)
jvodan (reporter)
2008-09-15 04:06

Yes use/need Ipsec
(0001618)
peter-endian (administrator)
2008-09-15 11:11

ok, good. so maybe we can reproduce it then. Because it seems that it does not happen when ipsec will not be used
(0001619)
peter-endian (administrator)
2008-09-15 16:25

found the next machine, using UMTS and ipsec
Sep 11 22:09:18 XXXXX-slave kernel: unregister_netdevice: waiting for ppp0 to become free. Usage count = -1
(0001625)
peter-endian (administrator)
2008-09-16 13:22

reproduced on mia with ISDN and ipsec
(0001626)
peter-endian (administrator)
2008-09-16 13:47

the problem don't occurrs with disabled ipsec
(0001634)
jvodan (reporter)
2008-09-23 02:28
edited on: 2008-09-23 02:29

Your kidding right !
Disabling IPSEC is not a fix.

I have more than 10 clients using pppoe and ipsec, half them have this bug the other half are way behind in updates.

(0001638)
peter-endian (administrator)
2008-09-23 10:27

It's a patch to openswan
The fix is in our subversion repository and will be shipped with the next release

I can't attach the rpm's because they are built against a newer kernel, which is not released yet for the community version. Sorry.
(0001639)
peter-endian (administrator)
2008-09-23 11:15

I'm sorry, I did not realize that you are an enterprise customer. They normally use our support form.

The fix for the enterprise version is in the testing process and will be released asap on endian network.

The status of the bugtracker entries here is for managing our development and reflect the situation in our source base.

- Issue History
Date Modified Username Field Change
2008-09-02 00:50 jvodan New Issue
2008-09-02 00:50 jvodan Status new => assigned
2008-09-02 00:50 jvodan Assigned To => peter-endian
2008-09-02 00:55 jvodan Note Added: 0001567
2008-09-02 01:14 jvodan Note Added: 0001568
2008-09-02 01:16 jvodan Note Edited: 0001568
2008-09-03 19:11 peter-endian Relationship added related to 0001192
2008-09-03 19:11 peter-endian Status assigned => resolved
2008-09-03 19:11 peter-endian Fixed in Version => 2.2-rc3
2008-09-03 19:11 peter-endian Resolution open => fixed
2008-09-09 02:02 jvodan Status resolved => feedback
2008-09-09 02:02 jvodan Resolution fixed => reopened
2008-09-09 02:02 jvodan Note Added: 0001582
2008-09-09 10:35 peter-endian Note Added: 0001586
2008-09-10 06:05 jvodan Note Added: 0001590
2008-09-10 09:22 peter-endian Assigned To peter-endian =>
2008-09-10 09:22 peter-endian Status feedback => acknowledged
2008-09-10 09:22 peter-endian Tag Attached: heavy
2008-09-10 09:22 peter-endian Tag Attached: needsfix
2008-09-10 11:12 peter-endian Note Added: 0001593
2008-09-10 22:27 jvodan Note Added: 0001605
2008-09-11 13:38 peter-endian Note Added: 0001607
2008-09-12 14:13 peter-endian Note Added: 0001614
2008-09-15 04:06 jvodan Note Added: 0001617
2008-09-15 11:11 peter-endian Note Added: 0001618
2008-09-15 16:25 peter-endian Note Added: 0001619
2008-09-16 13:22 peter-endian Note Added: 0001625
2008-09-16 13:22 peter-endian Status acknowledged => confirmed
2008-09-16 13:47 peter-endian Note Added: 0001626
2008-09-22 13:00 peter-endian Status confirmed => resolved
2008-09-22 13:00 peter-endian Fixed in Version 2.2-rc3 => 2.3
2008-09-22 13:00 peter-endian Resolution reopened => fixed
2008-09-22 13:00 peter-endian Assigned To => peter-endian
2008-09-23 02:28 jvodan Status resolved => feedback
2008-09-23 02:28 jvodan Resolution fixed => reopened
2008-09-23 02:28 jvodan Note Added: 0001634
2008-09-23 02:29 jvodan Note Edited: 0001634
2008-09-23 10:27 peter-endian Note Added: 0001638
2008-09-23 10:27 peter-endian Status feedback => resolved
2008-09-23 10:27 peter-endian Resolution reopened => fixed
2008-09-23 11:15 peter-endian Note Added: 0001639
2009-10-27 12:02 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker