SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0001318: Proxygroups can not be add,configure or activated - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001318Endian FirewallProxy HTTPpublic2008-09-09 18:092009-10-27 12:01
Reporterblobbi 
Assigned Tosimon-endian 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.2-rc2 
Target VersionFixed in Version2.3 
Summary0001318: Proxygroups can not be add,configure or activated
DescriptionI set up many efw rc2 and every time the same Problem, when i activate the Proxy and will use the proxy Groups, disabled, standard oder extended
i can not edit, add, remove or activate correctly nothing of the presetted Groups

so i try to find out whats going wrong because i ned this function :)

and i found a Problem in /var/efw/proxy in de conf files and under /var/efw/proxy/auth/ncsa the groups1..2..3

in the config files the parameters are all written in capital letters, if i rewrite all the files in lowercase letters it works an in de GUI i can see the Groups and with from the groups is activated ...

hope you can fix it :)
Additional Informationif any questions send my a mail blobbi [ at ] blackshadow.de
Tagsneedsfix
Attached Filesjpg file icon proxy_issues.jpg [^] (42,488 bytes) 2008-09-09 18:09

- Relationships

-  Notes
(0001591)
blobbi (reporter)
2008-09-10 07:10

the problem is in the GUI which read and write the config files wrong.
i edit the accordingly cgi files and it works now
(0001678)
blobbi (reporter)
2008-10-08 19:16

i got now the same problem on rc3 !
(0001707)
simon-endian (developer)
2008-10-15 09:45

this bug is fixed in 2.3 (trunk), it will be merged to 2.2 after some testing

blobbi could you please post your patches of the cgi that people who need this
feature can use it as quickfix?

Regards Simon
(0001713)
blobbi (reporter)
2008-10-16 06:56

Hi Simon,
the fastest way ( new installation without Backup ) is bevore you edit,add or delete any ProxyGroup delete all Files and Folders in /var/efw/proxy/auth/nsca

then open proxyGrout Config in EFW GUI and add new Groups.

Where can i send you the cgi modification?
And how i can help with developing, and testing, or send modifications?

Regards Frank
(0001720)
simon-endian (developer)
2008-10-17 16:48

ah ok, these is a migration problem.

This problem occurs because the SettingsFile class used by the restartscript to migrate after
appliing a backup or creating the default groups after a fresh install saves the keys in UPPERCASE
which the proxy gui does not regognize at the moment. I am working on it.

There are 2 workarounds:

- patch existing ncsa groups and settings by making the key of the settings file lowercase
   (<key>=<value>)
 
- Another way would be to make the keys uppercase and apply blobbies patch (after he posted it :-)).

you need to do this for the following settingsfiles:
/var/efw/proxy/auth/nsca/settings
/var/efw/proxy/auth/nsca/group*/settings

Blobbi you can attach the patch file to this bug tracker entry (Upload File).

The best way for now the help is by testing and uploading patches or
descriping workarounds for kown bugs.

Also read this http://www.endian.com/de/community/community-affairs/ [^] and the posts of
chris in the mailing list for more information.

Best Regards
Simon
(0001788)
blobbi (reporter)
2008-11-13 19:22
edited on: 2008-11-13 19:26

there are more Problems in this cgi File,
so the easyest way ist that users where need this feature delete all files/folders in /var/efw/proxy/auth/nsca
and then create a new in the efw GUI.

simon what is easier, edit the cgi file or when you bild the next release delete all file into /var/efw/proxy/auth/nsca

is all of the config file entrys more UPPERCASE or LOWERCASE
so i know what i change in patches
regards

(0001804)
simon-endian (developer)
2008-11-19 18:24

this is now also fixed in 2.2 and will be soon available

files with lowercase keys are now migrated to uppercase and work too.

(keys should all be uppercase)

- Issue History
Date Modified Username Field Change
2008-09-09 18:09 blobbi New Issue
2008-09-09 18:09 blobbi Status new => assigned
2008-09-09 18:09 blobbi Assigned To => simon-endian
2008-09-09 18:09 blobbi File Added: proxy_issues.jpg
2008-09-10 07:10 blobbi Note Added: 0001591
2008-09-10 11:12 peter-endian Tag Attached: needsfix
2008-10-08 19:16 blobbi Note Added: 0001678
2008-10-15 09:45 simon-endian Status assigned => resolved
2008-10-15 09:45 simon-endian Fixed in Version => 2.3
2008-10-15 09:45 simon-endian Resolution open => fixed
2008-10-15 09:45 simon-endian Note Added: 0001707
2008-10-16 06:56 blobbi Status resolved => feedback
2008-10-16 06:56 blobbi Resolution fixed => reopened
2008-10-16 06:56 blobbi Note Added: 0001713
2008-10-17 16:48 simon-endian Note Added: 0001720
2008-11-13 19:22 blobbi Note Added: 0001788
2008-11-13 19:26 blobbi Note Edited: 0001788
2008-11-19 18:24 simon-endian Note Added: 0001804
2008-11-19 18:24 simon-endian Status feedback => resolved
2008-11-19 18:24 simon-endian Resolution reopened => fixed
2009-10-27 12:01 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker