SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0000134: If you open 10443 allowed in on red and you are using a static ip and router on red, then you cant get to efw web page. - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000134Endian FirewallNetwork related (VPN, uplinks)public2007-03-13 07:322007-12-31 19:15
Reportermarktrent 
Assigned Tora-endian 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.1 
Target VersionFixed in Version2.2-beta2 
Summary0000134: If you open 10443 allowed in on red and you are using a static ip and router on red, then you cant get to efw web page.
DescriptionOk, I have reproduced and verified this error on many installs. If you open port 10443 inbound to allow management of EFW via red/internet and you have assigned an ip to red interface( eg 192.168.0.1 )on the same subnet as your eg: ADSL router(192.168.0.100). You then setup a forwarding rule on your ADSL router eg forward all port 10443 to 192.168.0.1 then the following happens, you get as far as endian asking for username and password, once you try and authenticate and click ok, nothing happens and eventually times out. If you are using firefox under linux you can see that the problem is that after authentication its trying to pass the 192.168.0.1 address out to the browser. This problem does not occur when you have the adsl router in bridged modem mode and are making a direct PPPOE connection from EFW on red.
TagsNo tags attached.
Attached Filespng file icon efwerror2.png [^] (43,738 bytes) 2007-03-13 07:32


png file icon efwerror1.png [^] (58,878 bytes) 2007-03-13 07:33


png file icon efwerror3.png [^] (61,032 bytes) 2007-03-13 07:41

- Relationships
related to 0000324closedpeter-endian Redirect with network wizard fails on IE 

-  Notes
(0000228)
peter-endian (administrator)
2007-03-13 10:01

the redirect on the efw is wrong if the firewall is behind a portfw. however, efw can't know the exact external ip, so this is not going to be fixed. we need to think about a solution.

workaround:
if this happens, you can manually change the url in your browser after the redirect in order to point it to the real extern ip address rather than to the wrongly redirected internal red ip.
(0000229)
marktrent (reporter)
2007-03-13 14:12

OK, here is a quick workaround, when putting in the url into the browser, manually specify " /cgi-bin/main.cgi " after the port number and it works immediately. e.g. instead of putting in "https://dynclient.dyndns.org:10443" [^] type in "https://dynclient.dyndns.org:10443/cgi-bin/main.cgi" [^] this works without problem.
(0000326)
pedro (reporter)
2007-05-22 21:51

Hi, i have de same problem in my EFW 2.1. I have tried the "solution" by putting in the url manually, and work it!Thanks marktrent!
(0000692)
peter-endian (administrator)
2007-12-10 17:06

Redirect will now be calculated by the url which will be typed in within the browser.
So this issue should be fixed..

Next beta (2.2beta2) will contain the fix.

- Issue History
Date Modified Username Field Change
2007-03-13 07:32 marktrent New Issue
2007-03-13 07:32 marktrent File Added: efwerror2.png
2007-03-13 07:33 marktrent File Added: efwerror1.png
2007-03-13 07:41 marktrent File Added: efwerror3.png
2007-03-13 10:01 peter-endian Note Added: 0000228
2007-03-13 10:01 peter-endian Status new => confirmed
2007-03-13 14:12 marktrent Note Added: 0000229
2007-05-22 21:51 pedro Note Added: 0000326
2007-10-27 21:27 peter-endian Status confirmed => assigned
2007-10-27 21:27 peter-endian Assigned To => ra-endian
2007-12-10 17:05 peter-endian Relationship added related to 0000324
2007-12-10 17:06 peter-endian Status assigned => resolved
2007-12-10 17:06 peter-endian Fixed in Version => 2.2
2007-12-10 17:06 peter-endian Resolution open => fixed
2007-12-10 17:06 peter-endian Note Added: 0000692
2007-12-31 19:15 raphael-endian Fixed in Version 2.2-beta1 => 2.2-beta2
2007-12-31 19:15 raphael-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker