SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0001385: dnsmask blackholes don't work - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001385Endian FirewallApplication Level Proxiespublic2008-10-16 10:532009-10-27 12:02
Reporterchris-endian 
Assigned Topeter-endian 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.2-rc3 
Target VersionFixed in Version2.3 
Summary0001385: dnsmask blackholes don't work
Description1. in the default config, blackhole lists are supposed to
   be downloaded daily, but this does not happen since
   the /etc/cron.daily/blackholedns sym link is missing
   Only after making changes to antispyware.cgi the links
   are created.

   -> add the link to the RPM

2. The file blackholedns.conf is not actually read into
   dnsmasq, because dnsmasq.conf.tmpl uses a conf-file=
   and a conf-dir= directive and only the conf-dir= is
   honoured.

   -> Please move the blackholedns.conf file into dnsmasq.d
   and use only the conf-dir= directive.

Bye,
Chris
Tagsneedsfix
Attached Files

- Relationships

-  Notes
(0001731)
peter-endian (administrator)
2008-10-21 10:49

to step 2:
getblackholedns need to restart dnsmasq. a reload is not sufficient. That's the real problem.
The config files will be read in fine on restart

- Issue History
Date Modified Username Field Change
2008-10-16 10:53 chris-endian New Issue
2008-10-16 10:53 chris-endian Assigned To => peter-endian
2008-10-16 11:32 chris-endian Tag Attached: needsfix
2008-10-21 10:49 peter-endian Note Added: 0001731
2008-10-21 15:02 peter-endian Status new => resolved
2008-10-21 15:02 peter-endian Fixed in Version => 2.3
2008-10-21 15:02 peter-endian Resolution open => fixed
2009-10-27 12:02 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker