SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0001458: restartsquid crashes when a zone has authentication enabled - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001458Endian FirewallProxy HTTPpublic2008-11-12 18:242009-10-27 12:21
Reporterpeter-endian 
Assigned Tosimon-endian 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.2-rc3 
Target Version2.3Fixed in Version2.3 
Summary0001458: restartsquid crashes when a zone has authentication enabled
Descriptionwith authentication enabled on a zone, restartsquid crashes with the following traceback:

Traceback (most recent call last):
  File "/usr/local/bin/restartsquid.py", line 1656, in ?
    values = restart(havp, options.force)
  File "/usr/local/bin/restartsquid.py", line 1442, in restart
    values = start()
  File "/usr/local/bin/restartsquid.py", line 1155, in start
    values = write_squid_config(proxy_conf)
  File "/usr/local/bin/restartsquid.py", line 837, in write_squid_config
    file.write(t.respond())
  File "_etc_squid_squid_conf_tmpl.py", line 965, in respond
NameMapper.NotFound: cannot find 'ACL_DST_NOAUTH'


squid will not start afterwards
Tagsneedsfix
Attached Files

- Relationships

-  Notes
(0001823)
simon-endian (developer)
2008-11-24 09:46

could not reproduce with the newest version. should be fixed with the new version

- Issue History
Date Modified Username Field Change
2008-11-12 18:24 peter-endian New Issue
2008-11-12 18:24 peter-endian Assigned To => simon-endian
2008-11-12 18:25 peter-endian Tag Attached: needsfix
2008-11-24 09:46 simon-endian Note Added: 0001823
2008-11-24 09:46 simon-endian Status new => resolved
2008-11-24 09:46 simon-endian Fixed in Version => 2.3
2008-11-24 09:46 simon-endian Resolution open => fixed
2009-10-27 12:01 peter-endian Status resolved => closed
2009-10-27 12:21 peter-endian Target Version future => 2.3

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker