SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0001463: pppcall does not recognize when pppd dialing in using rp-pppoe receives a timeout and exits - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001463Endian FirewallNetwork related (VPN, uplinks)public2008-11-14 17:152009-10-27 12:01
Reporterpeter-endian 
Assigned Topeter-endian 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.2-rc3 
Target VersionFixed in Version2.3 
Summary0001463: pppcall does not recognize when pppd dialing in using rp-pppoe receives a timeout and exits
Descriptionnow PPPoE is the next, which behaves like ISDN and UMTS during dialup.

A system with a PPPoE connection which has no ethernet cable attached, let's the pppd timeout waiting for a PADO. After the timeout pppd exits, but pppcall continues to wait:

0xb7d40bae in __open_nocancel () from /lib/tls/i686/libc.so.6
(gdb) where
#0 0xb7d40bae in __open_nocancel () from /lib/tls/i686/libc.so.6
0000001 0xb7ceb044 in _IO_new_file_fopen (fp=0x8e90908, filename=0x8ea5200 "/var/efw//uplinks//main//main.fifo", mode=Variable "mode" is not available.
) at fileops.c:233
0000002 0xb7ce33d2 in __fopen_internal (filename=0x8ea5200 "/var/efw//uplinks//main//main.fifo", mode=0xb7c5eed4 "r", is32=0) at iofopen.c:93
0000003 0xb7ce5471 in _IO_fopen64 (filename=0x8ea5200 "/var/efw//uplinks//main//main.fifo", mode=0xb7c5eed4 "r") at iofopen64.c:39


uplinksdaemon then kills away the dialup process after 5 minutes, but that's way to long to wait for a pppoE connection which retries 3 times having a timeout of 5 minutes every time.

This causes the backup uplink to come up after more than 15 minutes and that's not acceptable
Tagsneedsfix
Attached Files

- Relationships

-  Notes
(0001790)
peter-endian (administrator)
2008-11-14 18:31

the problem is within pppd. pppd exits with exitcode 0 when rp-pppoe gets a timeout waiting for PADO
It should exit with an errorcode != 0, I think it should be 10

" 10 The PPP negotiation failed, that is, it didn’t reach the point
              where at least one network protocol (e.g. IP) was running.
"
(0001791)
peter-endian (administrator)
2008-11-14 19:09

status == EXIT_OK witin start_link() before calling connect()
if connect() fails, status is still EXIT_OK, because nobody (the plugins) sets a failure.
I think status must always be != EXIT_OK on start_link()
(0001796)
peter-endian (administrator)
2008-11-17 19:34

moved status = EXIT_NEGOTIATION_FAILED before something happens in start_link()
So if first steps go wrong, it exits with failure

- Issue History
Date Modified Username Field Change
2008-11-14 17:15 peter-endian New Issue
2008-11-14 17:15 peter-endian Assigned To => peter-endian
2008-11-14 17:15 peter-endian Tag Attached: needsfix
2008-11-14 18:31 peter-endian Note Added: 0001790
2008-11-14 19:09 peter-endian Note Added: 0001791
2008-11-17 19:34 peter-endian Note Added: 0001796
2008-11-17 19:34 peter-endian Status new => resolved
2008-11-17 19:34 peter-endian Fixed in Version => 2.3
2008-11-17 19:34 peter-endian Resolution open => fixed
2009-10-27 12:01 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker