SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0001477: cheetah prints out warnings when template source is empty - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001477Endian FirewallOther Scriptspublic2008-11-20 18:192009-10-27 12:21
Reporterpeter-endian 
Assigned Topeter-endian 
PrioritynormalSeverityminorReproducibilitysometimes
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.2-rc3 
Target Version2.3Fixed in Version2.3 
Summary0001477: cheetah prints out warnings when template source is empty
Descriptionrestartscripts sometimes print out the following:

/usr/lib/python2.4/site-packages/Cheetah/Compiler.py:1577: UserWarning: You supplied an empty string for the source!

This is because cheetah templates pass twice through the template engine, in order to allow variable sustitution coming from the settings files, because the second time sometimes the template source is an empty string

This does not make much sense and can be removed and implemented otherwise in the future
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2008-11-20 18:19 peter-endian New Issue
2008-11-20 18:19 peter-endian Assigned To => peter-endian
2008-11-20 18:20 peter-endian Status new => resolved
2008-11-20 18:20 peter-endian Fixed in Version => 2.3
2008-11-20 18:20 peter-endian Resolution open => fixed
2009-10-27 12:01 peter-endian Status resolved => closed
2009-10-27 12:21 peter-endian Target Version future => 2.3

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker