SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0001486: firewall config including an ANY or ALL instead of a zone name, create wrong rules - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001486Endian FirewallFirewall (iptables)public2008-11-25 16:222009-10-27 12:21
Reporterpeter-endian 
Assigned Topeter-endian 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.2-rc3 
Target Version2.3Fixed in Version2.3 
Summary0001486: firewall config including an ANY or ALL instead of a zone name, create wrong rules
DescriptionANY/ALL will not be replaced by '' but taken as interface name. This creates wrong rules like these:

    0 0 ALLOW icmp -- ANY * 0.0.0.0/0 0.0.0.0/0 limit: avg 3/sec burst 5 mode srcip-dstip icmp type 8
    0 0 ALLOW icmp -- ANY * 0.0.0.0/0 0.0.0.0/0 limit: avg 3/sec burst 5 mode srcip-dstip icmp type 30

substZones() need to return '' when the value is ANY or ALL
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0001833)
peter-endian (administrator)
2008-12-02 09:18

no comment on reopen -> re-resolve it, since the bug is fixed

- Issue History
Date Modified Username Field Change
2008-11-25 16:22 peter-endian New Issue
2008-11-25 16:22 peter-endian Assigned To => peter-endian
2008-11-25 16:22 peter-endian Tag Attached: needsfix
2008-11-25 16:22 peter-endian Tag Detached: needsfix
2008-11-25 16:38 peter-endian Status new => resolved
2008-11-25 16:38 peter-endian Fixed in Version => 2.3
2008-11-25 16:38 peter-endian Resolution open => fixed
2008-11-28 16:58 Anonymous Status resolved => feedback
2008-11-28 16:58 Anonymous Resolution fixed => reopened
2008-12-02 09:18 peter-endian Note Added: 0001833
2008-12-02 09:18 peter-endian Status feedback => resolved
2008-12-02 09:18 peter-endian Resolution reopened => fixed
2009-10-27 12:01 peter-endian Status resolved => closed
2009-10-27 12:21 peter-endian Target Version future => 2.3

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker