SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0001523: recipient blacklist/whitelist not used - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001523Endian FirewallProxy SMTPpublic2008-12-20 18:102009-10-27 12:01
ReporterwolfS 
Assigned Tosimon-endian 
PrioritynormalSeverityfeatureReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.2-rc3 
Target VersionFixed in Version2.3 
Summary0001523: recipient blacklist/whitelist not used
DescriptionThe recipient_rules database gives you an opportunity to implement
simple address checking on incoming mail. E.g. you can add all your known
internal users to the whitelist, add your domains (without usernames) to the
blacklist. This scheme used to work in 2.1x iirc
This can help to reduce backscatter. Especially since verify does
not work very well against an Exchange server.

Additional Informationrecipient_rules is still being built, it just needs to be added
back in main.cf.tmpl

#if $reject_unknown_recipient_domain == '1'
     reject_unknown_recipient_domain,
#end if
     check_recipient_access btree:/etc/postfix/recipient_rules,
#if $greylisting_enabled == '1'
     check_policy_service inet:127.0.0.1:10026,
#end if
Tagsneedsfix
Attached Files

- Relationships

-  Notes
(0001955)
simon-endian (developer)
2009-02-11 10:50

this happend because of a merge bug:

needed to replace this lines
- check_client_access cidr:/etc/postfix/client_rules,
+ check_recipient_access cidr:/etc/postfix/recipient_rules,
(0001993)
peter-endian (administrator)
2009-02-24 11:48

+ check_recipient_access btree:/etc/postfix/recipient_rules,
not
+ check_recipient_access cidr:/etc/postfix/recipient_rules,


!

- Issue History
Date Modified Username Field Change
2008-12-20 18:10 wolfS New Issue
2009-01-30 12:29 peter-endian Assigned To => simon-endian
2009-01-30 12:29 peter-endian Status new => confirmed
2009-02-06 16:06 peter-endian Tag Attached: needsfix
2009-02-11 10:50 simon-endian Note Added: 0001955
2009-02-11 10:57 simon-endian Status confirmed => resolved
2009-02-11 10:57 simon-endian Fixed in Version => 2.3
2009-02-11 10:57 simon-endian Resolution open => fixed
2009-02-24 11:48 peter-endian Note Added: 0001993
2009-10-27 12:01 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker