SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0001537: p3scan cause pop-clients timeout if a virus/phishing is found - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001537Endian FirewallApplication Level Proxiespublic2009-01-23 17:062009-10-27 12:01
Reporterluca-endian 
Assigned Toluca-endian 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.2-rc3 
Target VersionFixed in Version2.3 
Summary0001537: p3scan cause pop-clients timeout if a virus/phishing is found
DescriptionProxy > POP3 > Virus scanner = enabled
p3scan has problems with mail clients when a mail is noticed by clamav as virus.

Behaviour:
Mail client hangs up on infected email, time out error is displayed.
To stop the loop is needed to delete the mail via webmail.
By watching the log all seems to be ok.

Known issues with:
Outlook, Outlook Express, Merak mail server.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0001928)
luca-endian (developer)
2009-01-24 01:11
edited on: 2009-01-27 11:37

Solution:
There are extra "/n" inside the p3scan template email /etc/p3scan/en/p3scan.mail
by removing the "/n" at the beginning and at the and of the mail all should be ok
make sure to do not remove dot "." at the end of the file

One alternative is to copy the original template file:
cp /usr/share/templates/p3scan/en/p3scan.mail.orig.tmpl /etc/p3scan/en/p3scan.mail

WARNING this hack works until a firewall reboot


- Issue History
Date Modified Username Field Change
2009-01-23 17:06 luca-endian New Issue
2009-01-24 01:11 luca-endian Note Added: 0001928
2009-01-24 01:12 luca-endian Status new => feedback
2009-01-26 23:02 luca-endian Note Edited: 0001928
2009-01-27 11:37 luca-endian Note Edited: 0001928
2009-02-03 12:32 luca-endian Status feedback => new
2009-02-03 12:32 luca-endian Assigned To => luca-endian
2009-02-03 12:32 luca-endian Status new => resolved
2009-02-03 12:32 luca-endian Fixed in Version => 2.3
2009-02-03 12:32 luca-endian Resolution open => fixed
2009-10-27 12:01 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker