SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0001538: Sarg Reports are incorrect - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001538Endian FirewallProxy HTTPpublic2009-01-27 23:032009-10-27 11:59
Reporterben-endian 
Assigned Toluca-endian 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.2-rc3 
Target VersionFixed in Version2.2 
Summary0001538: Sarg Reports are incorrect
DescriptionThis bug affects daily, weekly and monthly report due to a change of cronjob time from before midnight to a time after 1AM.

Daily report is completely useless, weekly and monthly are incorrect because use always one day more.

The Sarg daily reports use the current day's date instead of the previous day and thus the report only has information in it for the time period of 12:00PM to 1:25AM which is when the sarg daily cron job runs.

DAILY SOLUTION:

CURRENT SCRIPT
#########################
# Get yesterday's date
TODAY=$(date +%d/%m/%Y)

WHAT IT SHOULD BE
#########################
# Get yesterday's date
TODAY=$(date -d "yesterday" +%d/%m/%Y)
Tagsneedsfix
Attached Files

- Relationships

-  Notes
(0001967)
luca-endian (developer)
2009-02-16 10:20

Found this issue on three different systems.
(0001974)
luca-endian (developer)
2009-02-18 12:17

Discovered errors in weekly and monthly report as well.
Updated bug description

- Issue History
Date Modified Username Field Change
2009-01-27 23:03 ben-endian New Issue
2009-01-27 23:03 ben-endian Assigned To => simon-endian
2009-02-16 10:20 luca-endian Note Added: 0001967
2009-02-16 10:20 luca-endian Status new => confirmed
2009-02-16 11:52 peter-endian Status confirmed => new
2009-02-16 11:52 peter-endian Assigned To simon-endian => luca-endian
2009-02-16 11:53 peter-endian Status new => confirmed
2009-02-16 12:02 peter-endian Tag Attached: needsfix
2009-02-18 12:17 luca-endian Note Added: 0001974
2009-02-18 12:17 luca-endian Summary Sarg Daily Reports => Sarg Reports are incorrect
2009-02-18 12:17 luca-endian Description Updated
2009-07-28 13:13 luca-endian Status confirmed => resolved
2009-07-28 13:13 luca-endian Fixed in Version => 2.2
2009-07-28 13:13 luca-endian Resolution open => fixed
2009-10-27 11:59 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker