SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0001547: p3scan blocks mail client if mail has a virus - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001547Endian FirewallOther Servicespublic2009-02-05 14:422009-10-27 12:01
Reporterpeter-endian 
Assigned Topeter-endian 
PrioritynormalSeverityminorReproducibilitysometimes
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version2.3 
Summary0001547: p3scan blocks mail client if mail has a virus
Descriptionif a mail with virus will be downloaded by p3scan it logs this:

Feb 5 14:05:44 efw p3scan[5793]: POP3 from x.x.x.x to y.y.y.y from <email> to <email> user: user virus: virus.name: Per instruction, the message has been deleted.
Feb 5 14:05:44 efw p3scan[5793]: ERR: Critical error opening file '', Program aborted.
Feb 5 14:05:44 efw p3scan[5793]: ERR: Exiting now...
Feb 5 14:05:44 efw p3scan[5793]: ERR: Unable to free memory not previously allocated: (null)
Feb 5 14:05:44 efw p3scan[4921]: ERR: Attention: child with pid 5793 died with abnormal termsignal (11)! This is probably a bug. Please report to the author. numprocs is now 0


and the mail client stops
Tagsneedsfix
Attached Files

- Relationships
duplicate of 0001466closedluca-endian p3scan critical error, child process dies 

-  Notes
(0001945)
peter-endian (administrator)
2009-02-05 20:12

it's a permission problem
createtemplate creates implicitely directories which sometimes will be created with umask != 022, so they are not accessible by p3scan

solution:
createtemplate need to be extended in a manner that it sets the permissions of implicitely created directories to 0755
setting the umask to 022 is not enough. already installed systems will not be fixed with that change

- Issue History
Date Modified Username Field Change
2009-02-05 14:42 peter-endian New Issue
2009-02-05 14:42 peter-endian Tag Attached: needsfix
2009-02-05 19:36 luca-endian Relationship added duplicate of 0001466
2009-02-05 20:12 peter-endian Note Added: 0001945
2009-02-05 20:14 peter-endian Status new => resolved
2009-02-05 20:14 peter-endian Fixed in Version => 2.3
2009-02-05 20:14 peter-endian Resolution open => fixed
2009-02-05 20:14 peter-endian Assigned To => peter-endian
2009-10-27 12:01 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker