SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0000156: Havp Whitelist are not applied to havp conf - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000156Endian FirewallApplication Level Proxiespublic2007-04-05 09:322009-10-27 12:01
Reporterbuzzzo 
Assigned Tosimon-endian 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.1 
Target VersionFixed in Version2.3 
Summary0000156: Havp Whitelist are not applied to havp conf
DescriptionWhen i save an havp whitelist tru web gui it will be saved on /var/efw/havp/whitelist , but it seems that the python script doesn't write
the whitelist on /etc/havp .

So the result is that havp doesn't use the whitelist provided from the web gui .

Is it a bug ?

Thx
Tagsneedsfix
Attached Files

- Relationships

-  Notes
(0000279)
peter-endian (administrator)
2007-04-12 17:54

in havp.conf the place for the whitelist is set to /etc/havp/whitelist, which is a symbolic link to /var/efw/havp/whitelist, so this should not be a problem.
try to open /etc/havp/whitelist with an editor, you should see the same content as in /var/efw/havp/whitelist
(0000287)
buzzzo (reporter)
2007-04-16 08:38

As far as I remember the file was not a simlink , but was a empty file .

I've resolved the problem modifying the restarthavp.py and adding a simple
check of the whitelist file and copy it on the right place (/etc/whitelist).

I suggest adding code on the script to check if the link exists and if not, creating it .

Thx
(0000293)
detlef (reporter)
2007-04-24 21:30

Hi,

whitelist dosnĀ“t work for me. Have installed efw-2.1 on four boxes and
it never works.
In the whitlist are two entries:

www.testvirus.de/*
www.eicar.org/*

every time i download a testvirus, havp is blocking this.
on my boxes the symlink and /etc/havp/whitelist does exist.

Detlef
(0000315)
buzzzo (reporter)
2007-05-08 16:38

So ... how about this bug ?

I think it should be closed ... the problem is acknowleged and the solution
is simply to create the simlink .
(0000317)
peter-endian (administrator)
2007-05-10 15:32

thank you very much for pointing out to close the issue.
this is what we need to keep the tracker clean.
(0001767)
luca-endian (developer)
2008-11-04 13:01

Same problem of original issue.
That appends on efw enterprise 2.2 and also development version.
(0001822)
simon-endian (developer)
2008-11-21 16:58

- if /etc/havp/whitelist is not a symlink but a file the file is moved to /var/efw/havp/whitelist, owner is set to nobody:nobody and a symlink is created (0000156)
- if /etc/havp/whitelist is not a symlink and does not exist a symlink is created (0000156)
- if /var/efw/havp/whitelist does not exist it is touched and owner is set to nobody:nobody (0000156)

- Issue History
Date Modified Username Field Change
2007-04-05 09:32 buzzzo New Issue
2007-04-12 17:54 peter-endian Note Added: 0000279
2007-04-12 17:54 peter-endian Status new => feedback
2007-04-16 08:38 buzzzo Note Added: 0000287
2007-04-24 21:30 detlef Note Added: 0000293
2007-05-08 16:38 buzzzo Note Added: 0000315
2007-05-10 15:32 peter-endian Status feedback => resolved
2007-05-10 15:32 peter-endian Resolution open => fixed
2007-05-10 15:32 peter-endian Assigned To => peter-endian
2007-05-10 15:32 peter-endian Note Added: 0000317
2007-07-11 09:01 peter-endian Status resolved => closed
2008-11-04 13:01 luca-endian Note Added: 0001767
2008-11-04 13:01 luca-endian Status closed => feedback
2008-11-04 13:01 luca-endian Resolution fixed => reopened
2008-11-04 13:02 luca-endian Status feedback => confirmed
2008-11-04 16:42 peter-endian Tag Attached: needsfix
2008-11-04 16:42 peter-endian Status confirmed => new
2008-11-04 16:42 peter-endian Assigned To peter-endian => simon-endian
2008-11-04 16:42 peter-endian Status new => confirmed
2008-11-21 16:58 simon-endian Note Added: 0001822
2008-11-21 16:58 simon-endian Status confirmed => resolved
2008-11-21 16:58 simon-endian Fixed in Version => 2.3
2008-11-21 16:58 simon-endian Resolution reopened => fixed
2009-10-27 12:01 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker