SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0001643: create partitions for /var/log and /var/efw - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001643Endian FirewallUncategorizedpublic2009-03-06 18:022009-10-27 12:00
Reporterpeter-endian 
Assigned Topeter-endian 
PrioritynormalSeveritycrashReproducibilitysometimes
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version2.3Fixed in Version2.3 
Summary0001643: create partitions for /var/log and /var/efw
Descriptionif /var will be filled up and the user saves something afterwards, that settingsfile will be truncated to 0 size and configuration is gone then.

if we reserve an absolute amount of space for /var/efw, configuration can always be saved. Need to pay attention with bazaar!

a partition for /var/log would give a defined amount of space for logs, so log's cannot eat space for other services.

Partition changes to be done:

/boot -> remove
/var/log -> define a percentage
/var/efw -> absolute size (100M?)
Tagspurple
Attached Files

- Relationships

-  Notes
(0002295)
luca-endian (developer)
2009-05-06 14:33

My opinion about partition table is:

/ - normal linux stuff
/boot - I think that a dedicated boot partition make the systems more reliable
/var - the biggest partition with logs and backups
/efw - on a dedicated partition or basically in /

The important thing is that efw settings are separated from the files which may fill up the partition such logs.
Backups as I wrote here (1852) should stay on the same partition of logs.

Maybe also the /tmp directory may be on the same partition of logs and backups.
(0002339)
mike-f (updater)
2009-05-14 11:48

an own /var/log and /var/spool would be nice

maybe we switch also to LVM which makes it a bit easier to create more partitions and growing/shrinking if needed
(0002343)
peter-endian (administrator)
2009-05-14 15:55

LVM would be nice, but the current software stack (mostly mkinitrd) is not 100% ready for it.

we need to pay attention with the amount of partitions since disk space is precious when using a CF, which should be possible in future.

the issue with /boot is, that it always wents to small when we upgrade kernels, initrd and vmlinuz files become bigger and bigger. so sooner or later it's not possible anymore to upgrade. and i think the 1024 cylinder issue for which we have that /boot partition is gone now.
a bigger /boot eats precious disk space, so i consider to put it on the / partition.

i will now change to
/
/var
/var/efw
/var/log

need to think about /var/spool, but i think it's not necessary, since /var is already an own partition and configuration is safe due to /var/efw partition and logging do not fill /var due to /var/log partition
so it should be a good tradeoff
(0002344)
luca-endian (developer)
2009-05-14 16:03
edited on: 2009-05-14 16:05

About /boot I agree.

In which partition will the backup files be stored? They can be very big.

The big question now is: how big should be the partitions?

(0002346)
Anonymous (viewer)
2009-05-14 16:11
edited on: 2009-05-14 16:13

edit (report by mike-f)
be aware it's not only the /var/log partition that could fill up:

bounce-mails in /var/spool/postfix
(when using as relay and main mail-host is down)

virii in /var/virusmails or /var/amavis

maybe we move both of the above (and any other that might grow) to /var/spool too

P.S.:
somebody to check the url mantis sends out?
-> bugs.endian.it -> change to bugs.endian.com

(0002347)
mike-f (updater)
2009-05-14 16:16

the sub to the big question is:

how big is the smallest card we want to use in the future
(0002349)
mike-f (updater)
2009-05-18 09:07

for the /boot we should add a note about old BIOS'es that might not boot properly
-> User has to install a more recent BIOS to make it work

as for the LVM-issue we could start testing a more current upstream-version
(and the deps)
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/os/SRPMS/mkinitrd-5.1.19.6-44.src.rpm [^]
(0002350)
peter-endian (administrator)
2009-05-18 10:09

well, upgrading that opens a huge dependency tree, which requires to package/upgrade a lot of other packages. i will not do that right now.

The 1024 cylinder issue is solved by our grub version. No need for newer BIOSes as long as the disk is < 8G or the BIOS supports LBA mode. But i think we are speaking about features even old computers support right now. So an own partition for /boot does not make any more sense to me.
(http://www.gnu.org/software/grub/grub-legacy-faq.en.html#TOCq3 [^])
(0002351)
mike-f (updater)
2009-05-18 13:21

i mean putting a hint (some note in the docs) to the user when using big disks on old bios'es
will give less bug-reports on people asking for reason why not booting

http://www.gnu.org/software/grub/grub-legacy-faq.en.html#TOCq13 [^]

- Issue History
Date Modified Username Field Change
2009-03-06 18:02 peter-endian New Issue
2009-03-06 18:02 peter-endian Assigned To => ra-endian
2009-04-23 15:27 luca-endian Tag Attached: purple
2009-05-06 14:33 luca-endian Note Added: 0002295
2009-05-14 11:48 mike-f Note Added: 0002339
2009-05-14 15:55 peter-endian Note Added: 0002343
2009-05-14 15:57 peter-endian Assigned To ra-endian => peter-endian
2009-05-14 16:01 peter-endian Status new => assigned
2009-05-14 16:03 peter-endian Relationship added child of 0001873
2009-05-14 16:03 luca-endian Note Added: 0002344
2009-05-14 16:05 luca-endian Note Edited: 0002344
2009-05-14 16:11 Anonymous Note Added: 0002346
2009-05-14 16:11 Anonymous Status assigned => feedback
2009-05-14 16:11 Anonymous Note Edited: 0002346
2009-05-14 16:13 Anonymous Note Edited: 0002346
2009-05-14 16:16 mike-f Note Added: 0002347
2009-05-18 09:07 mike-f Note Added: 0002349
2009-05-18 10:09 peter-endian Note Added: 0002350
2009-05-18 13:21 mike-f Note Added: 0002351
2009-05-21 18:57 peter-endian Status feedback => resolved
2009-05-21 18:57 peter-endian Fixed in Version => 2.3
2009-05-21 18:57 peter-endian Resolution open => fixed
2009-10-27 12:00 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker