SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0001692: Add microcode update to kernel - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001692Endian FirewallHardware related (kernel, drivers, hardware)public2009-03-19 04:572010-11-22 11:51
Reporterkfason 
Assigned Topeter-endian 
PrioritynormalSeverityfeatureReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.2-rc3 
Target VersionFixed in Version2.4 
Summary0001692: Add microcode update to kernel
DescriptionIntel Processors since PPro have the ability to update their microcode to deal with design flaws. Normally this is updated in the BIOS by the motherboard manufacturer but not all keep on top of it. You can compile in support for a microcode update process and during bootup the kernel will load it into the processor.

Just add the framework and more advanced users can insert/update the microcode file from Intels web site. Dont know if this applies to the EFW appliances or just the community version?
Additional InformationEnable kernel option

Processor type and features --->
    <M> /dev/cpu/microcode - Intel IA32 CPU microcode support


More info can be garnered here for the userspace tool that loads it.
   http://www.urbanmyth.org/microcode/ [^]
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2009-03-19 04:57 kfason New Issue
2010-03-31 13:50 peter-endian Status new => resolved
2010-03-31 13:50 peter-endian Fixed in Version => codename: angry armadillo
2010-03-31 13:50 peter-endian Resolution open => fixed
2010-03-31 13:50 peter-endian Assigned To => peter-endian
2010-11-22 11:51 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker