SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0001908: openvpn problem upgrading efw 2.1 or 2.1.2, to 2.2 - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001908Endian FirewallUncategorizedpublic2009-05-30 19:272010-11-22 12:08
Reportercompdoc 
Assigned Tora-endian 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.1 
Target VersionFixed in Version2.4.1 
Summary0001908: openvpn problem upgrading efw 2.1 or 2.1.2, to 2.2
DescriptionI've updated a few 2.3rc3 servers to 2.2 and this has worked flawlessly. Good job, guys.

But today, I stupidly updated a few 2.1 and 2.1.2 servers to 2.2. It seemed to go perfectly, and everything else works that I can see. But then I noticed one major problem...

Normally, on the VPN setup page, there are these three choices in the left pane:

OpenVPN
serverOpenVPN client (Gw2Gw)
IPsec

On the 2.1 and 2.1.2 servers that were upgraded with the efw-uprade command, only these two choices appear:

OpenVPN
IPsec

They are missing the ability to create server-to-server bridges. Also, the directory /var/efw/openvpnclients is missing, as well as some config files in /etc/openvpn.

Config files for existing bridges were not created, so these bridges are no longer working.

I'm going to attempt to recreate these files by hand tomorrow since this has to be up monday morning, unless you think you can fix this by then.

Of course, I wont be able to add the missing 'serverOpenVPN client (Gw2Gw)' setup page.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0002453)
peter-endian (administrator)
2009-06-03 15:32

try:
smart install efw-vpnclient
(0004099)
Anonymous (viewer)
2010-03-25 16:52

I cant figure out how to use this bug tracker. It wants feedback, but I dont see how to do that so I'll just say the 'smart update' command fixed it. Thanks!

- Issue History
Date Modified Username Field Change
2009-05-30 19:27 compdoc New Issue
2009-06-03 15:32 peter-endian Note Added: 0002453
2009-06-03 15:32 peter-endian Assigned To => ra-endian
2010-03-25 16:01 ra-endian Status new => feedback
2010-03-25 16:52 Anonymous Note Added: 0004099
2010-03-25 16:52 Anonymous Status feedback => resolved
2010-03-25 16:52 Anonymous Resolution open => fixed
2010-11-22 12:08 peter-endian Fixed in Version => 2.4.1
2010-11-22 12:08 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker