SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0001947: ethconfig writes businfotab wrong sorted when NIC hardware configuration changes (NIC added/removed) - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001947Endian FirewallNetwork related (VPN, uplinks)public2009-06-16 00:012009-10-27 11:59
Reporterpeter-endian 
Assigned Topeter-endian 
PrioritynormalSeverityminorReproducibilitysometimes
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.2-rc3 
Target Version2.3Fixed in Version2.3 
Summary0001947: ethconfig writes businfotab wrong sorted when NIC hardware configuration changes (NIC added/removed)
Descriptionif NIC's will be removed/added, ethconfig --update will write down a new businfotab.

updateBusinfotab first reads out the current businfotab and writes it down afterwards.
If there are NIC's added or removed it will reflect that changes in the businfotab, but somehow it happens that the old name -> pciid assignement changes.
So interfaces will change their names when NIC's will be added/removed.
TagsNo tags attached.
Attached Files

- Relationships
related to 0001945closed problem while adding a network card after the installation 

-  Notes
(0002724)
peter-endian (administrator)
2009-06-30 17:47

unreproduceable :(

tried simulating it with only changing the assignement in businfotab: was always ok
tried with vmware really adding an interface: was always ok.

need to try with a real system.
last time we did this:

used this businfotab:
eth0 02:00.0
eth1 01:00.0
eth2 03:09.0
eth3 03:0a.0

1) removed eth3
2) reboot
3) added eth3
4) reboot
-> changed order
(0002725)
mike-f (updater)
2009-06-30 21:48

maybe we just take the MAC-adresses to be linked to the eth*-if'aces
(or other way round)

do we really need that businfotab?

thinking forward:
if a card breaks down, and/or a new one will be added, this one will be "auto" added to green-bridge (in case it was the green - to still be able to configure it over green-if) unless user will configure card using network-config)

if the new card is an replacement for red we just need an input for user:
any new card will be in green unless configured other way
please plug off the cable on the new card if not on GREEN
(0002726)
peter-endian (administrator)
2009-07-01 10:38

think in ports on a network appliance.
you want to have them always on the same position, also if you change the NIC with another one. that's only possible with the pci-id.

mac addresses can also be spoofed.. if you spoof, you will always have jumping NIC assignments.
(0002732)
peter-endian (administrator)
2009-07-02 14:48

on a real system it did not happen either :/

but probably this happened:
original businfotab:

eth0 02:00.0
eth1 01:00.0
eth2 03:0a.0
eth3 03:09.0

if you remove eth2 and eth3 and then boot, the businfotab will be updated in order to reflect the hardware change.
so after the first boot we will have:
eth0 02:00.0
eth1 01:00.0

if you afterwards add the 2 NIC's and boot, there is no more packaged businfotab, but only the updated version, so the ordering will be re-assigned, so we will have:
eth0 02:00.0
eth1 01:00.0
eth2 03:09.0
eth3 03:0a.0

in the end.


I think we need a current businfotab and a default (packaged) businfotab, which will be considered during assignement of new NIC's.

That will probably lead in assignements like:

eth0 02:00.0
eth1 01:00.0
eth3 03:0a.0
eth4 03:0b.0

but who cares. it would work


however, re-ordering should never occur, if the NIC will only be changed (because of broken NIC), if there is no reboot with fewer NIC's
(0002859)
peter-endian (administrator)
2009-08-17 20:06

packaged businfotab is now in businfotab*.default, so every product can have it's own file.
from there will now be read out an interface name assignement if there is none for
a specific pci id. if there is none defined in the default file, next free will
be used.

non-existint interfaces will now not be removed anymore from the businfotab file in order to keep a pci-id 2 interface name assignement also if the NIC will be removed. if the NIC will be re-added to the same pci clost it will get the same interface name as the old one.

Unsure if these changes fix this problem completely. At least it should be more correct with these fixes.

Ticket should be reopened if the issue is still not fixed.

- Issue History
Date Modified Username Field Change
2009-06-16 00:01 peter-endian New Issue
2009-06-16 00:01 peter-endian Assigned To => peter-endian
2009-06-16 14:46 luca-endian Relationship added related to 0001945
2009-06-30 17:47 peter-endian Note Added: 0002724
2009-06-30 21:48 mike-f Note Added: 0002725
2009-07-01 10:38 peter-endian Note Added: 0002726
2009-07-02 14:48 peter-endian Note Added: 0002732
2009-08-17 20:06 peter-endian Note Added: 0002859
2009-08-17 20:06 peter-endian Status new => resolved
2009-08-17 20:06 peter-endian Fixed in Version => 2.3
2009-08-17 20:06 peter-endian Resolution open => fixed
2009-10-27 11:59 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker