SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0000199: no default route in red zone via DHCP - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000199Endian FirewallNetwork related (VPN, uplinks)public2007-06-26 12:322009-10-27 12:01
Reportermitchymagic 
Assigned Topeter-endian 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.1 
Target VersionFixed in Version2.3 
Summary0000199: no default route in red zone via DHCP
DescriptionHi All,

I think i may have come across a bug, when using the Bt Homehub " feature " of assigning the public address to my firewall via dhcp. The machine gets the address with a /8 mask however no default route shows up. The ip address is an 86.x.x.x address and the gateway is a 217.x.x.x and like i say the mask is a /8 by the looks of things so the gateway isnt reachable directly connected. Now i know this cant work under normal operation however when i try the same setup with a pc it works ( i assume the hub does some sort of proxy arp ) Like i say it works on my pc's but not on the endian machine. Normal DHCP works fine when given the standard 192.168.x.x /24 address range.

Any ideas ( apart from getting rid of the home hub obviously )

Cheers

Mitch
TagsNo tags attached.
Attached Files

- Relationships
duplicate of 0000010closedpeter-endian default gateway outside ip/netmask range 

-  Notes
(0000577)
peter-endian (administrator)
2007-10-27 21:13

This is a hack which some ISP's use. Normally the gateway has to be within a known subnet.
It's however possible to set up a hostroute only for the default gateway.
We will implement this hack later.

- Issue History
Date Modified Username Field Change
2007-06-26 12:32 mitchymagic New Issue
2007-10-27 21:13 peter-endian Note Added: 0000577
2007-10-27 21:13 peter-endian Assigned To => peter-endian
2007-10-27 21:13 peter-endian Status new => confirmed
2007-10-28 14:38 peter-endian Relationship added duplicate of 0000010
2009-02-17 20:48 peter-endian Status confirmed => resolved
2009-02-17 20:48 peter-endian Fixed in Version => 2.3
2009-02-17 20:48 peter-endian Resolution open => fixed
2009-10-27 12:01 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker