SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0001994: SNMPD logging is too high - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001994Endian FirewallOther Servicespublic2009-07-10 14:052009-10-27 11:59
Reporterphoenix 
Assigned Topeter-endian 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.2 
Target VersionFixed in Version2.3 
Summary0001994: SNMPD logging is too high
DescriptionI use Cacti to monitor my systems including EFW, when it polls EFW I see the following in /var/log/messages:

Jan 8 13:45:02 example snmpd[2048]: Connection from UDP: [10.0.0.1]:51890
Jan 8 13:45:02 example snmpd[2048]: Received SNMP packet(s) from UDP: [10.0.0.1]:51890

These are repeated about 10 times on each polling session (every 5 minutes). Prior to the 2.2 final I was able to reduce the logging with the fix in this article: http://www.stat.auckland.ac.nz/~kimihia/net-snmp [^]

Since the installation of EFW 2.2 final the problem has recurred, it appears this version ignores the /etc/snmp/snmpd.options file. In the snmpd startup script I changed the following lines:

PTIONS="-Lsd -Lf /dev/null -p /var/run/snmpd.pid -a"
if [ -e /etc/sysconfig/snmpd ]; then
  . /etc/sysconfig/snmpd
fi

to this:

if [ -e /etc/snmp/snmpd.options ]; then
  . /etc/snmp/snmpd.options
else
   OPTIONS="-Lsd -Lf /dev/null -p /var/run/snmpd.pid -a"
fi

This now honours any additional options you have in this file and logging is reduced to a more manageable level.

I don't know if that's the correct fix as my scripting skills aren't that great but it works for me.

TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0002750)
peter-endian (administrator)
2009-07-10 20:09

thank's for the fix
changed it slightly in order to read out /etc/sysconfig/snmpd and added it to the codebase

- Issue History
Date Modified Username Field Change
2009-07-10 14:05 phoenix New Issue
2009-07-10 20:09 peter-endian Note Added: 0002750
2009-07-10 20:09 peter-endian Status new => resolved
2009-07-10 20:09 peter-endian Fixed in Version => 2.3
2009-07-10 20:09 peter-endian Resolution open => fixed
2009-07-10 20:09 peter-endian Assigned To => peter-endian
2009-10-27 11:59 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker