SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0002064: It is not possible to add a QOS device / 500 Internal error - due to a DataSource issue - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002064Endian FirewallOther Servicespublic2009-08-05 16:012010-11-22 12:06
Reporterchristian-endian 
Assigned Tosimon-endian 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version2.3.1Fixed in Version2.3.1 
Summary0002064: It is not possible to add a QOS device / 500 Internal error - due to a DataSource issue
DescriptionSeems like a problem with FormEncode's locale files...

/var/log/emi reports this:
Could not load language settings: [Errno 2] No translation file found for domain: 'FormEncode'
Tagspurple
Attached Files

- Relationships
has duplicate 0002387closed After creating QoS devices and going back to the link I get a 500 error 
related to 0002036assignedpeter-endian RBL file lets datasourcecrash 
related to 0002034assignedpeter-endian datasource does not read default settings when there are no user settings 

-  Notes
(0002915)
christian-endian (administrator)
2009-08-26 21:39

FormEncode does indeed not provide an English translation. However, that is not a problem since the exception is caught and the string itself is returned.

Something else must be the real problem.
(0002934)
peter-endian (administrator)
2009-09-03 13:51

works also for me. maybe this happens only due to a strange problem on your machine?
(0002936)
christian-endian (administrator)
2009-09-06 08:45

Original title was: It is not possible to add a QOS device / 500 Internal error

The problem arises when an OpenVPN client connection (or an uplink - have not tried that, but should be the same problem) is created with capital letters in its name because each connection is stored in a directory with that name.

In niclist.py the getVPNs function uses the DataSource to read the configuration which in turn accesses every key by using lower(). As for now we do not map filenames though.

Possible solutions:
1. Fix DataSource
2. Make sure these directories are always created lowercase (Would require a migration script as well as fixes in efw-network and efw-vpnclient).
(0002937)
peter-endian (administrator)
2009-09-07 16:59

solution 1 is the better one - we know that, don't we? :)
(0003840)
christian-endian (administrator)
2010-02-23 15:11
edited on: 2010-02-23 15:12

We'll have to go with solution 2 for now:

Keep in mind that affected VPN connections must be closed before migrating and then restarted!

Make sure to not only rename the directory but change the name in the settings file as well.

(0003873)
simon-endian (developer)
2010-02-26 14:16

implemented solution2 -> folder and name key are renamed and condstop before / start after is triggered for the effected vpnclient connections

from now on name of new profiles will be lowercased

- Issue History
Date Modified Username Field Change
2009-08-05 16:01 christian-endian New Issue
2009-08-26 21:35 christian-endian Project Delemont OneShield => not released
2009-08-26 21:39 christian-endian Note Added: 0002915
2009-09-03 13:51 peter-endian Note Added: 0002934
2009-09-06 08:45 christian-endian Note Added: 0002936
2009-09-06 08:45 christian-endian Assigned To => peter-endian
2009-09-06 08:45 christian-endian Reproducibility have not tried => always
2009-09-06 08:45 christian-endian Status new => assigned
2009-09-06 08:45 christian-endian Summary It is not possible to add a QOS device / 500 Internal error => It is not possible to add a QOS device / 500 Internal error - due to a DataSource issue
2009-09-07 16:59 peter-endian Note Added: 0002937
2009-09-07 16:59 peter-endian Status assigned => acknowledged
2009-09-07 17:00 peter-endian Relationship added related to 0002036
2009-09-07 17:01 peter-endian Relationship added related to 0002034
2009-10-27 14:10 peter-endian Project not released => Endian Firewall
2009-10-27 14:11 peter-endian Target Version => 2.3.1
2009-11-06 12:12 peter-endian Relationship added has duplicate 0002387
2009-11-25 16:57 peter-endian Product Version enterprise-2.3-beta2 =>
2009-11-25 16:57 peter-endian Target Version 2.3.1 => future
2010-02-17 14:10 luca-endian Tag Attached: purple
2010-02-23 15:11 christian-endian Note Added: 0003840
2010-02-23 15:12 christian-endian Assigned To peter-endian => simon-endian
2010-02-23 15:12 christian-endian Status acknowledged => assigned
2010-02-23 15:12 christian-endian Target Version future => 2.3.1
2010-02-23 15:12 christian-endian Note Edited: 0003840
2010-02-26 14:16 simon-endian Note Added: 0003873
2010-02-26 14:16 simon-endian Status assigned => resolved
2010-02-26 14:16 simon-endian Fixed in Version => 2.3.1
2010-02-26 14:16 simon-endian Resolution open => fixed
2010-11-22 12:06 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker