SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0002171: Backup doesn't work - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002171Endian FirewallEndian Firewallpublic2009-09-17 12:542010-11-22 12:08
Reporterluca-endian 
Assigned Topeter-endian 
PrioritynormalSeveritymajorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version2.3.1Fixed in Version2.4.1 
Summary0002171: Backup doesn't work
DescriptionOn a beta4 system upgraded to rc1.
Backup settings from gui interface doesn't work, neither via shell:

root@kenny-23:/mnt/usbstick/efw-backups # backup-create.sh --settings --logs --logarchives --dbdumps
Could not create backup '/tmp/backup.tar.d23059'!

root@kenny-23:/home/httpd/html/backup # efw-backupusb --runbackup

2009-09-17 14:33:55,389 - efw-backupusb[21117] - INFO - Creating backup...
2009-09-17 14:35:10,902 - efw-backupusb[21117] - ERROR - Error running command: /usr/local/bin/backup-create.sh --settings --logs --logarchives --dbdumps --message "'USB-Stick Backup: kenny-23.southpark'" 2> /dev/null
ERROR: {"msg": "Error running command: /usr/local/bin/backup-create.sh --settings --logs --logarchives --dbdumps --message \"'USB-Stick Backup: kenny-23.southpark'\" 2> /dev/null", "type": "error", "time": 1253190910.9061821}
2009-09-17 14:35:11,920 - efw-backupusb[21117] - INFO - updating symlinks
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0002964)
luca-endian (developer)
2009-09-17 13:02

There's just this line in /var/log/messages

Sep 17 15:00:04 kenny-23 backup-create: Could not create backup '/tmp/backup.tar.xt6960'!
(0002966)
luca-endian (developer)
2009-09-17 14:20

Ok probably I understood what's wrong, maybe it's related with the "new logs system". In fact if I backup settings only it works.

root@firewall:~ # backup-create.sh --settings --logs
Could not create backup '/tmp/backup.tar.s28029'!

root@firewall:~ # backup-create.sh --settings
/home/httpd/html/backup/backup-20090917161253-firewall.hpa.it-settings.tar.gz

I've tried it on 2 different rc1 system upgraded from beta4.
(0003898)
peter-endian (administrator)
2010-03-03 21:01

happens when backup would take to much space

for example (most probably) if log archives take to much space.
(0003980)
peter-endian (administrator)
2010-03-08 15:43

this does not happen because of space issues, but because of this:
tar: /var/log/openvpn/openvpn.log: file changed as we read it

--ignore-failed-read *should* ignore this error, but it does not! probably tar has a problem?


at the other hand.. space *is* a problem, can be worked around by using /var/tmp instead of /tmp
(0003981)
peter-endian (administrator)
2010-03-08 15:46

/tmp -> /var/tmp done

- Issue History
Date Modified Username Field Change
2009-09-17 12:54 luca-endian New Issue
2009-09-17 13:02 luca-endian Note Added: 0002964
2009-09-17 14:20 luca-endian Note Added: 0002966
2009-10-27 14:07 peter-endian Project not released => Endian Firewall
2009-10-27 14:08 peter-endian Target Version => 2.3.1
2009-10-29 08:26 luca-endian Status new => confirmed
2009-11-05 11:43 luca-endian Relationship added related to 0002376
2009-12-15 16:00 luca-endian Relationship deleted related to 0002376
2010-03-03 15:22 ra-endian Assigned To => peter-endian
2010-03-03 15:22 ra-endian Status confirmed => acknowledged
2010-03-03 21:01 peter-endian Note Added: 0003898
2010-03-03 21:01 peter-endian Status acknowledged => confirmed
2010-03-08 15:43 peter-endian Note Added: 0003980
2010-03-08 15:46 peter-endian Note Added: 0003981
2010-03-08 16:57 peter-endian Status confirmed => resolved
2010-03-08 16:57 peter-endian Fixed in Version => 2.3.1
2010-03-08 16:57 peter-endian Resolution open => fixed
2010-11-22 12:08 peter-endian Fixed in Version 2.3.1 => 2.4.1
2010-11-22 12:08 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker