SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0002182: The webgui hangs on proxy apply setting - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002182Endian FirewallGUIpublic2009-09-21 14:332009-10-27 11:58
Reporterpravinpanday 
Assigned Tosimon-endian 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.3-rc1 
Target VersionFixed in Version2.3 
Summary0002182: The webgui hangs on proxy apply setting
DescriptionThe proxy page hangs after making any changes
Additional InformationWhenever I make any changes on the proxy setting page the page hangs and doesnt come back with the message "changes applied successfully". Although the proxy service and internet keeps running fine. I have triedrestarting the httpd and squid service however the webinterface doesnt respond. This was not an issue with release 2.2. Also in 2.3 rc1 most of the buttons have to be re clicked to get them worked.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0002980)
mhandrich (reporter)
2009-09-21 23:54

i have the same - but - after a minute or so - i only have to go to the address line (this one: https://myendian:10443 [^]) and press ENTER - then it reloads and everzhing is ok.
(0002981)
pravinpanday (reporter)
2009-09-22 04:42

gr8, I will try that and update on this issue.
(0003022)
simon-endian (developer)
2009-09-28 10:15

can you please check if this is caused by a browser timeout, because the restart of the proxy takes long.

how long did you wait for the page to come back and was the browser still loading?
(0003050)
pravinpanday (reporter)
2009-10-01 08:31

It takes around an hour or 2.
(0003051)
luca-endian (developer)
2009-10-01 08:41

Does this happens always?
Can you look at the logs to see if something goes wrong?

/var/log/messages/
/var/log/httpd/
/var/log/squid

If you run this command "restartsquid.py --force --debug" do you see errors?
(0003064)
simon-endian (developer)
2009-10-06 15:36

need to add status notification like with snort, to let the user now something is going on in the background
(0003066)
simon-endian (developer)
2009-10-07 10:56

- added notifications to squid, dansguardian, havp and sarg restartscripts
- added notification messages to http proxy, http contentfilter and http antivirus gui

- Issue History
Date Modified Username Field Change
2009-09-21 14:33 pravinpanday New Issue
2009-09-21 23:54 mhandrich Note Added: 0002980
2009-09-22 04:42 pravinpanday Note Added: 0002981
2009-09-23 13:32 simon-endian Assigned To => simon-endian
2009-09-28 10:15 simon-endian Note Added: 0003022
2009-09-28 10:15 simon-endian Status new => feedback
2009-10-01 08:31 pravinpanday Note Added: 0003050
2009-10-01 08:41 luca-endian Note Added: 0003051
2009-10-06 15:36 simon-endian Note Added: 0003064
2009-10-06 15:37 simon-endian Status feedback => assigned
2009-10-07 10:56 simon-endian Note Added: 0003066
2009-10-07 10:56 simon-endian Status assigned => resolved
2009-10-07 10:56 simon-endian Fixed in Version => 2.3
2009-10-07 10:56 simon-endian Resolution open => fixed
2009-10-27 11:58 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker