SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0002187: push dns and domain missing in openvpn.conf - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002187Endian FirewallNetwork related (VPN, uplinks)public2009-09-22 14:572010-09-23 13:21
Reporterkourush 
Assigned Topeter-endian 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionduplicate 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0002187: push dns and domain missing in openvpn.conf
Description"Push these nameservers" and "Push domain" in openvpn advanced tab not work
mush add manual "push domain" and "push dns" in openvpn.conf.tmpl
i don't know why never reported this bug.
TagsNo tags attached.
Attached Files

- Relationships
duplicate of 0002682confirmed global OpenVPN DCHP Options not pushed when using X509 without having accounts 

-  Notes
(0002984)
peter-endian (administrator)
2009-09-22 18:56

it will not be put in /etc/openvpn/openvpn.conf but in /var/openvpn/clients/* to every single client.

This is necessary because you can also define the same parameters on a per-user basis. If you do that the global configuration should not be pushed anymore.

Try to take a look to those files if the push lines are configured to your users.
(0004684)
Anonymous (viewer)
2010-08-18 02:49

But this means you have to define every client, right? I thought part of the approach of X509 certs was that it would allow for all users signed by your CA to connect without having to define every client specifically.

The global routes seemed to get pushed, but no global DNS servers. What is the way to accomplish this without having to define every client discretely in the openvpn config?
(0004834)
peter-endian (administrator)
2010-09-23 13:21

handled in 0002682, please follow that ticket

- Issue History
Date Modified Username Field Change
2009-09-22 14:57 kourush New Issue
2009-09-22 14:57 kourush Assigned To => peter-endian
2009-09-22 18:56 peter-endian Note Added: 0002984
2009-09-22 18:56 peter-endian Status new => feedback
2009-09-23 13:25 peter-endian Status feedback => closed
2009-09-23 13:25 peter-endian Resolution open => no change required
2010-08-18 02:49 Anonymous Note Added: 0004684
2010-08-18 02:49 Anonymous Status closed => feedback
2010-08-18 02:49 Anonymous Resolution no change required => reopened
2010-09-23 13:20 peter-endian Relationship added duplicate of 0002682
2010-09-23 13:21 peter-endian Note Added: 0004834
2010-09-23 13:21 peter-endian Status feedback => closed
2010-09-23 13:21 peter-endian Resolution reopened => duplicate

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker